[ia64] nouveau: Disable another bit of ACPI support (fixes FTBFS)

svn path=/dists/trunk/linux/; revision=19709
This commit is contained in:
Ben Hutchings 2013-01-06 04:40:13 +00:00
parent 2243576c5b
commit 4a9bf3378a
2 changed files with 18 additions and 0 deletions

7
debian/changelog vendored
View File

@ -1,3 +1,10 @@
linux (3.7.1-1~experimental.3) UNRELEASED; urgency=low
[ Ben Hutchings ]
* [ia64] nouveau: Disable another bit of ACPI support (fixes FTBFS)
-- Ben Hutchings <ben@decadent.org.uk> Sun, 06 Jan 2013 04:39:12 +0000
linux (3.7.1-1~experimental.2) experimental; urgency=low
[ Ben Hutchings ]

View File

@ -49,3 +49,14 @@ Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
void nouveau_register_dsm_handler(void);
void nouveau_unregister_dsm_handler(void);
void nouveau_switcheroo_optimus_dsm(void);
--- a/drivers/gpu/drm/nouveau/core/subdev/bios/base.c
+++ b/drivers/gpu/drm/nouveau/core/subdev/bios/base.c
@@ -172,7 +172,7 @@ out:
nv_wr32(bios, pcireg, access);
}
-#if defined(CONFIG_ACPI)
+#if defined(CONFIG_ACPI) && defined(CONFIG_X86)
int nouveau_acpi_get_bios_chunk(uint8_t *bios, int offset, int len);
bool nouveau_acpi_rom_supported(struct pci_dev *pdev);
#else