Add debian version information to kernel version string.

* debian/changelog: Update.
* debian/patches-debian/series/2.6.13-1: Add version.patch.
* debian/patches-debian/version.patch: Add.

svn path=/dists/trunk/linux-2.6/; revision=4189
This commit is contained in:
Bastian Blank 2005-09-14 09:03:26 +00:00
parent 37cbf44c47
commit 49e1c17082
3 changed files with 84 additions and 2 deletions

3
debian/changelog vendored
View File

@ -28,13 +28,14 @@ linux-2.6 (2.6.13-1) UNRELEASED; urgency=low
[ Bastian Blank ]
* Move audit and preempt settings to core config file.
* Fix powerpc configuration.
* Add debian version information to kernel version string.
[ Christian T. Steigies ]
* update m68k.diff for linux-2.6.13
* add m68k-42_dma.patch and m68k-sonic.patch that will be in upstream 2.6.14
(which makes sun3 build fail, needs fixing)
-- Bastian Blank <waldi@debian.org> Mon, 12 Sep 2005 19:01:53 +0000
-- Bastian Blank <waldi@debian.org> Wed, 14 Sep 2005 10:02:21 +0000
linux-2.6 (2.6.12-6) unstable; urgency=high

View File

@ -1,3 +1,4 @@
+ patch-2.6.13.1
+ amd64-int3-fix.patch
+ drivers-ide-dma-blacklist-toshiba.patch
+ drivers-scsi-megaraid_splitup.patch
@ -20,4 +21,4 @@
+ remove-references-to-removed-drivers.patch
+ sparc64-hme-lockup.patch
+ tty-locking-fixes9.patch
+ patch-2.6.13.1
+ version.patch

80
debian/patches-debian/version.patch vendored Normal file
View File

@ -0,0 +1,80 @@
Attach informations from debian/changelog to compile.h.
---
commit 932fa20ce2db25e496f6aedf6f624e939f3dafa8
tree 87ebceaf3f1a47f9fafef53ad36510fab9cf3d5f
parent 05dbb1e557b392c8cef3675b4ba6497794ad4124
author Bastian Blank <waldi@debian.org> Tue, 13 Sep 2005 22:03:33 +0000
committer Bastian Blank <waldi@debian.org> Tue, 13 Sep 2005 22:03:33 +0000
scripts/mkcompile_h | 13 +++++++++++++
1 files changed, 13 insertions(+), 0 deletions(-)
diff --git a/scripts/mkcompile_h b/scripts/mkcompile_h
--- a/scripts/mkcompile_h
+++ b/scripts/mkcompile_h
@@ -55,6 +55,19 @@ UTS_TRUNCATE="sed -e s/\(.\{1,$UTS_LEN\}
fi
echo \#define LINUX_COMPILER \"`$CC -v 2>&1 | tail -n 1`\"
+
+ if [ -e debian/changelog ]; then
+ DISTRIBUTION=$(lsb_release -is 2>/dev/null)
+ [ "$DISTRIBUTION" ] || DISTRIBUTION=Debian
+ MAINTAINER=$(dpkg-parsechangelog | sed -ne 's,^Maintainer: .[^<]*<\([^>]*\)>,\1,p')
+ VERSION=$(dpkg-parsechangelog | awk '/^Version:/ {print $$2}')
+ echo \#define LINUX_COMPILE_SYSTEM_DISTRIBUTION \"$DISTRIBUTION\"
+ echo \#define LINUX_COMPILE_SYSTEM_MAINTAINER \"$MAINTAINER\"
+ echo \#define LINUX_COMPILE_SYSTEM_VERSION \"$VERSION\"
+ if [ -e debian/official ]; then
+ echo \#define LINUX_COMPILE_SYSTEM_OFFICIAL
+ fi
+ fi
) > .tmpcompile
# Only replace the real compile.h if the new one is different,
!-------------------------------------------------------------flip-
Use debian packaging informations in version string.
---
commit f9117a71c91d355243befb1a24bc557ea5d98e5b
tree 30e508720f0783c2a93b9103edd5e710f81f7f34
parent 932fa20ce2db25e496f6aedf6f624e939f3dafa8
author Bastian Blank <waldi@debian.org> Tue, 13 Sep 2005 22:04:14 +0000
committer Bastian Blank <waldi@debian.org> Tue, 13 Sep 2005 22:04:14 +0000
init/version.c | 14 ++++++++++++--
1 files changed, 12 insertions(+), 2 deletions(-)
diff --git a/init/version.c b/init/version.c
--- a/init/version.c
+++ b/init/version.c
@@ -29,5 +29,15 @@ struct new_utsname system_utsname = {
EXPORT_SYMBOL(system_utsname);
const char linux_banner[] =
- "Linux version " UTS_RELEASE " (" LINUX_COMPILE_BY "@"
- LINUX_COMPILE_HOST ") (" LINUX_COMPILER ") " UTS_VERSION "\n";
+ "Linux version " UTS_RELEASE " "
+#ifdef LINUX_COMPILE_SYSTEM_OFFICIAL
+ "(" LINUX_COMPILE_SYSTEM_DISTRIBUTION " "
+ LINUX_COMPILE_SYSTEM_VERSION ") "
+ "(" LINUX_COMPILE_SYSTEM_MAINTAINER ") "
+#else
+# ifdef LINUX_COMPILE_SYSTEM_VERSION
+ "(" LINUX_COMPILE_SYSTEM_VERSION ") "
+# endif
+ "(" LINUX_COMPILE_BY "@" LINUX_COMPILE_HOST ") "
+#endif
+ "(" LINUX_COMPILER ") " UTS_VERSION "\n";
!-------------------------------------------------------------flip-