aufs: Update support patchest to aufs4.8-20161010 (no functional change)

This commit is contained in:
Ben Hutchings 2016-10-11 20:02:43 +01:00
parent 387dbb7803
commit 49bfd9c5b2
4 changed files with 75 additions and 74 deletions

1
debian/changelog vendored
View File

@ -26,6 +26,7 @@ linux (4.8.1-1~exp1) UNRELEASED; urgency=medium
* bug script: Optionally use sudo to read a restricted kernel log, and fall
back to writing a placeholder
* [rt] Update to 4.8-rt1 and re-enable
* aufs: Update support patchest to aufs4.8-20161010 (no functional change)
-- Ben Hutchings <ben@decadent.org.uk> Sat, 01 Oct 2016 21:51:33 +0100

View File

@ -1,18 +1,18 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Sat Jul 30 20:52:25 2016 +0900
Subject: aufs4.7 base patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/30de7bf869b468b78f91a856323a5f0d2225a186
Date: Tue Oct 4 03:30:06 2016 +0900
Subject: aufs4.8 base patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/e9fd128dcb16167417683e199a5feb14f3c9eca8
Bug-Debian: https://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs4/gen-patch
aufs4.7 base patch
aufs4.8 base patch
diff --git a/MAINTAINERS b/MAINTAINERS
index 8c20323..d170184 100644
index f593300..8a17054 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -2213,6 +2213,19 @@ F: include/linux/audit.h
@@ -2256,6 +2256,19 @@ F: include/linux/audit.h
F: include/uapi/linux/audit.h
F: kernel/audit*
@ -33,10 +33,10 @@ index 8c20323..d170184 100644
M: Miguel Ojeda Sandonis <miguel.ojeda.sandonis@gmail.com>
W: http://miguelojeda.es/auxdisplay.htm
diff --git a/drivers/block/loop.c b/drivers/block/loop.c
index 1fa8cc2..7339e65 100644
index c9f2107..005e292 100644
--- a/drivers/block/loop.c
+++ b/drivers/block/loop.c
@@ -712,6 +712,24 @@ static inline int is_loop_device(struct file *file)
@@ -701,6 +701,24 @@ static inline int is_loop_device(struct file *file)
return i && S_ISBLK(i->i_mode) && MAJOR(i->i_rdev) == LOOP_MAJOR;
}
@ -62,10 +62,10 @@ index 1fa8cc2..7339e65 100644
static ssize_t loop_attr_show(struct device *dev, char *page,
diff --git a/fs/dcache.c b/fs/dcache.c
index d6847d7..c3c0b6d 100644
index 5c7cc95..df0268c 100644
--- a/fs/dcache.c
+++ b/fs/dcache.c
@@ -1202,7 +1202,7 @@ enum d_walk_ret {
@@ -1164,7 +1164,7 @@ enum d_walk_ret {
*
* The @enter() and @finish() callbacks are called with d_lock held.
*/
@ -97,10 +97,10 @@ index 350a2c8..6f42279 100644
return error;
diff --git a/fs/inode.c b/fs/inode.c
index 4ccbc21..aa6d071 100644
index 7e3ef3a..675fe84 100644
--- a/fs/inode.c
+++ b/fs/inode.c
@@ -1591,7 +1591,7 @@ EXPORT_SYMBOL(generic_update_time);
@@ -1593,7 +1593,7 @@ EXPORT_SYMBOL(generic_update_time);
* This does the actual work of updating an inodes time or version. Must have
* had called mnt_want_write() before calling this.
*/
@ -110,7 +110,7 @@ index 4ccbc21..aa6d071 100644
int (*update_time)(struct inode *, struct timespec *, int);
diff --git a/fs/read_write.c b/fs/read_write.c
index 933b53a..2d13282 100644
index 66215a7..a1da117 100644
--- a/fs/read_write.c
+++ b/fs/read_write.c
@@ -515,6 +515,28 @@ ssize_t __vfs_write(struct file *file, const char __user *p, size_t count,
@ -183,10 +183,10 @@ index 7444f5f..bdac0be 100644
static inline void fput_light(struct file *file, int fput_needed)
{
diff --git a/include/linux/fs.h b/include/linux/fs.h
index dd28814..b689a48 100644
index 901e25d..a71aa9e 100644
--- a/include/linux/fs.h
+++ b/include/linux/fs.h
@@ -1306,6 +1306,7 @@ extern void fasync_free(struct fasync_struct *);
@@ -1275,6 +1275,7 @@ extern void fasync_free(struct fasync_struct *);
/* can be called from interrupts */
extern void kill_fasync(struct fasync_struct **, int, int);
@ -194,7 +194,7 @@ index dd28814..b689a48 100644
extern void __f_setown(struct file *filp, struct pid *, enum pid_type, int force);
extern void f_setown(struct file *filp, unsigned long arg, int force);
extern void f_delown(struct file *filp);
@@ -1690,6 +1691,7 @@ struct file_operations {
@@ -1699,6 +1700,7 @@ struct file_operations {
ssize_t (*sendpage) (struct file *, struct page *, int, size_t, loff_t *, int);
unsigned long (*get_unmapped_area)(struct file *, unsigned long, unsigned long, unsigned long, unsigned long);
int (*check_flags)(int);
@ -202,7 +202,7 @@ index dd28814..b689a48 100644
int (*flock) (struct file *, int, struct file_lock *);
ssize_t (*splice_write)(struct pipe_inode_info *, struct file *, loff_t *, size_t, unsigned int);
ssize_t (*splice_read)(struct file *, loff_t *, struct pipe_inode_info *, size_t, unsigned int);
@@ -1750,6 +1752,12 @@ ssize_t rw_copy_check_uvector(int type, const struct iovec __user * uvector,
@@ -1759,6 +1761,12 @@ ssize_t rw_copy_check_uvector(int type, const struct iovec __user * uvector,
struct iovec *fast_pointer,
struct iovec **ret_pointer);
@ -215,7 +215,7 @@ index dd28814..b689a48 100644
extern ssize_t __vfs_read(struct file *, char __user *, size_t, loff_t *);
extern ssize_t __vfs_write(struct file *, const char __user *, size_t, loff_t *);
extern ssize_t vfs_read(struct file *, char __user *, size_t, loff_t *);
@@ -2105,6 +2113,7 @@ extern int current_umask(void);
@@ -2123,6 +2131,7 @@ extern int current_umask(void);
extern void ihold(struct inode * inode);
extern void iput(struct inode *);
extern int generic_update_time(struct inode *, struct timespec *, int);

View File

@ -1,18 +1,18 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Sat Jul 30 20:52:25 2016 +0900
Subject: aufs4.7 mmap patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/30de7bf869b468b78f91a856323a5f0d2225a186
Date: Tue Oct 4 03:30:06 2016 +0900
Subject: aufs4.8 mmap patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/e9fd128dcb16167417683e199a5feb14f3c9eca8
Bug-Debian: https://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs4/gen-patch
aufs4.7 mmap patch
aufs4.8 mmap patch
diff --git a/fs/proc/base.c b/fs/proc/base.c
index a11eb71..8f10865 100644
index ac0df4d..42255e5 100644
--- a/fs/proc/base.c
+++ b/fs/proc/base.c
@@ -1939,7 +1939,7 @@ static int map_files_get_link(struct dentry *dentry, struct path *path)
@@ -1938,7 +1938,7 @@ static int map_files_get_link(struct dentry *dentry, struct path *path)
down_read(&mm->mmap_sem);
vma = find_exact_vma(mm, vm_start, vm_end);
if (vma && vma->vm_file) {
@ -38,7 +38,7 @@ index f8595e8..cb8eda0 100644
ino = inode->i_ino;
}
diff --git a/fs/proc/task_mmu.c b/fs/proc/task_mmu.c
index 4648c7f..061cb85 100644
index f6fa99e..2750949 100644
--- a/fs/proc/task_mmu.c
+++ b/fs/proc/task_mmu.c
@@ -298,7 +298,10 @@ show_map_vma(struct seq_file *m, struct vm_area_struct *vma, int is_pid)
@ -53,7 +53,7 @@ index 4648c7f..061cb85 100644
dev = inode->i_sb->s_dev;
ino = inode->i_ino;
pgoff = ((loff_t)vma->vm_pgoff) << PAGE_SHIFT;
@@ -1624,7 +1627,7 @@ static int show_numa_map(struct seq_file *m, void *v, int is_pid)
@@ -1634,7 +1637,7 @@ static int show_numa_map(struct seq_file *m, void *v, int is_pid)
struct proc_maps_private *proc_priv = &numa_priv->proc_maps;
struct vm_area_struct *vma = v;
struct numa_maps *md = &numa_priv->md;
@ -79,10 +79,10 @@ index faacb0c..17b43be 100644
ino = inode->i_ino;
pgoff = (loff_t)vma->vm_pgoff << PAGE_SHIFT;
diff --git a/include/linux/mm.h b/include/linux/mm.h
index ece042d..1e24513 100644
index ef815b9..a772481 100644
--- a/include/linux/mm.h
+++ b/include/linux/mm.h
@@ -1239,6 +1239,28 @@ static inline int fixup_user_fault(struct task_struct *tsk,
@@ -1278,6 +1278,28 @@ static inline int fixup_user_fault(struct task_struct *tsk,
}
#endif
@ -112,10 +112,10 @@ index ece042d..1e24513 100644
extern int access_remote_vm(struct mm_struct *mm, unsigned long addr,
void *buf, int len, int write);
diff --git a/include/linux/mm_types.h b/include/linux/mm_types.h
index ca3e517..10bc491 100644
index 903200f..55fc528 100644
--- a/include/linux/mm_types.h
+++ b/include/linux/mm_types.h
@@ -274,6 +274,7 @@ struct vm_region {
@@ -275,6 +275,7 @@ struct vm_region {
unsigned long vm_top; /* region allocated to here */
unsigned long vm_pgoff; /* the offset in vm_file corresponding to vm_start */
struct file *vm_file; /* the backing file or NULL */
@ -123,7 +123,7 @@ index ca3e517..10bc491 100644
int vm_usage; /* region usage count (access under nommu_region_sem) */
bool vm_icache_flushed : 1; /* true if the icache has been flushed for
@@ -348,6 +349,7 @@ struct vm_area_struct {
@@ -349,6 +350,7 @@ struct vm_area_struct {
unsigned long vm_pgoff; /* Offset (within vm_file) in PAGE_SIZE
units */
struct file * vm_file; /* File we map to (can be NULL). */
@ -132,10 +132,10 @@ index ca3e517..10bc491 100644
#ifndef CONFIG_MMU
diff --git a/kernel/fork.c b/kernel/fork.c
index 4a7ec0c..8c8f7ac 100644
index beb3172..ad4cfa8 100644
--- a/kernel/fork.c
+++ b/kernel/fork.c
@@ -479,7 +479,7 @@ static int dup_mmap(struct mm_struct *mm, struct mm_struct *oldmm)
@@ -477,7 +477,7 @@ static int dup_mmap(struct mm_struct *mm, struct mm_struct *oldmm)
struct inode *inode = file_inode(file);
struct address_space *mapping = file->f_mapping;
@ -145,10 +145,10 @@ index 4a7ec0c..8c8f7ac 100644
atomic_dec(&inode->i_writecount);
i_mmap_lock_write(mapping);
diff --git a/mm/Makefile b/mm/Makefile
index 78c6f7d..aea4230 100644
index 2ca1faf..6b9da3f 100644
--- a/mm/Makefile
+++ b/mm/Makefile
@@ -37,7 +37,7 @@ obj-y := filemap.o mempool.o oom_kill.o \
@@ -40,7 +40,7 @@ obj-y := filemap.o mempool.o oom_kill.o \
mm_init.o mmu_context.o percpu.o slab_common.o \
compaction.o vmacache.o \
interval_tree.o list_lru.o workingset.o \
@ -158,10 +158,10 @@ index 78c6f7d..aea4230 100644
obj-y += init-mm.o
diff --git a/mm/filemap.c b/mm/filemap.c
index 20f3b1f..ee827ce 100644
index 2d0986a..4a31bad 100644
--- a/mm/filemap.c
+++ b/mm/filemap.c
@@ -2208,7 +2208,7 @@ int filemap_page_mkwrite(struct vm_area_struct *vma, struct vm_fault *vmf)
@@ -2284,7 +2284,7 @@ int filemap_page_mkwrite(struct vm_area_struct *vma, struct vm_fault *vmf)
int ret = VM_FAULT_LOCKED;
sb_start_pagefault(inode->i_sb);
@ -171,10 +171,10 @@ index 20f3b1f..ee827ce 100644
if (page->mapping != inode->i_mapping) {
unlock_page(page);
diff --git a/mm/memory.c b/mm/memory.c
index 9e04681..06980d1 100644
index 793fe0f..45f39f3 100644
--- a/mm/memory.c
+++ b/mm/memory.c
@@ -2100,7 +2100,7 @@ static inline int wp_page_reuse(struct mm_struct *mm,
@@ -2113,7 +2113,7 @@ static inline int wp_page_reuse(struct fault_env *fe, pte_t orig_pte,
}
if (!page_mkwrite)
@ -184,10 +184,10 @@ index 9e04681..06980d1 100644
return VM_FAULT_WRITE;
diff --git a/mm/mmap.c b/mm/mmap.c
index de2c176..b7f391c 100644
index ca9d91b..f3ebc5a 100644
--- a/mm/mmap.c
+++ b/mm/mmap.c
@@ -162,7 +162,7 @@ static struct vm_area_struct *remove_vma(struct vm_area_struct *vma)
@@ -163,7 +163,7 @@ static struct vm_area_struct *remove_vma(struct vm_area_struct *vma)
if (vma->vm_ops && vma->vm_ops->close)
vma->vm_ops->close(vma);
if (vma->vm_file)
@ -196,7 +196,7 @@ index de2c176..b7f391c 100644
mpol_put(vma_policy(vma));
kmem_cache_free(vm_area_cachep, vma);
return next;
@@ -782,7 +782,7 @@ again: remove_next = 1 + (end > next->vm_end);
@@ -790,7 +790,7 @@ again:
if (remove_next) {
if (file) {
uprobe_munmap(next, next->vm_start, next->vm_end);
@ -205,7 +205,7 @@ index de2c176..b7f391c 100644
}
if (next->anon_vma)
anon_vma_merge(vma, next);
@@ -1563,8 +1563,8 @@ out:
@@ -1574,8 +1574,8 @@ out:
return addr;
unmap_and_free_vma:
@ -215,7 +215,7 @@ index de2c176..b7f391c 100644
/* Undo any partial mapping done by a device driver. */
unmap_region(mm, vma, prev, vma->vm_start, vma->vm_end);
@@ -2358,7 +2358,7 @@ static int __split_vma(struct mm_struct *mm, struct vm_area_struct *vma,
@@ -2380,7 +2380,7 @@ static int __split_vma(struct mm_struct *mm, struct vm_area_struct *vma,
goto out_free_mpol;
if (new->vm_file)
@ -224,7 +224,7 @@ index de2c176..b7f391c 100644
if (new->vm_ops && new->vm_ops->open)
new->vm_ops->open(new);
@@ -2377,7 +2377,7 @@ static int __split_vma(struct mm_struct *mm, struct vm_area_struct *vma,
@@ -2399,7 +2399,7 @@ static int __split_vma(struct mm_struct *mm, struct vm_area_struct *vma,
if (new->vm_ops && new->vm_ops->close)
new->vm_ops->close(new);
if (new->vm_file)
@ -233,7 +233,7 @@ index de2c176..b7f391c 100644
unlink_anon_vmas(new);
out_free_mpol:
mpol_put(vma_policy(new));
@@ -2528,7 +2528,7 @@ SYSCALL_DEFINE5(remap_file_pages, unsigned long, start, unsigned long, size,
@@ -2550,7 +2550,7 @@ SYSCALL_DEFINE5(remap_file_pages, unsigned long, start, unsigned long, size,
struct vm_area_struct *vma;
unsigned long populate = 0;
unsigned long ret = -EINVAL;
@ -242,7 +242,7 @@ index de2c176..b7f391c 100644
pr_warn_once("%s (%d) uses deprecated remap_file_pages() syscall. See Documentation/vm/remap_file_pages.txt.\n",
current->comm, current->pid);
@@ -2597,10 +2597,27 @@ SYSCALL_DEFINE5(remap_file_pages, unsigned long, start, unsigned long, size,
@@ -2625,10 +2625,27 @@ SYSCALL_DEFINE5(remap_file_pages, unsigned long, start, unsigned long, size,
}
}
@ -271,7 +271,7 @@ index de2c176..b7f391c 100644
out:
up_write(&mm->mmap_sem);
if (populate)
@@ -2873,7 +2890,7 @@ struct vm_area_struct *copy_vma(struct vm_area_struct **vmap,
@@ -2903,7 +2920,7 @@ struct vm_area_struct *copy_vma(struct vm_area_struct **vmap,
if (anon_vma_clone(new_vma, vma))
goto out_free_mempol;
if (new_vma->vm_file)
@ -281,7 +281,7 @@ index de2c176..b7f391c 100644
new_vma->vm_ops->open(new_vma);
vma_link(mm, new_vma, prev, rb_link, rb_parent);
diff --git a/mm/nommu.c b/mm/nommu.c
index c2e588802..c39edc4 100644
index 95daf81..5086a29 100644
--- a/mm/nommu.c
+++ b/mm/nommu.c
@@ -644,7 +644,7 @@ static void __put_nommu_region(struct vm_region *region)

View File

@ -1,18 +1,18 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Sat Jul 30 20:52:25 2016 +0900
Subject: aufs4.7 standalone patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/30de7bf869b468b78f91a856323a5f0d2225a186
Date: Tue Oct 4 03:30:06 2016 +0900
Subject: aufs4.8 standalone patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/e9fd128dcb16167417683e199a5feb14f3c9eca8
Bug-Debian: https://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs4/gen-patch
aufs4.7 standalone patch
aufs4.8 standalone patch
diff --git a/fs/dcache.c b/fs/dcache.c
index c3c0b6d..c99d2d2 100644
index df0268c..76280ee 100644
--- a/fs/dcache.c
+++ b/fs/dcache.c
@@ -1310,6 +1310,7 @@ rename_retry:
@@ -1272,6 +1272,7 @@ rename_retry:
seq = 1;
goto again;
}
@ -21,7 +21,7 @@ index c3c0b6d..c99d2d2 100644
/*
* Search for at least 1 mount point in the dentry's subdirs.
diff --git a/fs/exec.c b/fs/exec.c
index 887c1c9..40e8767 100644
index 6fcfb3f..ed9d646 100644
--- a/fs/exec.c
+++ b/fs/exec.c
@@ -104,6 +104,7 @@ bool path_noexec(const struct path *path)
@ -81,10 +81,10 @@ index ad17e05..ae9f267 100644
void __init files_init(void)
{
diff --git a/fs/inode.c b/fs/inode.c
index aa6d071..f336032 100644
index 675fe84..da063d3 100644
--- a/fs/inode.c
+++ b/fs/inode.c
@@ -1600,6 +1600,7 @@ int update_time(struct inode *inode, struct timespec *time, int flags)
@@ -1602,6 +1602,7 @@ int update_time(struct inode *inode, struct timespec *time, int flags)
return update_time(inode, time, flags);
}
@ -93,7 +93,7 @@ index aa6d071..f336032 100644
/**
* touch_atime - update the access time
diff --git a/fs/namespace.c b/fs/namespace.c
index 419f746..9c0e0af 100644
index 7bb2cda..88ec098 100644
--- a/fs/namespace.c
+++ b/fs/namespace.c
@@ -463,6 +463,7 @@ void __mnt_drop_write(struct vfsmount *mnt)
@ -113,7 +113,7 @@ index 419f746..9c0e0af 100644
static void cleanup_group_ids(struct mount *mnt, struct mount *end)
{
diff --git a/fs/notify/group.c b/fs/notify/group.c
index 3e2dd85..b17cb4b 100644
index b47f7cf..618bc9e 100644
--- a/fs/notify/group.c
+++ b/fs/notify/group.c
@@ -22,6 +22,7 @@
@ -124,7 +124,7 @@ index 3e2dd85..b17cb4b 100644
#include <linux/fsnotify_backend.h>
#include "fsnotify.h"
@@ -81,6 +82,7 @@ void fsnotify_get_group(struct fsnotify_group *group)
@@ -100,6 +101,7 @@ void fsnotify_get_group(struct fsnotify_group *group)
{
atomic_inc(&group->refcnt);
}
@ -132,7 +132,7 @@ index 3e2dd85..b17cb4b 100644
/*
* Drop a reference to a group. Free it if it's through.
@@ -90,6 +92,7 @@ void fsnotify_put_group(struct fsnotify_group *group)
@@ -109,6 +111,7 @@ void fsnotify_put_group(struct fsnotify_group *group)
if (atomic_dec_and_test(&group->refcnt))
fsnotify_final_destroy_group(group);
}
@ -140,7 +140,7 @@ index 3e2dd85..b17cb4b 100644
/*
* Create a new fsnotify_group and hold a reference for the group returned.
@@ -118,6 +121,7 @@ struct fsnotify_group *fsnotify_alloc_group(const struct fsnotify_ops *ops)
@@ -137,6 +140,7 @@ struct fsnotify_group *fsnotify_alloc_group(const struct fsnotify_ops *ops)
return group;
}
@ -185,7 +185,7 @@ index d3fea0b..5fc06ad 100644
/*
* Destroy all marks in destroy_list, waits for SRCU period to finish before
diff --git a/fs/open.c b/fs/open.c
index 93ae3cd..d25b9bd 100644
index 4fd6e25..ec6f532 100644
--- a/fs/open.c
+++ b/fs/open.c
@@ -64,6 +64,7 @@ int do_truncate(struct dentry *dentry, loff_t length, unsigned int time_attrs,
@ -205,7 +205,7 @@ index 93ae3cd..d25b9bd 100644
static int do_dentry_open(struct file *f,
struct inode *inode,
diff --git a/fs/read_write.c b/fs/read_write.c
index 2d13282..260c4a4 100644
index a1da117..c643215 100644
--- a/fs/read_write.c
+++ b/fs/read_write.c
@@ -525,6 +525,7 @@ vfs_readf_t vfs_readf(struct file *file)
@ -245,10 +245,10 @@ index 9326c2a..0606690 100644
/**
* splice_direct_to_actor - splices data directly between two non-pipes
diff --git a/fs/xattr.c b/fs/xattr.c
index 4beafc4..e118715 100644
index c243905..b60dc60 100644
--- a/fs/xattr.c
+++ b/fs/xattr.c
@@ -207,6 +207,7 @@ vfs_getxattr_alloc(struct dentry *dentry, const char *name, char **xattr_value,
@@ -214,6 +214,7 @@ vfs_getxattr_alloc(struct dentry *dentry, const char *name, char **xattr_value,
*xattr_value = value;
return error;
}
@ -257,19 +257,19 @@ index 4beafc4..e118715 100644
ssize_t
vfs_getxattr(struct dentry *dentry, const char *name, void *value, size_t size)
diff --git a/kernel/task_work.c b/kernel/task_work.c
index 53fa971..bce3211 100644
index d513051..e056d54 100644
--- a/kernel/task_work.c
+++ b/kernel/task_work.c
@@ -118,3 +118,4 @@ void task_work_run(void)
@@ -119,3 +119,4 @@ void task_work_run(void)
} while (work);
}
}
+EXPORT_SYMBOL_GPL(task_work_run);
diff --git a/security/commoncap.c b/security/commoncap.c
index e7fadde..6423e53 100644
index 14540bd..4e3b242 100644
--- a/security/commoncap.c
+++ b/security/commoncap.c
@@ -1058,12 +1058,14 @@ int cap_mmap_addr(unsigned long addr)
@@ -1066,12 +1066,14 @@ int cap_mmap_addr(unsigned long addr)
}
return ret;
}
@ -305,7 +305,7 @@ index 03c1652..f88c84b 100644
int devcgroup_inode_mknod(int mode, dev_t dev)
{
diff --git a/security/security.c b/security/security.c
index 7095693..da7fe2c 100644
index 4838e7f..36c741e 100644
--- a/security/security.c
+++ b/security/security.c
@@ -434,6 +434,7 @@ int security_path_rmdir(const struct path *dir, struct dentry *dentry)
@ -372,7 +372,7 @@ index 7095693..da7fe2c 100644
int security_inode_setattr(struct dentry *dentry, struct iattr *attr)
{
@@ -737,6 +745,7 @@ int security_file_permission(struct file *file, int mask)
@@ -758,6 +766,7 @@ int security_file_permission(struct file *file, int mask)
return fsnotify_perm(file, mask);
}
@ -380,7 +380,7 @@ index 7095693..da7fe2c 100644
int security_file_alloc(struct file *file)
{
@@ -796,6 +805,7 @@ int security_mmap_file(struct file *file, unsigned long prot,
@@ -817,6 +826,7 @@ int security_mmap_file(struct file *file, unsigned long prot,
return ret;
return ima_file_mmap(file, prot);
}