Merge /dists/sid/linux-2.6.

r6084:  waldi | 2006-03-06 11:08:07 +0100
debian/changelog: Prepare to release (2.6.15-8).

svn path=/dists/trunk/linux-2.6/; revision=6086
This commit is contained in:
Bastian Blank 2006-03-06 12:13:55 +00:00
parent 2cecf70f8c
commit 4680af3629
5 changed files with 1368 additions and 3 deletions

61
debian/changelog vendored
View File

@ -24,9 +24,6 @@ linux-2.6 (2.6.15+2.6.16-rc5-0experimental.1) UNRELEASED; urgency=low
- Add Tulip fixes for Cobalt.
* Fix a typo in the description of the linux-doc-* package,
thanks Justin Pryzby. Closes: #343424.
* [powerpc] Disabled CONFIG_IEEE1394_SBP2_PHYS_DMA, which was broken on
powerpc64, as it used the long deprecated bus_to_virt symbol.
(Closes: #330225)
-- Bastian Blank <waldi@debian.org> Mon, 06 Mar 2006 10:40:01 +0100
@ -69,6 +66,64 @@ linux-2.6 (2.6.15+2.6.16-rc4-0experimental.1) experimental; urgency=low
-- Bastian Blank <waldi@debian.org> Fri, 24 Feb 2006 16:02:11 +0000
linux-2.6 (2.6.15-8) unstable; urgency=high
[ maximilian attems ]
* Add stable Release 2.6.15.5:
- Fix deadlock in br_stp_disable_bridge
- Fix a severe bug
- i386: Move phys_proc_id/early intel workaround to correct function
- ramfs: update dir mtime and ctime
- sys_mbind sanity checking
- Fix s390 build failure.
- Revert skb_copy_datagram_iovec() recursion elimination.
- s390: add #ifdef __KERNEL__ to asm-s390/setup.h
- netfilter missing symbol has_bridge_parent
- hugetlbfs mmap ENOMEM failure
- IB/mthca: max_inline_data handling tweaks
- it87: Fix oops on removal
- hwmon it87: Probe i2c 0x2d only
- reiserfs: disable automatic enabling of reiserfs inode attributes
- Fix snd-usb-audio in 32-bit compat environment
- dm: missing bdput/thaw_bdev at removal
- dm: free minor after unlink gendisk
- gbefb: IP32 gbefb depth change fix
- shmdt cannot detach not-alined shm segment cleanly.
- Address autoconfiguration does not work after device down/up cycle
- gbefb: Set default of FB_GBE_MEM to 4 MB
- XFS ftruncate() bug could expose stale data (CVE-2006-0554)
- sys_signal: initialize ->sa_mask
- do_sigaction: cleanup ->sa_mask manipulation
- fix zap_thread's ptrace related problems
- fix deadlock in ext2
- cfi: init wait queue in chip struct
- sd: fix memory corruption with broken mode page headers
- sbp2: fix another deadlock after disconnection
- skge: speed setting
- skge: fix NAPI/irq race
- skge: genesis phy initialization fix
- skge: fix SMP race
- x86_64: Check for bad elf entry address (CVE-2006-0741)
- alsa: fix bogus snd_device_free() in opl3-oss.c
- ppc32: Put cache flush routines back into .relocate_code section
- sys32_signal() forgets to initialize ->sa_mask
- Normal user can panic NFS client with direct I/O (CVE-2006-0555)
* Deactivate merged duplicates: s390-klibc-buildfix.patch,
powerpc-relocate_code.patch.
* Add stable Release 2.6.15.6:
- Don't reset rskq_defer_accept in reqsk_queue_alloc
- fs/nfs/direct.c compile fix
- mempolicy.c compile fix, make sure BITS_PER_BYTE is defined
- [IA64] die_if_kernel() can return (CVE-2006-0742)
[ Sven Luther ]
* [powerpc] Disabled CONFIG_IEEE1394_SBP2_PHYS_DMA, which was broken on
powerpc64, as it used the long deprecated bus_to_virt symbol.
(Closes: #330225)
* [powerpc] Fixed gettimeofday breakage causing clock drift.
-- Bastian Blank <waldi@debian.org> Mon, 6 Mar 2006 11:06:28 +0100
linux-2.6 (2.6.15-7) unstable; urgency=low
[ Norbert Tretkowski ]

1213
debian/patches/2.6.15.5.patch vendored Normal file

File diff suppressed because it is too large Load Diff

67
debian/patches/2.6.15.6.patch vendored Normal file
View File

@ -0,0 +1,67 @@
diff --git a/arch/ia64/kernel/unaligned.c b/arch/ia64/kernel/unaligned.c
index 43b45b6..f2bc971 100644
--- a/arch/ia64/kernel/unaligned.c
+++ b/arch/ia64/kernel/unaligned.c
@@ -24,7 +24,7 @@
#include <asm/uaccess.h>
#include <asm/unaligned.h>
-extern void die_if_kernel(char *str, struct pt_regs *regs, long err) __attribute__ ((noreturn));
+extern void die_if_kernel(char *str, struct pt_regs *regs, long err);
#undef DEBUG_UNALIGNED_TRAP
diff --git a/fs/nfs/direct.c b/fs/nfs/direct.c
index 3ebb06e..96c104b 100644
--- a/fs/nfs/direct.c
+++ b/fs/nfs/direct.c
@@ -57,6 +57,7 @@
#define NFSDBG_FACILITY NFSDBG_VFS
#define MAX_DIRECTIO_SIZE (4096UL << PAGE_SHIFT)
+static void nfs_free_user_pages(struct page **pages, int npages, int do_dirty);
static kmem_cache_t *nfs_direct_cachep;
/*
@@ -106,12 +107,16 @@ nfs_get_user_pages(int rw, unsigned long
result = get_user_pages(current, current->mm, user_addr,
page_count, (rw == READ), 0,
*pages, NULL);
+ up_read(&current->mm->mmap_sem);
+ /*
+ * If we got fewer pages than expected from get_user_pages(),
+ * the user buffer runs off the end of a mapping; return EFAULT.
+ */
if (result >= 0 && result < page_count) {
nfs_free_user_pages(*pages, result, 0);
*pages = NULL;
result = -EFAULT;
}
- up_read(&current->mm->mmap_sem);
}
return result;
}
diff --git a/include/linux/types.h b/include/linux/types.h
index 21b9ce8..f5a4572 100644
--- a/include/linux/types.h
+++ b/include/linux/types.h
@@ -8,6 +8,7 @@
(((bits)+BITS_PER_LONG-1)/BITS_PER_LONG)
#define DECLARE_BITMAP(name,bits) \
unsigned long name[BITS_TO_LONGS(bits)]
+#define BITS_PER_BYTE 8
#endif
#include <linux/posix_types.h>
diff --git a/net/core/request_sock.c b/net/core/request_sock.c
index b8203de..98f0fc9 100644
--- a/net/core/request_sock.c
+++ b/net/core/request_sock.c
@@ -52,7 +52,6 @@ int reqsk_queue_alloc(struct request_soc
get_random_bytes(&lopt->hash_rnd, sizeof(lopt->hash_rnd));
rwlock_init(&queue->syn_wait_lock);
queue->rskq_accept_head = queue->rskq_accept_head = NULL;
- queue->rskq_defer_accept = 0;
lopt->nr_table_entries = nr_table_entries;
write_lock_bh(&queue->syn_wait_lock);

View File

@ -0,0 +1,25 @@
A bug in the assembly code of the vdso can cause gettimeofday() to hang
or to return incorrect results. The wrong register was used to test for
pending updates of the calibration variables and to create a dependency
for subsequent loads. This fixes it.
Signed-off-by: Benjamin Herrenschmidt <benh@kernel.crashing.org>
---
Might be worth applying to the stable series too and/or distro kernels
2.6.15 and later
--- linux-work.orig/arch/powerpc/kernel/vdso64/gettimeofday.S 2006-02-26 08:02:57.000000000 +1100
+++ linux-work/arch/powerpc/kernel/vdso64/gettimeofday.S 2006-02-26 08:04:23.000000000 +1100
@@ -225,9 +225,9 @@
.cfi_startproc
/* check for update count & load values */
1: ld r8,CFG_TB_UPDATE_COUNT(r3)
- andi. r0,r4,1 /* pending update ? loop */
+ andi. r0,r8,1 /* pending update ? loop */
bne- 1b
- xor r0,r4,r4 /* create dependency */
+ xor r0,r8,r8 /* create dependency */
add r3,r3,r0
/* Get TB & offset it */

5
debian/patches/series/8 vendored Normal file
View File

@ -0,0 +1,5 @@
- s390-klibc-buildfix.patch
- powerpc-relocate_code.patch
+ 2.6.15.5.patch
+ 2.6.15.6.patch
+ powerpc-vsod-timeshift.patch