aufs: Update to aufs3.x-rcN-20140120

svn path=/dists/trunk/linux/; revision=20988
This commit is contained in:
Ben Hutchings 2014-01-20 03:35:11 +00:00
parent d74cf87418
commit 4652cd45e1
6 changed files with 305 additions and 308 deletions

2
debian/changelog vendored
View File

@ -6,6 +6,8 @@ linux (3.13-1~exp1) UNRELEASED; urgency=low
* [armhf] xen/pci: Fix build on non-x86
* [hppa/parisc64-smp] Disable MLONGCALLS (Closes: #733897)
* [armel] Remove iop32x flavour (fixes FTBFS)
* aufs: Update to aufs3.x-rcN-20140120
- bugfix, removed /proc/PID/fd/N
[ Bastian Blank ]
* Initial Python 3 support:

File diff suppressed because it is too large Load Diff

View File

@ -1,7 +1,7 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Wed Dec 18 12:37:33 2013 +0900
Subject: aufs3.x-rcN base patch
Origin: http://sourceforge.net/p/aufs/aufs3-standalone/ci/7b136a27b021da9010d8b6c101939dd298e46be7/tree/
Origin: http://sourceforge.net/p/aufs/aufs3-standalone/ci/94b50bae2118905dca9c63eaa7f29c322ce155d6/tree/
Bug-Debian: http://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs3/gen-patch

View File

@ -1,7 +1,7 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Wed Dec 18 12:37:33 2013 +0900
Subject: aufs3.x-rcN kbuild patch
Origin: http://sourceforge.net/p/aufs/aufs3-standalone/ci/7b136a27b021da9010d8b6c101939dd298e46be7/tree/
Origin: http://sourceforge.net/p/aufs/aufs3-standalone/ci/94b50bae2118905dca9c63eaa7f29c322ce155d6/tree/
Bug-Debian: http://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs3/gen-patch

View File

@ -1,16 +1,13 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Wed Dec 18 12:37:33 2013 +0900
Date: Thu Jan 9 15:51:36 2014 +0900
Subject: aufs3.x-rcN mmap patch
Origin: http://sourceforge.net/p/aufs/aufs3-standalone/ci/7b136a27b021da9010d8b6c101939dd298e46be7/tree/
Origin: http://sourceforge.net/p/aufs/aufs3-standalone/ci/94b50bae2118905dca9c63eaa7f29c322ce155d6/tree/
Bug-Debian: http://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs3/gen-patch
aufs3.x-rcN mmap patch
[bwh: Resolved conflict with commit 4eb919825e6c ('mm: fix use-after-free
in sys_remap_file_pages')]
diff --git a/fs/buffer.c b/fs/buffer.c
index 6024877..95bbf13 100644
--- a/fs/buffer.c
@ -78,7 +75,7 @@ index 678455d..ad0ce45 100644
ino = inode->i_ino;
pgoff = (loff_t)vma->vm_pgoff << PAGE_SHIFT;
diff --git a/include/linux/mm.h b/include/linux/mm.h
index 1cedd00..a31519b 100644
index 3552717..3c5a972 100644
--- a/include/linux/mm.h
+++ b/include/linux/mm.h
@@ -17,6 +17,9 @@
@ -180,10 +177,10 @@ index 1cedd00..a31519b 100644
extern int access_remote_vm(struct mm_struct *mm, unsigned long addr,
void *buf, int len, int write);
diff --git a/include/linux/mm_types.h b/include/linux/mm_types.h
index bd29941..b5c6151 100644
index 290901a..c21588b 100644
--- a/include/linux/mm_types.h
+++ b/include/linux/mm_types.h
@@ -230,6 +230,7 @@ struct vm_region {
@@ -231,6 +231,7 @@ struct vm_region {
unsigned long vm_top; /* region allocated to here */
unsigned long vm_pgoff; /* the offset in vm_file corresponding to vm_start */
struct file *vm_file; /* the backing file or NULL */
@ -191,7 +188,7 @@ index bd29941..b5c6151 100644
int vm_usage; /* region usage count (access under nommu_region_sem) */
bool vm_icache_flushed : 1; /* true if the icache has been flushed for
@@ -298,6 +299,7 @@ struct vm_area_struct {
@@ -299,6 +300,7 @@ struct vm_area_struct {
unsigned long vm_pgoff; /* Offset (within vm_file) in PAGE_SIZE
units, *not* PAGE_CACHE_SIZE */
struct file * vm_file; /* File we map to (can be NULL). */
@ -200,7 +197,7 @@ index bd29941..b5c6151 100644
#ifndef CONFIG_MMU
diff --git a/kernel/fork.c b/kernel/fork.c
index 728d5be..4e4344e 100644
index 5721f0e..ae597af 100644
--- a/kernel/fork.c
+++ b/kernel/fork.c
@@ -412,7 +412,7 @@ static int dup_mmap(struct mm_struct *mm, struct mm_struct *oldmm)
@ -226,25 +223,19 @@ index b7749a9..a6693ca 100644
if (page->mapping != inode->i_mapping) {
unlock_page(page);
diff --git a/mm/fremap.c b/mm/fremap.c
index 5bff081..246a9c7 100644
index bbc4d66..7deee2c 100644
--- a/mm/fremap.c
+++ b/mm/fremap.c
@@ -207,12 +207,13 @@ get_write_lock:
*/
if (mapping_cap_account_dirty(mapping)) {
unsigned long addr;
- struct file *file = get_file(vma->vm_file);
+ struct file *file = vma->vm_file;
@@ -211,7 +211,9 @@ get_write_lock:
/* mmap_region may free vma; grab the info now */
vm_flags = vma->vm_flags;
+ vma_get_file(vma);
addr = mmap_region(file, start, size, vm_flags, pgoff);
- fput(file);
+ vma_fput(vma);
fput(file);
if (IS_ERR_VALUE(addr)) {
err = addr;
} else {
diff --git a/mm/madvise.c b/mm/madvise.c
index 539eeb9..5e700b1 100644
--- a/mm/madvise.c
@ -265,7 +256,7 @@ index 539eeb9..5e700b1 100644
return error;
}
diff --git a/mm/memory.c b/mm/memory.c
index 5d9025f..3e3c5d5 100644
index 6768ce9..22d2cec 100644
--- a/mm/memory.c
+++ b/mm/memory.c
@@ -2752,7 +2752,7 @@ reuse:

View File

@ -1,7 +1,7 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Wed Dec 18 12:37:33 2013 +0900
Subject: aufs3.x-rcN standalone patch
Origin: http://sourceforge.net/p/aufs/aufs3-standalone/ci/7b136a27b021da9010d8b6c101939dd298e46be7/tree/
Origin: http://sourceforge.net/p/aufs/aufs3-standalone/ci/94b50bae2118905dca9c63eaa7f29c322ce155d6/tree/
Bug-Debian: http://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs3/gen-patch