Update to 3.9.7

svn path=/dists/sid/linux/; revision=20283
This commit is contained in:
Ben Hutchings 2013-06-23 15:55:26 +00:00
parent 7459ea3b2b
commit 46013cc609
4 changed files with 24 additions and 37 deletions

22
debian/changelog vendored
View File

@ -1,5 +1,25 @@
linux (3.9.6-2) UNRELEASED; urgency=low
linux (3.9.7-1) UNRELEASED; urgency=low
* New upstream stable update:
http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.9.7
- b43: stop format string leaking into error msgs (CVE-2013-2852)
- ACPI / video: Do not bind to device objects with a scan handler
- libceph: must hold mutex for reset_changed_osds()
- ceph: ceph_pagelist_append might sleep while atomic
- rbd: don't destroy ceph_opts in rbd_add()
- Bluetooth: Fix missing length checks for L2CAP signalling PDUs
- kmsg: honor dmesg_restrict sysctl on /dev/kmsg
- memcg: don't initialize kmem-cache destroying work for root caches
- md/raid1: consider WRITE as successful only if at least one non-Faulty
and non-rebuilding drive completed it.
- md/raid1,5,10: Disable WRITE SAME until a recovery strategy is in place
- [x86] Modify UEFI anti-bricking code
- powerpc: Fix stack overflow crash in resume_kernel when ftracing
- USB: pl2303: fix device initialisation at open
- USB: f81232: fix device initialisation at open
- USB: spcp8x5: fix device initialisation at open
[ Ben Hutchings ]
* yama: Disable ptrace restrictions by default, and change boot message
to indicate this (Closes: #712740)

View File

@ -1,32 +0,0 @@
From: Sujith Manoharan <c_manoha@qca.qualcomm.com>
Date: Sat, 1 Jun 2013 07:08:09 +0530
Subject: ath9k: Disable PowerSave by default
commit 73c79617596b89a3693ff0d89d42bcd5ddedcf15 upstream.
Almost all the DMA issues which have plagued ath9k (in station mode)
for years are related to PS. Disabling PS usually "fixes" the user's
connection stablility. Reports of DMA problems are still trickling in
and are sitting in the kernel bugzilla. Until the PS code in ath9k is
given a thorough review, disbale it by default. The slight increase
in chip power consumption is a small price to pay for improved link
stability.
Signed-off-by: Sujith Manoharan <c_manoha@qca.qualcomm.com>
Signed-off-by: John W. Linville <linville@tuxdriver.com>
---
drivers/net/wireless/ath/ath9k/init.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
--- a/drivers/net/wireless/ath/ath9k/init.c
+++ b/drivers/net/wireless/ath/ath9k/init.c
@@ -766,8 +766,7 @@ void ath9k_set_hw_capab(struct ath_softc
hw->wiphy->iface_combinations = &if_comb;
hw->wiphy->n_iface_combinations = 1;
- if (AR_SREV_5416(sc->sc_ah))
- hw->wiphy->flags &= ~WIPHY_FLAG_PS_ON_BY_DEFAULT;
+ hw->wiphy->flags &= ~WIPHY_FLAG_PS_ON_BY_DEFAULT;
hw->wiphy->flags |= WIPHY_FLAG_IBSS_RSN;
hw->wiphy->flags |= WIPHY_FLAG_SUPPORTS_TDLS;

View File

@ -15,15 +15,15 @@ are available. This should trigger udev to load it.
---
--- a/arch/x86/platform/efi/efi.c
+++ b/arch/x86/platform/efi/efi.c
@@ -42,6 +42,7 @@
@@ -41,6 +41,7 @@
#include <linux/io.h>
#include <linux/reboot.h>
#include <linux/bcd.h>
#include <linux/ucs2_string.h>
+#include <linux/platform_device.h>
#include <asm/setup.h>
#include <asm/efi.h>
@@ -870,6 +871,20 @@ void __init efi_late_init(void)
@@ -773,6 +774,20 @@ void __init efi_late_init(void)
efi_bgrt_init();
}

View File

@ -104,7 +104,6 @@ features/arm/imx53-qsb-usb-power.patch
features/arm/0001-thermal-Add-driver-for-Armada-370-XP-SoC-thermal-man.patch
features/arm/0001-ARM-mvebu-Add-thermal-support-to-Armada-XP-device-tr.patch
bugfix/all/ath9k-Disable-PowerSave-by-default.patch
bugfix/x86/viafb-autoload-on-olpc-xo1.5-only.patch
debian/powerpc-machdep-avoid-abi-change-in-3.9.6.patch
debian/yama-disable-by-default.patch