drm/nouveau/pmu: do not assume a PMU is present (Closes: #809481)

This commit is contained in:
Ben Hutchings 2016-01-01 18:41:43 +00:00
parent d9ebd74365
commit 45e2ecad07
3 changed files with 31 additions and 0 deletions

1
debian/changelog vendored
View File

@ -13,6 +13,7 @@ linux (4.3.3-3) UNRELEASED; urgency=medium
* KEYS: Fix race between read and revoke (CVE-2015-7550)
* [armhf] udeb: Add modular clock, GPIO, PHY and regulator drivers to
core-modules (Closes: #809521)
* drm/nouveau/pmu: do not assume a PMU is present (Closes: #809481)
[ Salvatore Bonaccorso ]
* ovl: fix permission checking for setattr (CVE-2015-8660)

View File

@ -0,0 +1,29 @@
From: Alexandre Courbot <acourbot@nvidia.com>
Date: Thu, 3 Sep 2015 17:39:52 +0900
Subject: drm/nouveau/pmu: do not assume a PMU is present
Origin: https://git.kernel.org/linus/579b7c58215329803ce184704463de09f0f310ac
Bug-Debian: https://bugs.debian.org/809481
Some devices may not have a PMU. Avoid a NULL pointer dereference in
such cases by checking whether the pointer given to nvkm_pmu_pgob() is
valid.
Signed-off-by: Alexandre Courbot <acourbot@nvidia.com>
Signed-off-by: Ben Skeggs <bskeggs@redhat.com>
---
drivers/gpu/drm/nouveau/nvkm/subdev/pmu/base.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/gpu/drm/nouveau/nvkm/subdev/pmu/base.c b/drivers/gpu/drm/nouveau/nvkm/subdev/pmu/base.c
index 27a79c0..d95eb86 100644
--- a/drivers/gpu/drm/nouveau/nvkm/subdev/pmu/base.c
+++ b/drivers/gpu/drm/nouveau/nvkm/subdev/pmu/base.c
@@ -28,7 +28,7 @@
void
nvkm_pmu_pgob(struct nvkm_pmu *pmu, bool enable)
{
- if (pmu->func->pgob)
+ if (pmu && pmu->func->pgob)
pmu->func->pgob(pmu, enable);
}

View File

@ -128,3 +128,4 @@ bugfix/all/xen-pciback-don-t-allow-msi-x-ops-if-pci_command_mem.patch
bugfix/all/ptrace-being-capable-wrt-a-process-requires-mapped-uids-gids.patch
bugfix/all/keys-fix-race-between-read-and-revoke.patch
bugfix/x86/KVM-x86-Reload-pit-counters-for-all-channels-when-re.patch
bugfix/all/drm-nouveau-pmu-do-not-assume-a-pmu-is-present.patch