hyperv-daemons: Fix fortify format warning

This commit is contained in:
Ben Hutchings 2015-09-25 20:32:34 +01:00
parent 5b5133ebf7
commit 4555b9e92e
3 changed files with 56 additions and 0 deletions

1
debian/changelog vendored
View File

@ -9,6 +9,7 @@ linux-tools (4.2-1) UNRELEASED; urgency=medium
* linux-perf: Fix installation directory for bash completions
* linux-perf: Remove shebang lines from perf scripts
* Set compiler flags according to dpkg-buildflags
* hyperv-daemons: Fix fortify format warning
-- Ben Hutchings <ben@decadent.org.uk> Fri, 25 Sep 2015 18:42:20 +0100

View File

@ -13,3 +13,4 @@ lockdep-fix-soname.patch
tools-perf-remove-shebangs.patch
tools-lib-traceevent-use-ldflags.patch
tools-lib-lockdep-use-ldflags.patch
tools-hv-fix-fortify-format-warning.patch

View File

@ -0,0 +1,54 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Fri, 25 Sep 2015 20:28:10 +0100
Subject: tools/hv: Fix fortify format warning
With fortify enabled, gcc warns:
tools/hv/hv_kvp_daemon.c:705:2: error: format not a string literal and no format arguments [-Werror=format-security]
snprintf(dev_id, sizeof(dev_id), kvp_net_dir);
^
kvp_net_dir is a pointer to a string literal, but lacks const
qualification. As it is never modified, it should be a const
array rather than a pointer.
Also, while snprintf() has a bounds check, the following strcat()s
do not. Combine them into a single snprintf().
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
--- a/tools/hv/hv_kvp_daemon.c
+++ b/tools/hv/hv_kvp_daemon.c
@@ -691,10 +691,10 @@ static char *kvp_mac_to_if_name(char *ma
DIR *dir;
struct dirent *entry;
FILE *file;
- char *p, *q, *x;
+ char *p, *x;
char *if_name = NULL;
char buf[256];
- char *kvp_net_dir = "/sys/class/net/";
+ const char kvp_net_dir[] = "/sys/class/net/";
char dev_id[256];
unsigned int i;
@@ -702,17 +702,9 @@ static char *kvp_mac_to_if_name(char *ma
if (dir == NULL)
return NULL;
- snprintf(dev_id, sizeof(dev_id), kvp_net_dir);
- q = dev_id + strlen(kvp_net_dir);
-
while ((entry = readdir(dir)) != NULL) {
- /*
- * Set the state for the next pass.
- */
- *q = '\0';
-
- strcat(dev_id, entry->d_name);
- strcat(dev_id, "/address");
+ snprintf(dev_id, sizeof(dev_id), "%s%s/address",
+ kvp_net_dir, entry->d_name);
file = fopen(dev_id, "r");
if (file == NULL)