ext4: Report max_batch_time option correctly (Closes: #654206)

svn path=/dists/sid/linux-2.6/; revision=18970
This commit is contained in:
Ben Hutchings 2012-05-01 01:45:51 +00:00
parent 1dbc9c5653
commit 43eb0a755b
3 changed files with 34 additions and 0 deletions

1
debian/changelog vendored
View File

@ -2,6 +2,7 @@ linux-2.6 (3.2.16-2) UNRELEASED; urgency=low
[ Ben Hutchings ]
* aufs: Enable AUFS_EXPORT
* ext4: Report max_batch_time option correctly (Closes: #654206)
-- Ben Hutchings <ben@decadent.org.uk> Tue, 01 May 2012 00:43:48 +0100

View File

@ -0,0 +1,31 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Wed, 4 Jan 2012 21:22:51 -0500
Subject: [PATCH] ext4: Report max_batch_time option correctly
commit 1d526fc91bea04ee35b7599bf8b82f86c0aaf46c upstream.
Currently the value reported for max_batch_time is really the
value of min_batch_time.
Reported-by: Russell Coker <russell@coker.com.au>
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
fs/ext4/super.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/fs/ext4/super.c b/fs/ext4/super.c
index 35377d5..36570b7 100644
--- a/fs/ext4/super.c
+++ b/fs/ext4/super.c
@@ -1096,7 +1096,7 @@ static int ext4_show_options(struct seq_file *seq, struct vfsmount *vfs)
}
if (sbi->s_max_batch_time != EXT4_DEF_MAX_BATCH_TIME) {
seq_printf(seq, ",max_batch_time=%u",
- (unsigned) sbi->s_min_batch_time);
+ (unsigned) sbi->s_max_batch_time);
}
/*
--
1.7.10

View File

@ -198,3 +198,5 @@
+ debian/revert-rtc-Provide-flag-for-rtc-devices-that-don-t-s.patch
+ debian/nls-Avoid-ABI-change-from-improvement-to-utf8s_to_ut.patch
+ debian/efi-avoid-ABI-change.patch
+ bugfix/all/ext4-Report-max_batch_time-option-correctly.patch