Update to 3.10.3

svn path=/dists/sid/linux/; revision=20410
This commit is contained in:
Ben Hutchings 2013-07-26 04:49:07 +00:00
parent 0f1eb1e783
commit 43af771d91
3 changed files with 27 additions and 68 deletions

29
debian/changelog vendored
View File

@ -1,4 +1,4 @@
linux (3.10.2-1) UNRELEASED; urgency=low
linux (3.10.3-1) UNRELEASED; urgency=low
* New upstream stable update:
http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.10.2
@ -38,6 +38,32 @@ linux (3.10.2-1) UNRELEASED; urgency=low
- [armhf] dts: imx: cpus/cpu nodes dts updates
- [armhf] drivers/dma/pl330.c: fix locking in pl330_free_chan_resources()
- memcg, kmem: fix reference count handling on the error path
* New upstream stable update:
http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.10.3
- cpufreq: Revert commit a66b2e to fix suspend/resume regression
- iio: Fix iio_channel_has_info
- iio: inkern: fix iio_convert_raw_to_processed_unlocked
- ALSA: seq-oss: Initialize MIDI clients asynchronously
- ALSA: Fix unlocked snd_pcm_stop() calls in various drivers
- libata-zpodd: Use ata_tf_init() to select the right device
- md/raid10: fix bug which causes all RAID10 reshapes to move no data.
- md/raid10: fix two bugs affecting RAID10 reshape.
- md/raid10: fix two problems with RAID10 resync. (Closes: #717681)
- mac80211: close AP_VLAN interfaces before unregistering all
- svcrpc: fix failures to handle -1 uid's
- svcrpc: fix handling of too-short rpc's
- drm/i915: Fix context sizes on HSW
- drm/i915: Only clear write-domains after a successful wait-seqno
- drm/gem: fix not to assign error value to gem name
- drm/nv50-/disp: Use output specific mask in interrupt (Closes: #717590)
- iommu/amd: Only unmap large pages from the first pte
- MIPS: Octeon: Don't clobber bootloader data structures.
- perf: Clone child context from parent context pmu
- perf: Remove WARN_ON_ONCE() check in __perf_event_enable() for valid
scenario
- perf: Fix perf_lock_task_context() vs RCU
- tracing: Protect ftrace_trace_arrays list in trace_events.c
- tracing: Fix race between deleting buffer and setting events
[ Arnaud Patard ]
* udeb: add ehci-pci to usb-modules
@ -54,7 +80,6 @@ linux (3.10.2-1) UNRELEASED; urgency=low
compression of package (but use gzip, to keep old tools happy).
* linux-source: Install kernel config files for linux-image packages in
/usr/src/linux-config-$UPSTREAMVERSION directory
* nouveau: nv50-/disp: Use output specific mask in interrupt (Closes: #717590)
-- Arnaud Patard <arnaud.patard@rtp-net.org> Tue, 16 Jul 2013 08:19:29 +0200

View File

@ -1,65 +0,0 @@
From: Emil Velikov <emil.l.velikov@gmail.com>
Date: Tue, 2 Jul 2013 14:44:12 +0100
Subject: drm/nv50-/disp: Use output specific mask in interrupt
Origin: https://git.kernel.org/linus/378f2bcdf7c971453d11580936dc0ffe845f5880
The commit
commit 476e84e126171d809f9c0b5d97137f5055f95ca8
Author: Ben Skeggs <bskeggs@redhat.com>
Date: Mon Feb 11 09:24:23 2013 +1000
drm/nv50-/disp: initial supervisor support for off-chip encoders
changed the write mask in one of the interrupt functions for on-chip encoders,
causing a regression in certain VGA dual-head setups. This commit reintroduces
the mask thus resolving the regression
Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=66129
Reported-and-Tested-by: Yves-Alexis <corsac@debian.org>
Cc: stable@vger.kernel.org [3.9+]
CC: Ben Skeggs <bskeggs@redhat.com>
Signed-off-by: Emil Velikov <emil.l.velikov@gmail.com>
Signed-off-by: Ben Skeggs <bskeggs@redhat.com>
---
drivers/gpu/drm/nouveau/core/engine/disp/nv50.c | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)
diff --git a/drivers/gpu/drm/nouveau/core/engine/disp/nv50.c b/drivers/gpu/drm/nouveau/core/engine/disp/nv50.c
index 8b42f45..7ffe2f3 100644
--- a/drivers/gpu/drm/nouveau/core/engine/disp/nv50.c
+++ b/drivers/gpu/drm/nouveau/core/engine/disp/nv50.c
@@ -1107,6 +1107,7 @@ nv50_disp_intr_unk20_2(struct nv50_disp_priv *priv, int head)
u32 pclk = nv_rd32(priv, 0x610ad0 + (head * 0x540)) & 0x3fffff;
u32 hval, hreg = 0x614200 + (head * 0x800);
u32 oval, oreg;
+ u32 mask;
u32 conf = exec_clkcmp(priv, head, 0xff, pclk, &outp);
if (conf != ~0) {
if (outp.location == 0 && outp.type == DCB_OUTPUT_DP) {
@@ -1133,6 +1134,7 @@ nv50_disp_intr_unk20_2(struct nv50_disp_priv *priv, int head)
oreg = 0x614280 + (ffs(outp.or) - 1) * 0x800;
oval = 0x00000000;
hval = 0x00000000;
+ mask = 0xffffffff;
} else
if (!outp.location) {
if (outp.type == DCB_OUTPUT_DP)
@@ -1140,14 +1142,16 @@ nv50_disp_intr_unk20_2(struct nv50_disp_priv *priv, int head)
oreg = 0x614300 + (ffs(outp.or) - 1) * 0x800;
oval = (conf & 0x0100) ? 0x00000101 : 0x00000000;
hval = 0x00000000;
+ mask = 0x00000707;
} else {
oreg = 0x614380 + (ffs(outp.or) - 1) * 0x800;
oval = 0x00000001;
hval = 0x00000001;
+ mask = 0x00000707;
}
nv_mask(priv, hreg, 0x0000000f, hval);
- nv_mask(priv, oreg, 0x00000707, oval);
+ nv_mask(priv, oreg, mask, oval);
}
}

View File

@ -109,4 +109,3 @@ bugfix/all/be2net-Fix-to-avoid-hardware-workaround-when-not-nee.patch
features/all/iwlwifi-mvm-support-BSS-only.patch
features/all/iwlwifi-mvm-adjust-firmware-D3-configuration-API.patch
features/all/iwlwifi-bump-required-firmware-API-version-for-3160-.patch
bugfix/all/drm-nv50-disp-Use-output-specific-mask-in-interrupt.patch