Update to 4.18.6

This commit is contained in:
Romain Perier 2018-09-05 21:43:28 +02:00
parent 78ba2bf0b1
commit 428a3d136e
3 changed files with 130 additions and 98 deletions

131
debian/changelog vendored
View File

@ -1,4 +1,133 @@
linux (4.18.5-1) UNRELEASED; urgency=medium
linux (4.18.6-1) UNRELEASED; urgency=medium
* New upstream stable update:
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.18.6
- scsi: libsas: dynamically allocate and free ata host
- xprtrdma: Fix disconnect regression
- mei: don't update offset in write
- cifs: add missing support for ACLs in SMB 3.11
- cifs: fix uninitialized ptr deref in smb2 signing
- cifs: add missing debug entries for kconfig options
- cifs: use a refcount to protect open/closing the cached file handle
- cifs: check kmalloc before use
- smb3: enumerating snapshots was leaving part of the data off end
- smb3: Do not send SMB3 SET_INFO if nothing changed
- smb3: don't request leases in symlink creation and query
- smb3: fill in statfs fsid and correct namelen
- btrfs: use correct compare function of dirty_metadata_bytes
- btrfs: don't leak ret from do_chunk_alloc
- Btrfs: fix mount failure after fsync due to hard link recreation
- Btrfs: fix btrfs_write_inode vs delayed iput deadlock
- Btrfs: fix send failure when root has deleted files still open
- Btrfs: send, fix incorrect file layout after hole punching beyond eof
- hwmon: (k10temp) 27C Offset needed for Threadripper2
- [armhf] bpf: fix stack var offset in jit
- [armhf, arm64] iommu/arm-smmu: Error out only if not enough context
interrupts
- printk: Split the code for storing a message into the log buffer
- printk: Create helper function to queue deferred console handling
- printk/nmi: Prevent deadlock when accessing the main log buffer in NMI
- [arm64] kprobes: Fix %p uses in error messages
- [arm64] Fix mismatched cache line size detection
- [arm64] Handle mismatched cache type
- [arm64] mm: check for upper PAGE_SHIFT bits in pfn_valid()
- [arm64] dts: rockchip: corrected uart1 clock-names for rk3328
- [armhf, arm64] KVM: Fix potential loss of ptimer interrupts
- [armhf, arm64] KVM: Fix lost IRQs from emulated physcial timer when
blocked
- [armhf, arm64] KVM: Skip updating PMD entry if no change
- [armhf, arm64] KVM: Skip updating PTE entry if no change
- [s390x] kvm: fix deadlock when killed by oom
- [s390x] perf kvm: Fix subcommands on s390
- stop_machine: Reflow cpu_stop_queue_two_works()
- stop_machine: Atomically queue and wake stopper threads
- ext4: check for NUL characters in extended attribute's name
- ext4: use ext4_warning() for sb_getblk failure
- ext4: sysfs: print ext4_super_block fields as little-endian
- ext4: reset error code in ext4_find_entry in fallback
- ext4: fix race when setting the bitmap corrupted flag
- nvme-pci: add a memory barrier to nvme_dbbuf_update_and_check_event
- [x86] gpu: reserve ICL's graphics stolen memory
- [x86] platform: wmi: Do not mix pages and kmalloc
- [x86] platform: ideapad-laptop: Apply no_hw_rfkill to Y20-15IKBM, too
- mm: move tlb_table_flush to tlb_flush_mmu_free
- [x86] mm/tlb, mm: Support invalidating TLB caches for RCU_TABLE_FREE
- [x86] speculation/l1tf: Fix overflow in l1tf_pfn_limit() on 32bit
- [x86] speculation/l1tf: Fix off-by-one error when warning that system has
too much RAM (Closes: #907581)
- [x86] speculation/l1tf: Suggest what to do on systems with too much RAM
- [x86] vdso: Fix vDSO build if a retpoline is emitted
- [x86] process: Re-export start_thread()
- [x86] KVM: ensure all MSRs can always be KVM_GET/SET_MSR'd
- [x86] KVM: SVM: Call x86_spec_ctrl_set_guest/host() with interrupts
disabled
- fuse: Don't access pipe->buffers without pipe_lock()
- fuse: fix initial parallel dirops
- fuse: fix double request_end()
- fuse: fix unlocked access to processing queue
- fuse: umount should wait for all requests
- fuse: Fix oops at process_init_reply()
- fuse: Add missed unlock_page() to fuse_readpages_fill()
- lib/vsprintf: Do not handle %pO[^F] as %px
- udl-kms: change down_interruptible to down
- udl-kms: handle allocation failure
- udl-kms: fix crash due to uninitialized memory
- udl-kms: avoid division
- b43legacy/leds: Ensure NUL-termination of LED name string
- b43/leds: Ensure NUL-termination of LED name string
- ASoC: dpcm: don't merge format from invalid codec dai
- ASoC: zte: Fix incorrect PCM format bit usages
- ASoC: sirf: Fix potential NULL pointer dereference
- ASoC: wm_adsp: Correct DSP pointer for preloader control
- [armhf] pinctrl: freescale: off by one in imx1_pinconf_group_dbg_show()
- scsi: qla2xxx: Fix stalled relogin
- [x86] vdso: Fix lsl operand order
- [x86 ]nmi: Fix NMI uaccess race against CR3 switching
- [x86] irqflags: Mark native_restore_fl extern inline
- [x86] spectre: Add missing family 6 check to microcode check
- [x86] speculation/l1tf: Increase l1tf memory limit for Nehalem+
(Closes: #907581)
- hwmon: (nct6775) Fix potential Spectre v1
- [x86] entry/64: Wipe KASAN stack shadow before rewind_stack_do_exit()
- [x86] Allow generating user-space headers without a compiler
- [s390x] mm: fix addressing exception after suspend/resume
- [s390x] lib: use expoline for all bcr instructions
- [s390x] fix br_r1_trampoline for machines without exrl
- [s390x] qdio: reset old sbal_state flags
- [s390x] numa: move initial setup of node_to_cpumask_map
- [s390x] pci: fix out of bounds access during irq setup
- [s390x] purgatory: Fix crash with expoline enabled
- [s390x] purgatory: Add missing FORCE to Makefile targets
- kprobes: Show blacklist addresses as same as kallsyms does
- kprobes: Replace %p with other pointer types
- kprobes/arm: Fix %p uses in error messages
- kprobes: Make list and blacklist root user read only
- [mips*] Correct the 64-bit DSP accumulator register size
- [mips*] memset.S: Fix byte_fixup for MIPSr6
- [mips*] Always use -march=<arch>, not -<arch> shortcuts
- [mips*] Change definition of cpu_relax() for Loongson-3
- [mips*] lib: Provide MIPS64r6 __multi3() for GCC < 7
- tpm: Return the actual size when receiving an unsupported command
- tpm: separate cmd_ready/go_idle from runtime_pm
- scsi: mpt3sas: Fix calltrace observed while running IO & reset
- scsi: mpt3sas: Fix _transport_smp_handler() error path
- scsi: sysfs: Introduce sysfs_{un,}break_active_protection()
- scsi: core: Avoid that SCSI device removal through sysfs triggers a
deadlock
- iscsi target: fix session creation failure handling
- mtd: rawnand: hynix: Use ->exec_op() in hynix_nand_reg_write_op()
- mtd: rawnand: fsmc: Stop using chip->read_buf()
- mtd: rawnand: marvell: add suspend and resume hooks
- mtd: rawnand: qcom: wait for desc completion in all BAM channels
- [arm64] clk: rockchip: fix clk_i2sout parent selection bits on rk3399
- PM / clk: signedness bug in of_pm_clk_add_clks()
- power: generic-adc-battery: fix out-of-bounds write when copying channel
properties
- power: generic-adc-battery: check for duplicate properties copied from
iio channels
- watchdog: Mark watchdog touch functions as notrace
- cdrom: Fix info leak/OOB read in cdrom_ioctl_drive_status
- [x86] dumpstack: Don't dump kernel memory based on usermode RIP
[ Ben Hutchings ]
* Set ABI to 1

View File

@ -1,96 +0,0 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Sun, 5 Aug 2018 23:44:24 +0800
Subject: scripts/kernel-doc: Escape all literal braces in regexes
Bug-Debian: https://bugs.debian.org/905116
Forwarded: https://marc.info/?l=linux-doc&m=153348608531181&w=2
Braces are usually metacharacters in regexes, used to specify a
number of repetitions or as part of an escape sequence. If this
interpretation is not possible then Perl currently treats them
as literal characters.
Perl 5.28 has deprecated the literal interpretation of left braces,
and Perl 5.32 will remove it (resulting in a fatal error).
Escape all left braces that are treated as literal characters. Also
escape literal right braces, for consistency and to avoid confusing
bracket-matching in text editors.
References: https://bugs.debian.org/905116
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
scripts/kernel-doc | 20 ++++++++++----------
1 file changed, 10 insertions(+), 10 deletions(-)
diff --git a/scripts/kernel-doc b/scripts/kernel-doc
index 0057d8eafcc1..8f0f508a78e9 100755
--- a/scripts/kernel-doc
+++ b/scripts/kernel-doc
@@ -1062,7 +1062,7 @@ sub dump_struct($$) {
my $x = shift;
my $file = shift;
- if ($x =~ /(struct|union)\s+(\w+)\s*{(.*)}/) {
+ if ($x =~ /(struct|union)\s+(\w+)\s*\{(.*)\}/) {
my $decl_type = $1;
$declaration_name = $2;
my $members = $3;
@@ -1148,20 +1148,20 @@ sub dump_struct($$) {
}
}
}
- $members =~ s/(struct|union)([^\{\};]+)\{([^\{\}]*)}([^\{\}\;]*)\;/$newmember/;
+ $members =~ s/(struct|union)([^\{\};]+)\{([^\{\}]*)\}([^\{\}\;]*)\;/$newmember/;
}
# Ignore other nested elements, like enums
- $members =~ s/({[^\{\}]*})//g;
+ $members =~ s/(\{[^\{\}]*\})//g;
create_parameterlist($members, ';', $file, $declaration_name);
check_sections($file, $declaration_name, $decl_type, $sectcheck, $struct_actual);
# Adjust declaration for better display
- $declaration =~ s/([{;])/$1\n/g;
- $declaration =~ s/}\s+;/};/g;
+ $declaration =~ s/([\{;])/$1\n/g;
+ $declaration =~ s/\}\s+;/};/g;
# Better handle inlined enums
- do {} while ($declaration =~ s/(enum\s+{[^}]+),([^\n])/$1,\n$2/);
+ do {} while ($declaration =~ s/(enum\s+\{[^\}]+),([^\n])/$1,\n$2/);
my @def_args = split /\n/, $declaration;
my $level = 1;
@@ -1171,12 +1171,12 @@ sub dump_struct($$) {
$clause =~ s/\s+$//;
$clause =~ s/\s+/ /;
next if (!$clause);
- $level-- if ($clause =~ m/(})/ && $level > 1);
+ $level-- if ($clause =~ m/(\})/ && $level > 1);
if (!($clause =~ m/^\s*#/)) {
$declaration .= "\t" x $level;
}
$declaration .= "\t" . $clause . "\n";
- $level++ if ($clause =~ m/({)/ && !($clause =~m/}/));
+ $level++ if ($clause =~ m/(\{)/ && !($clause =~m/\}/));
}
output_declaration($declaration_name,
'struct',
@@ -1244,7 +1244,7 @@ sub dump_enum($$) {
# strip #define macros inside enums
$x =~ s@#\s*((define|ifdef)\s+|endif)[^;]*;@@gos;
- if ($x =~ /enum\s+(\w+)\s*{(.*)}/) {
+ if ($x =~ /enum\s+(\w+)\s*\{(.*)\}/) {
$declaration_name = $1;
my $members = $2;
my %_members;
@@ -1785,7 +1785,7 @@ sub process_proto_type($$) {
}
while (1) {
- if ( $x =~ /([^{};]*)([{};])(.*)/ ) {
+ if ( $x =~ /([^\{\};]*)([\{\};])(.*)/ ) {
if( length $prototype ) {
$prototype .= " "
}

View File

@ -98,7 +98,6 @@ bugfix/all/kbuild-include-addtree-remove-quotes-before-matching-path.patch
debian/revert-objtool-fix-config_stack_validation-y-warning.patch
bugfix/all/i40e-build-for-64-bit-targets-only.patch
bugfix/all/netfilter-ipvs-Fix-invalid-bytes-in-IP_VS_MH_TAB_IND.patch
bugfix/all/scripts-kernel-doc-escape-all-literal-braces-in-rege.patch
bugfix/all/block-really-disable-runtime-pm-for-blk-mq.patch
# Miscellaneous features