Enable save/restore and memory ballooning in all Xen-enabled kernels.

svn path=/dists/trunk/linux-2.6/; revision=11836
This commit is contained in:
Ian Campbell 2008-07-14 17:30:49 +00:00
parent 461b224c90
commit 40e9d28683
5 changed files with 11 additions and 10 deletions

2
debian/changelog vendored
View File

@ -101,7 +101,7 @@ linux-2.6 (2.6.26-1~experimental.1) UNRELEASED; urgency=low
[ Ian Campbell ]
* Readme.build updated on how to generate orig tarballs.
* Forward port vmlinuz-target.patch.
* Enable save/restore and memory ballooning in Xen packages.
* Enable Xen save/restore and memory ballooning for Xen enabled kernels.
[ Bastian Blank ]
* [powerpc/powerpc-miboot] Disable. (closes: #481358)

View File

@ -959,10 +959,10 @@ diff --git a/arch/x86/xen/Kconfig b/arch/x86/xen/Kconfig
index 6c388e5..c2cc995 100644
--- a/arch/x86/xen/Kconfig
+++ b/arch/x86/xen/Kconfig
@@ -20,3 +20,13 @@ config XEN
select SYS_HYPERVISOR
help
This is the /proc/xen interface used by Xen's libxc.
@@ -12,3 +12,13 @@ config XEN
This is the Linux Xen port. Enabling this will allow the
kernel to boot in a paravirtualized environment under the
Xen hypervisor.
+
+config XEN_MAX_DOMAIN_MEMORY
+ int "Maximum allowed size of a domain in gigabytes"

View File

@ -21,10 +21,11 @@ diff --git a/arch/x86/xen/Kconfig b/arch/x86/xen/Kconfig
index 4d5f264..4723bc1 100644
--- a/arch/x86/xen/Kconfig
+++ b/arch/x86/xen/Kconfig
@@ -11,3 +11,10 @@ config XEN
This is the Linux Xen port. Enabling this will allow the
kernel to boot in a paravirtualized environment under the
Xen hypervisor.
@@ -22,3 +22,10 @@ config XEN
according to the maximum possible memory size of a Xen
domain. This array uses 1 page per gigabyte, so there's no
need to be too stingy here.
\ No newline at end of file
+
+config XENCTRL
+ tristate "Xen's user space control interfaces"

View File

@ -48,3 +48,4 @@
+ bugfix/fix-hifn_795X-divdi3.patch
+ bugfix/all/mtd-prevent-physmap-from-causing-request_module-runaway-loop-modprobe-net-pf-1.patch
#+ features/all/0001-iwlwifi-Set-monitor-mode-for-3945.patch
+ features/all/xen/tip-x86.patch

View File

@ -7,4 +7,3 @@
+ features/all/xen/xenctrl-privcmd.patch featureset=xen
+ features/all/xen/xenctrl-xenbus.patch featureset=xen
+ features/all/xen/xenctrl-sys-hypervisor.patch featureset=xen
+ features/all/xen/tip-x86.patch featureset=xen