[armhf] Add patch from upstream fixing cpufreq on Orange Pi Plus.

This commit is contained in:
Vagrant Cascadian 2019-02-16 19:51:38 -08:00
parent 26e9f62e39
commit 3f699085ff
3 changed files with 84 additions and 0 deletions

3
debian/changelog vendored
View File

@ -19,6 +19,9 @@ linux (4.19.20-2) UNRELEASED; urgency=medium
* linux-perf: Enable coresight trace (libopencsd) support in perf
(Closes: #895131)
[ Vagrant Cascadian ]
* [armhf] Add patch from upstream fixing cpufreq on Orange Pi Plus.
-- Ben Hutchings <ben@decadent.org.uk> Tue, 12 Feb 2019 12:49:10 +0000
linux (4.19.20-1) unstable; urgency=medium

View File

@ -0,0 +1,80 @@
From e98d72d98a25890308941080d3a17b4c77e3f460 Mon Sep 17 00:00:00 2001
From: Jorik Jonker <jorik@kippendief.biz>
Date: Sat, 29 Sep 2018 15:18:30 +0200
Subject: [PATCH] ARM: dts: sun8i-h3: add sy8106a to orange pi plus
The Orange Pi Plus board lacks voltage scaling capabilities in its
current form. This results in random freezes during boot when cpufreq is
enabled, probably due to wrong voltages.
This patch (more or less copy/paste from 06139c) does the following
things on this board:
- enable r_i2c
- add sy8106a to the r_i2c bus
- have the sy8106a regulate VDD of cpu
Since the Orange Pi Plus has the same PMU setup as the Orange Pi PC, I
simply took min/max/fixed/ramp from the latter DTS. In that file the
origin of the values are described by the following comment:
"The datasheet uses 1.1V as the minimum value of VDD-CPUX,
however both the Armbian DVFS table and the official one
have operating points with voltage under 1.1V, and both
DVFS table are known to work properly at the lowest
operating point.
Use 1.0V as the minimum voltage instead."
I have tested this on patch two Orange Pi Plus boards, by running a
kernel with this patch and do intermettent runs of cpuburn while
monitoring voltage, frequency and temperature. The board runs stable
across its operatiing points while showing a reasonable (< 40C)
temperature. My Orange Pi PC, when put to the same test, yields similar
stable results.
Signed-off-by: Jorik Jonker <jorik@kippendief.biz>
Signed-off-by: Maxime Ripard <maxime.ripard@bootlin.com>
---
arch/arm/boot/dts/sun8i-h3-orangepi-plus.dts | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)
diff --git a/arch/arm/boot/dts/sun8i-h3-orangepi-plus.dts b/arch/arm/boot/dts/sun8i-h3-orangepi-plus.dts
index b403e5d787cb..ac8438c2cff1 100644
--- a/arch/arm/boot/dts/sun8i-h3-orangepi-plus.dts
+++ b/arch/arm/boot/dts/sun8i-h3-orangepi-plus.dts
@@ -74,6 +74,10 @@
};
};
+&cpu0 {
+ cpu-supply = <&reg_vdd_cpux>;
+};
+
&ehci3 {
status = "okay";
};
@@ -119,6 +123,22 @@
};
};
+&r_i2c {
+ status = "okay";
+
+ reg_vdd_cpux: regulator@65 {
+ compatible = "silergy,sy8106a";
+ reg = <0x65>;
+ regulator-name = "vdd-cpux";
+ silergy,fixed-microvolt = <1200000>;
+ regulator-min-microvolt = <1000000>;
+ regulator-max-microvolt = <1400000>;
+ regulator-ramp-delay = <200>;
+ regulator-boot-on;
+ regulator-always-on;
+ };
+};
+
&usbphy {
usb3_vbus-supply = <&reg_usb3_vbus>;
};
--
2.20.1

View File

@ -80,6 +80,7 @@ bugfix/x86/x86-32-disable-3dnow-in-generic-config.patch
bugfix/powerpc/powerpc-fix-mcpu-options-for-spe-only-compiler.patch
bugfix/m68k/m68k-build-with-ffreestanding.patch
bugfix/x86/x86-kvmclock-set-offset-for-kvm-unstable-clock.patch
bugfix/arm/ARM-dts-sun8i-h3-add-sy8106a-to-orange-pi-plus.patch
# Arch features
features/mips/MIPS-increase-MAX-PHYSMEM-BITS-on-Loongson-3-only.patch