add efifb fix from bugzilla

Reported-by: Julien Cristau <jcristau@debian.org>

svn path=/dists/trunk/linux-2.6/; revision=15177
This commit is contained in:
Maximilian Attems 2010-02-16 13:15:38 +00:00
parent 7e9f27fb1d
commit 3d930c037a
3 changed files with 56 additions and 0 deletions

1
debian/changelog vendored
View File

@ -13,6 +13,7 @@ linux-2.6 (2.6.32-9) UNRELEASED; urgency=low
* Enable VT_HW_CONSOLE_BINDING for unbinding efifb. (closes: #569314)
* hwmon: Add driver for VIA CPU core temperature.
* wireless: report reasonable bitrate for MCS rates through wext.
* efifb: fix framebuffer handoff. (bugzilla.k.o #15151)
[ Bastian Blank ]
* Restrict access to sensitive SysRq keys by default.

View File

@ -0,0 +1,54 @@
From: Marcin Slusarz <marcin.slusarz@gmail.com>
Subject: [PATCH] efifb: fix framebuffer handoff
Commit 4410f3910947dcea8672280b3adecd53cec4e85e
(fbdev: add support for handoff from firmware to hw framebuffers)
for unknown reason didn't add fb_destroy operation to efifb.
Change aperture_size to match size passed to request_mem_region.
See: http://bugzilla.kernel.org/show_bug.cgi?id=15151
Reported-by: Alex Zhavnerchik <alex.vizor@gmail.com>
Tested-by: Alex Zhavnerchik <alex.vizor@gmail.com>
Cc: Dave Airlie <airlied@redhat.com>
Cc: linux-fbdev@vger.kernel.org
Cc: dri-devel@lists.sourceforge.net
Signed-off-by: Marcin Slusarz <marcin.slusarz@gmail.com>
---
drivers/video/efifb.c | 11 ++++++++++-
1 files changed, 10 insertions(+), 1 deletions(-)
diff --git a/drivers/video/efifb.c b/drivers/video/efifb.c
index eb12182..d25df51 100644
--- a/drivers/video/efifb.c
+++ b/drivers/video/efifb.c
@@ -161,8 +161,17 @@ static int efifb_setcolreg(unsigned regno, unsigned red, unsigned green,
return 0;
}
+static void efifb_destroy(struct fb_info *info)
+{
+ if (info->screen_base)
+ iounmap(info->screen_base);
+ release_mem_region(info->aperture_base, info->aperture_size);
+ framebuffer_release(info);
+}
+
static struct fb_ops efifb_ops = {
.owner = THIS_MODULE,
+ .fb_destroy = efifb_destroy,
.fb_setcolreg = efifb_setcolreg,
.fb_fillrect = cfb_fillrect,
.fb_copyarea = cfb_copyarea,
@@ -281,7 +290,7 @@ static int __init efifb_probe(struct platform_device *dev)
info->par = NULL;
info->aperture_base = efifb_fix.smem_start;
- info->aperture_size = size_total;
+ info->aperture_size = size_remap;
info->screen_base = ioremap(efifb_fix.smem_start, efifb_fix.smem_len);
if (!info->screen_base) {
--
1.6.6

View File

@ -7,3 +7,4 @@
+ features/all/macvlan-export-macvlan-mode-through-netlink.patch
+ features/all/hwmon-Add-driver-for-VIA-CPU-core-temperature.patch
+ features/all/wireless-report-reasonable-bitrate-for-MCS-rates-th.patch
+ bugfix/all/efifb_fix_v2.patch