Update to 3.2-rc5

svn path=/dists/trunk/linux-2.6/; revision=18373
This commit is contained in:
Ben Hutchings 2011-12-10 14:13:58 +00:00
parent 081ea2a37a
commit 3c2b560acc
4 changed files with 3 additions and 74 deletions

4
debian/changelog vendored
View File

@ -1,4 +1,6 @@
linux-2.6 (3.2~rc4-1~experimental.2) UNRELEASED; urgency=low
linux-2.6 (3.2~rc5-1~experimental.1) UNRELEASED; urgency=low
* New upstream release candidate
[ Ben Hutchings ]
* [powerpc] pasemi_mac: Fix building as module

View File

@ -1,44 +0,0 @@
From ed27850db5bec21b1804ed326691af575bdfbd23 Mon Sep 17 00:00:00 2001
From: Ben Hutchings <ben@decadent.org.uk>
Date: Tue, 22 Nov 2011 06:55:26 +0000
Subject: [PATCH] netdev: Revert ARCNET and PHYLIB to tristate options
commit 88491d8103498a6166f70d5999902fec70924314 ("drivers/net: Kconfig
& Makefile cleanup") changed the type of these options to bool, but
they select code that could (and still can) be built as modules.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
drivers/net/arcnet/Kconfig | 2 +-
drivers/net/phy/Kconfig | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/net/arcnet/Kconfig b/drivers/net/arcnet/Kconfig
index a73d9dc..84fb634 100644
--- a/drivers/net/arcnet/Kconfig
+++ b/drivers/net/arcnet/Kconfig
@@ -4,7 +4,7 @@
menuconfig ARCNET
depends on NETDEVICES && (ISA || PCI || PCMCIA)
- bool "ARCnet support"
+ tristate "ARCnet support"
---help---
If you have a network card of this type, say Y and check out the
(arguably) beautiful poetry in
diff --git a/drivers/net/phy/Kconfig b/drivers/net/phy/Kconfig
index bb88e12..a702443 100644
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
@@ -3,7 +3,7 @@
#
menuconfig PHYLIB
- bool "PHY Device support and infrastructure"
+ tristate "PHY Device support and infrastructure"
depends on !S390
depends on NETDEVICES
help
--
1.7.7.3

View File

@ -1,27 +0,0 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Tue, 6 Dec 2011 04:07:39 +0000
Subject: [PATCH] pasemi_mac: Fix building as module
Commit ded19addf9c937d83b9bfb4d73a836732569041b ('pasemic_mac*: Move
the PA Semi driver') inadvertently split pasemi_mac into two separate
modules with unresolved symbols. Change it back into a single module.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
drivers/net/ethernet/pasemi/Makefile | 3 ++-
1 files changed, 2 insertions(+), 1 deletions(-)
diff --git a/drivers/net/ethernet/pasemi/Makefile b/drivers/net/ethernet/pasemi/Makefile
index 05db543..90497ff 100644
--- a/drivers/net/ethernet/pasemi/Makefile
+++ b/drivers/net/ethernet/pasemi/Makefile
@@ -2,4 +2,5 @@
# Makefile for the A Semi network device drivers.
#
-obj-$(CONFIG_PASEMI_MAC) += pasemi_mac.o pasemi_mac_ethtool.o
+obj-$(CONFIG_PASEMI_MAC) += pasemi_mac_driver.o
+pasemi_mac_driver-objs := pasemi_mac.o pasemi_mac_ethtool.o
--
1.7.7.3

View File

@ -45,7 +45,6 @@
# Defer until we're sure about the system call number
#+ bugfix/ia64/ia64-Add-accept4-syscall.patch
+ bugfix/arm/ixp4xx_iobe.patch
+ bugfix/all/netdev-Revert-ARCNET-and-PHYLIB-to-tristate-options.patch
+ debian/bcma-Do-not-claim-PCI-device-IDs-also-claimed-by-brc.patch
@ -57,4 +56,3 @@
+ features/all/topology-Provide-CPU-topology-in-sysfs-in-SMP-configura.patch
+ features/all/aufs3/aufs3-fix-export-__devcgroup_inode_permission.patch
+ bugfix/powerpc/pasemi_mac-Fix-building-as-module.patch