[powerpcspe] powerpc/Makefile: Assemble with -me500 when building for E500

This fixes a new FTBFS in 4.18.  Thanks again to James Clarke.
This commit is contained in:
Ben Hutchings 2018-07-12 23:26:15 +01:00
parent 5cf22ecc66
commit 3c07bfca57
3 changed files with 35 additions and 0 deletions

4
debian/changelog vendored
View File

@ -6,6 +6,10 @@ linux (4.18~rc4-1~exp2) UNRELEASED; urgency=medium
* [m68k] scsi: Enable CONFIG_SCSI_ZORRO_ESP as module.
* [m68k] udeb: Add zorro_esp module to scsi-modules.
[ Ben Hutchings ]
* [powerpcspe] powerpc/Makefile: Assemble with -me500 when building for E500
(fixes FTBFS) (thanks to James Clarke)
-- Ben Hutchings <ben@decadent.org.uk> Thu, 12 Jul 2018 13:55:31 +0100
linux (4.18~rc4-1~exp1) experimental; urgency=medium

View File

@ -0,0 +1,30 @@
From: James Clarke <jrtc27@jrtc27.com>
Subject: powerpc/Makefile: Assemble with -me500 when building for E500
Date: Thu, 12 Jul 2018 22:41:49 +0100
Origin: https://people.debian.org/~jrtc27/linux-ppc32/0001-powerpc-Makefile-Assemble-with-me500-when-building-f.patch
Some of the assembly files use instructions specific to BookE or E500,
which are rejected with the now-default -mcpu=powerpc, so we must pass
-me500 to the assembler just as we pass -me200 for E200.
Fixes: 4bf4f42a2feb ("powerpc/kbuild: Set default generic machine type for 32-bit compile")
Signed-off-by: James Clarke <jrtc27@jrtc27.com>
---
arch/powerpc/Makefile | 1 +
1 file changed, 1 insertion(+)
diff --git a/arch/powerpc/Makefile b/arch/powerpc/Makefile
index 2ea575cb..fb96206d 100644
--- a/arch/powerpc/Makefile
+++ b/arch/powerpc/Makefile
@@ -243,6 +243,7 @@ endif
cpu-as-$(CONFIG_4xx) += -Wa,-m405
cpu-as-$(CONFIG_ALTIVEC) += $(call as-option,-Wa$(comma)-maltivec)
cpu-as-$(CONFIG_E200) += -Wa,-me200
+cpu-as-$(CONFIG_E500) += -Wa,-me500
cpu-as-$(CONFIG_PPC_BOOK3S_64) += -Wa,-mpower4
cpu-as-$(CONFIG_PPC_E500MC) += $(call as-option,-Wa$(comma)-me500mc)
--
2.18.0

View File

@ -68,6 +68,7 @@ bugfix/x86/mmap-add-an-exception-to-the-stack-gap-for-hotspot-jvm.patch
bugfix/powerpc/powerpc-lib-sstep-fix-building-for-powerpcspe.patch
bugfix/powerpc/powerpc-lib-makefile-don-t-pull-in-quad.o-for-32-bit.patch
bugfix/arm/arm-mm-export-__sync_icache_dcache-for-xen-privcmd.patch
bugfix/powerpc/powerpc-makefile-assemble-with-me500-when-building-f.patch
# Arch features
features/mips/MIPS-increase-MAX-PHYSMEM-BITS-on-Loongson-3-only.patch