Update to 3.5.3

svn path=/dists/trunk/linux/; revision=19354
This commit is contained in:
Ben Hutchings 2012-08-28 04:31:51 +00:00
parent dd8b73a87c
commit 3b89cc45a2
3 changed files with 7 additions and 34 deletions

7
debian/changelog vendored
View File

@ -1,3 +1,10 @@
linux (3.5.3-1~experimental.1) UNRELEASED; urgency=low
* New upstream stable update:
http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.5.3
-- Ben Hutchings <ben@decadent.org.uk> Mon, 27 Aug 2012 17:22:33 -0700
linux (3.5.2-1~experimental.1) experimental; urgency=low
* New upstream stable update:

View File

@ -1,33 +0,0 @@
From: Jesse Barnes <jbarnes@virtuousgeek.org>
Date: Thu, 21 Jun 2012 15:13:50 -0700
Subject: drm/i915: prefer wide & slow to fast & narrow in DP configs
commit 2514bc510d0c3aadcc5204056bb440fa36845147 upstream.
High frequency link configurations have the potential to cause trouble
with long and/or cheap cables, so prefer slow and wide configurations
instead. This patch has the potential to cause trouble for eDP
configurations that lie about available lanes, so if we run into that we
can make it conditional on eDP.
Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=45801
Tested-by: peter@colberg.org
Signed-off-by: Jesse Barnes <jbarnes@virtuousgeek.org>
Signed-off-by: Daniel Vetter <daniel.vetter@ffwll.ch>
---
drivers/gpu/drm/i915/intel_dp.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
--- a/drivers/gpu/drm/i915/intel_dp.c
+++ b/drivers/gpu/drm/i915/intel_dp.c
@@ -726,8 +726,8 @@ intel_dp_mode_fixup(struct drm_encoder *
bpp = adjusted_mode->private_flags & INTEL_MODE_DP_FORCE_6BPC ? 18 : 24;
mode_rate = intel_dp_link_required(mode->clock, bpp);
- for (lane_count = 1; lane_count <= max_lane_count; lane_count <<= 1) {
- for (clock = 0; clock <= max_clock; clock++) {
+ for (clock = 0; clock <= max_clock; clock++) {
+ for (lane_count = 1; lane_count <= max_lane_count; lane_count <<= 1) {
int link_avail = intel_dp_max_data_rate(intel_dp_link_clock(bws[clock]), lane_count);
if (mode_rate <= link_avail) {

View File

@ -52,7 +52,6 @@ features/all/wacom/0030-wacom-ignore-new-style-Wacom-multi-touch-packets-on-.pat
bugfix/ia64/IA64-Export-asm-cmpxchg.h-to-userland.patch
features/all/cpu-devices/Partially-revert-cpufreq-Add-support-for-x86-cpuinfo.patch
bugfix/all/net-e100-ucode-is-optional-in-some-cases.patch
bugfix/x86/drm-i915-prefer-wide-slow-to-fast-narrow-in-DP-confi.patch
bugfix/all/hwmon-applesmc-Skip-sensor-mapping.patch
bugfix/all/hwmon-applesmc-Shorten-minimum-wait-time.patch
bugfix/all/hwmon-applesmc-Allow-negative-temperature-values.patch