* Include module.lds in headers package if it exists. (closes: #342246)

* Add Apple MacBook product IDs to usbhid and set
  CONFIG_USB_HIDINPUT_POWERBOOK=y on i386 and amd64. (closes: #383620)

svn path=/dists/sid/linux-2.6/; revision=7213
This commit is contained in:
dann frazier 2006-08-21 00:29:13 +00:00
parent 7b59838e5e
commit 3ac3c8e934
5 changed files with 34 additions and 2 deletions

View File

@ -1288,6 +1288,7 @@ CONFIG_USB_STORAGE_SDDR55=y
CONFIG_USB_STORAGE_JUMPSHOT=y
CONFIG_USB_HID=m
CONFIG_USB_HIDINPUT=y
CONFIG_USB_HIDINPUT_POWERBOOK=y
# CONFIG_HID_FF is not set
CONFIG_USB_HIDDEV=y
CONFIG_USB_KBD=m

View File

@ -1542,6 +1542,7 @@ CONFIG_USB_STORAGE_SDDR55=y
CONFIG_USB_STORAGE_JUMPSHOT=y
CONFIG_USB_HID=m
CONFIG_USB_HIDINPUT=y
CONFIG_USB_HIDINPUT_POWERBOOK=y
# CONFIG_HID_FF is not set
CONFIG_USB_HIDDEV=y
CONFIG_USB_KBD=m

6
debian/changelog vendored
View File

@ -27,9 +27,11 @@ linux-2.6 (2.6.17-7) UNRELEASED; urgency=low
* Activate CONFIG_R8169_VLAN on amd64. (closes: #383707)
[ dann frazier ]
* Include module.lds in headers package if it exists. Closes: #342246
* Include module.lds in headers package if it exists. (closes: #342246)
* Add Apple MacBook product IDs to usbhid and set
CONFIG_USB_HIDINPUT_POWERBOOK=y on i386 and amd64. (closes: #383620)
-- dann frazier <dannf@debian.org> Sun, 20 Aug 2006 13:27:58 -0600
-- dann frazier <dannf@debian.org> Sun, 20 Aug 2006 14:09:30 -0600
linux-2.6 (2.6.17-6) unstable; urgency=low

27
debian/patches/macbook-usbhid-ids.patch vendored Normal file
View File

@ -0,0 +1,27 @@
From: Rene Rebe <rene@exactcode.de>
Date: Sun, 4 Jun 2006 09:39:09 +0000 (+0200)
Subject: [PATCH] USB: Add Apple MacBook product IDs to usbhid
X-Git-Tag: v2.6.18-rc1
X-Git-Url: http://kernel.org/git/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=5c218e3b86510f9685bfae5b0d2d7cc8468056c1
[PATCH] USB: Add Apple MacBook product IDs to usbhid
This adds the Apple MacBook product IDs for the Fn translation
to the usbhid.
Signed-off-by: Rene Rebe <rene@exactcode.de>
Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
---
--- a/drivers/usb/input/hid-core.c
+++ b/drivers/usb/input/hid-core.c
@@ -1693,6 +1693,9 @@ static const struct hid_blacklist {
{ USB_VENDOR_ID_APPLE, 0x0214, HID_QUIRK_POWERBOOK_HAS_FN },
{ USB_VENDOR_ID_APPLE, 0x0215, HID_QUIRK_POWERBOOK_HAS_FN },
{ USB_VENDOR_ID_APPLE, 0x0216, HID_QUIRK_POWERBOOK_HAS_FN },
+ { USB_VENDOR_ID_APPLE, 0x0217, HID_QUIRK_POWERBOOK_HAS_FN },
+ { USB_VENDOR_ID_APPLE, 0x0218, HID_QUIRK_POWERBOOK_HAS_FN },
+ { USB_VENDOR_ID_APPLE, 0x0219, HID_QUIRK_POWERBOOK_HAS_FN },
{ USB_VENDOR_ID_APPLE, 0x030A, HID_QUIRK_POWERBOOK_HAS_FN },
{ USB_VENDOR_ID_APPLE, 0x030B, HID_QUIRK_POWERBOOK_HAS_FN },

View File

@ -1 +1,2 @@
+ 2.6.17.9
+ macbook-usbhid-ids.patch