add lonely 2.6.33.1 stable drm patch

applies to 2.6.33 drm

svn path=/dists/sid/linux-2.6/; revision=15372
This commit is contained in:
Maximilian Attems 2010-03-14 09:29:47 +00:00
parent 21471bc8d9
commit 3a1683af77
3 changed files with 44 additions and 0 deletions

1
debian/changelog vendored
View File

@ -6,6 +6,7 @@ linux-2.6 (2.6.32-10) UNRELEASED; urgency=low
- net/via-rhine: Fix scheduling while atomic bugs (closes: #549606)
- drm/i915: Fix DDC on some systems by clearing BIOS GMBUS
(closes: #567747)
* drm/radeon/kms/atom: fix shr/shl ops.
[ Moritz Muehlenhoff ]
* Enable CONFIG_KEYS_DEBUG_PROC_KEYS (Closes: #400932)

View File

@ -0,0 +1,42 @@
From 6a8a2d702b33c6ed5c789f21b4e89fdf221f01ca Mon Sep 17 00:00:00 2001
From: Alex Deucher <alexdeucher@gmail.com>
Date: Tue, 23 Feb 2010 21:56:12 -0500
Subject: drm/radeon/kms/atom: fix shr/shl ops
From: Alex Deucher <alexdeucher@gmail.com>
commit 6a8a2d702b33c6ed5c789f21b4e89fdf221f01ca upstream.
The whole attribute table is valid for
shr/shl ops.
Fixes fdo bug 26668
Signed-off-by: Alex Deucher <alexdeucher@gmail.com>
Signed-off-by: Dave Airlie <airlied@redhat.com>
Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
---
drivers/gpu/drm/radeon/atom.c | 4 ----
1 file changed, 4 deletions(-)
--- a/drivers/gpu/drm/radeon/atom.c
+++ b/drivers/gpu/drm/radeon/atom.c
@@ -881,8 +881,6 @@ static void atom_op_shl(atom_exec_contex
uint8_t attr = U8((*ptr)++), shift;
uint32_t saved, dst;
int dptr = *ptr;
- attr &= 0x38;
- attr |= atom_def_dst[attr >> 3] << 6;
SDEBUG(" dst: ");
dst = atom_get_dst(ctx, arg, attr, ptr, &saved, 1);
shift = atom_get_src(ctx, attr, ptr);
@@ -897,8 +895,6 @@ static void atom_op_shr(atom_exec_contex
uint8_t attr = U8((*ptr)++), shift;
uint32_t saved, dst;
int dptr = *ptr;
- attr &= 0x38;
- attr |= atom_def_dst[attr >> 3] << 6;
SDEBUG(" dst: ");
dst = atom_get_dst(ctx, arg, attr, ptr, &saved, 1);
shift = atom_get_src(ctx, attr, ptr);

View File

@ -35,3 +35,4 @@
+ bugfix/all/net-Fix-first-line-of-kernel-doc.patch
+ bugfix/all/video-fix-first-line-of-kernel-doc.patch
+ bugfix/all/mptscsih-Fix-first-line-of-kernel-doc.patch
+ bugfix/all/drm-radeon-kms-atom-fix-shr-shl-ops.patch