aufs: Update support patchset to aufs4.16-20180409 (no functional change)

This commit is contained in:
Ben Hutchings 2018-04-08 20:06:10 +02:00
parent 51c5591ed2
commit 39213877ab
4 changed files with 97 additions and 71 deletions

1
debian/changelog vendored
View File

@ -1,6 +1,7 @@
linux (4.16-1~exp2) UNRELEASED; urgency=medium
* aufs: gen-patch: Fix Subject generation to skip SPDX-License-Identifier
* aufs: Update support patchset to aufs4.16-20180409 (no functional change)
-- Ben Hutchings <ben@decadent.org.uk> Sun, 08 Apr 2018 19:03:49 +0100

View File

@ -1,19 +1,19 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Sat Dec 16 15:29:33 2017 +0900
Subject: SPDX-License-Identifier: GPL-2.0
Origin: https://github.com/sfjro/aufs4-standalone/tree/8b9c1be851f351af1104f55952e211ae541695ee
Date: Tue Apr 3 14:43:11 2018 +0900
Subject: aufs4.16 base patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/8ed212d3987b8aed42d89dd0137bd44bad4a0a6c
Bug-Debian: https://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs4/gen-patch
SPDX-License-Identifier: GPL-2.0
aufs4.x-rcN base patch
aufs4.16 base patch
diff --git a/MAINTAINERS b/MAINTAINERS
index 82ad0ea..7d8b461 100644
index 6e950b8..7324ece 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -2478,6 +2478,19 @@ F: include/linux/audit.h
@@ -2485,6 +2485,19 @@ F: include/linux/audit.h
F: include/uapi/linux/audit.h
F: kernel/audit*
@ -34,7 +34,7 @@ index 82ad0ea..7d8b461 100644
M: Miguel Ojeda Sandonis <miguel.ojeda.sandonis@gmail.com>
W: http://miguelojeda.es/auxdisplay.htm
diff --git a/drivers/block/loop.c b/drivers/block/loop.c
index bc8e615..e51a59d 100644
index ee62d2d..4ca6361 100644
--- a/drivers/block/loop.c
+++ b/drivers/block/loop.c
@@ -691,6 +691,24 @@ static inline int is_loop_device(struct file *file)
@ -63,10 +63,10 @@ index bc8e615..e51a59d 100644
static ssize_t loop_attr_show(struct device *dev, char *page,
diff --git a/fs/dcache.c b/fs/dcache.c
index 5c7df1d..019f14b 100644
index 8945e6c..87c19c0 100644
--- a/fs/dcache.c
+++ b/fs/dcache.c
@@ -1197,7 +1197,7 @@ enum d_walk_ret {
@@ -1205,7 +1205,7 @@ enum d_walk_ret {
*
* The @enter() and @finish() callbacks are called with d_lock held.
*/
@ -76,7 +76,7 @@ index 5c7df1d..019f14b 100644
void (*finish)(void *))
{
diff --git a/fs/fcntl.c b/fs/fcntl.c
index 0522e28..74c255d 100644
index 1e97f1f..8cd01f7 100644
--- a/fs/fcntl.c
+++ b/fs/fcntl.c
@@ -32,7 +32,7 @@
@ -98,10 +98,10 @@ index 0522e28..74c255d 100644
return error;
diff --git a/fs/inode.c b/fs/inode.c
index 03102d6..517883c 100644
index ef36236..929a5a3 100644
--- a/fs/inode.c
+++ b/fs/inode.c
@@ -1655,7 +1655,7 @@ EXPORT_SYMBOL(generic_update_time);
@@ -1659,7 +1659,7 @@ EXPORT_SYMBOL(generic_update_time);
* This does the actual work of updating an inodes time or version. Must have
* had called mnt_want_write() before calling this.
*/
@ -111,7 +111,7 @@ index 03102d6..517883c 100644
int (*update_time)(struct inode *, struct timespec *, int);
diff --git a/fs/namespace.c b/fs/namespace.c
index e158ec6..312bdbd8 100644
index 9d1374a..26ef600 100644
--- a/fs/namespace.c
+++ b/fs/namespace.c
@@ -846,6 +846,12 @@ static inline int check_mnt(struct mount *mnt)
@ -214,10 +214,10 @@ index 279720d..76e38ea 100644
static inline void fput_light(struct file *file, int fput_needed)
{
diff --git a/include/linux/fs.h b/include/linux/fs.h
index 511fbaa..96e05b3 100644
index c6baf76..71dc695 100644
--- a/include/linux/fs.h
+++ b/include/linux/fs.h
@@ -1265,6 +1265,7 @@ extern void fasync_free(struct fasync_struct *);
@@ -1270,6 +1270,7 @@ extern void fasync_free(struct fasync_struct *);
/* can be called from interrupts */
extern void kill_fasync(struct fasync_struct **, int, int);
@ -225,7 +225,7 @@ index 511fbaa..96e05b3 100644
extern void __f_setown(struct file *filp, struct pid *, enum pid_type, int force);
extern int f_setown(struct file *filp, unsigned long arg, int force);
extern void f_delown(struct file *filp);
@@ -1712,6 +1713,7 @@ struct file_operations {
@@ -1722,6 +1723,7 @@ struct file_operations {
ssize_t (*sendpage) (struct file *, struct page *, int, size_t, loff_t *, int);
unsigned long (*get_unmapped_area)(struct file *, unsigned long, unsigned long, unsigned long, unsigned long);
int (*check_flags)(int);
@ -233,7 +233,7 @@ index 511fbaa..96e05b3 100644
int (*flock) (struct file *, int, struct file_lock *);
ssize_t (*splice_write)(struct pipe_inode_info *, struct file *, loff_t *, size_t, unsigned int);
ssize_t (*splice_read)(struct file *, loff_t *, struct pipe_inode_info *, size_t, unsigned int);
@@ -1782,6 +1784,12 @@ ssize_t rw_copy_check_uvector(int type, const struct iovec __user * uvector,
@@ -1792,6 +1794,12 @@ ssize_t rw_copy_check_uvector(int type, const struct iovec __user * uvector,
struct iovec *fast_pointer,
struct iovec **ret_pointer);
@ -246,7 +246,7 @@ index 511fbaa..96e05b3 100644
extern ssize_t __vfs_read(struct file *, char __user *, size_t, loff_t *);
extern ssize_t vfs_read(struct file *, char __user *, size_t, loff_t *);
extern ssize_t vfs_write(struct file *, const char __user *, size_t, loff_t *);
@@ -2201,6 +2209,7 @@ extern int current_umask(void);
@@ -2196,6 +2204,7 @@ extern int current_umask(void);
extern void ihold(struct inode * inode);
extern void iput(struct inode *);
extern int generic_update_time(struct inode *, struct timespec *, int);
@ -254,7 +254,7 @@ index 511fbaa..96e05b3 100644
/* /sys/fs */
extern struct kobject *fs_kobj;
@@ -2481,6 +2490,7 @@ static inline bool sb_is_blkdev_sb(struct super_block *sb)
@@ -2476,6 +2485,7 @@ static inline bool sb_is_blkdev_sb(struct super_block *sb)
return false;
}
#endif
@ -263,10 +263,10 @@ index 511fbaa..96e05b3 100644
extern const struct file_operations def_blk_fops;
extern const struct file_operations def_chr_fops;
diff --git a/include/linux/lockdep.h b/include/linux/lockdep.h
index a842551..453e941 100644
index 6fc77d4..27e76f0 100644
--- a/include/linux/lockdep.h
+++ b/include/linux/lockdep.h
@@ -406,6 +406,8 @@ static inline int lockdep_match_key(struct lockdep_map *lock,
@@ -313,6 +313,8 @@ static inline int lockdep_match_key(struct lockdep_map *lock,
return lock->key == key;
}
@ -275,7 +275,7 @@ index a842551..453e941 100644
/*
* Acquire a lock.
*
@@ -535,6 +537,7 @@ struct lockdep_map { };
@@ -439,6 +441,7 @@ struct lockdep_map { };
#define lockdep_depth(tsk) (0)
@ -318,10 +318,10 @@ index 74b4911..19789fb 100644
+ unsigned int flags);
#endif
diff --git a/kernel/locking/lockdep.c b/kernel/locking/lockdep.c
index 670d8d7..2cd0282 100644
index 89b5f83..0dca42f 100644
--- a/kernel/locking/lockdep.c
+++ b/kernel/locking/lockdep.c
@@ -156,7 +156,7 @@ static struct lock_list list_entries[MAX_LOCKDEP_ENTRIES];
@@ -140,7 +140,7 @@ static struct lock_list list_entries[MAX_LOCKDEP_ENTRIES];
unsigned long nr_lock_classes;
static struct lock_class lock_classes[MAX_LOCKDEP_KEYS];
@ -330,7 +330,7 @@ index 670d8d7..2cd0282 100644
{
if (!hlock->class_idx) {
/*
@@ -167,6 +167,7 @@ static inline struct lock_class *hlock_class(struct held_lock *hlock)
@@ -151,6 +151,7 @@ static inline struct lock_class *hlock_class(struct held_lock *hlock)
}
return lock_classes + hlock->class_idx - 1;
}

View File

@ -1,17 +1,19 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Sat Dec 16 15:29:33 2017 +0900
Subject: SPDX-License-Identifier: GPL-2.0
Origin: https://github.com/sfjro/aufs4-standalone/tree/8b9c1be851f351af1104f55952e211ae541695ee
Date: Tue Apr 3 14:43:11 2018 +0900
Subject: aufs4.16 mmap patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/8ed212d3987b8aed42d89dd0137bd44bad4a0a6c
Bug-Debian: https://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs4/gen-patch
SPDX-License-Identifier: GPL-2.0
aufs4.x-rcN mmap patch
aufs4.16 mmap patch
diff --git a/fs/proc/base.c b/fs/proc/base.c
index 9298324..da5bf4f9 100644
--- a/fs/proc/base.c
+++ b/fs/proc/base.c
@@ -2014,7 +2014,7 @@ static int map_files_get_link(struct den
@@ -2014,7 +2014,7 @@ static int map_files_get_link(struct dentry *dentry, struct path *path)
down_read(&mm->mmap_sem);
vma = find_exact_vma(mm, vm_start, vm_end);
if (vma && vma->vm_file) {
@ -20,9 +22,11 @@ aufs4.x-rcN mmap patch
path_get(path);
rc = 0;
}
diff --git a/fs/proc/nommu.c b/fs/proc/nommu.c
index 7563437..7c0dc0f 100644
--- a/fs/proc/nommu.c
+++ b/fs/proc/nommu.c
@@ -45,7 +45,10 @@ static int nommu_region_show(struct seq_
@@ -45,7 +45,10 @@ static int nommu_region_show(struct seq_file *m, struct vm_region *region)
file = region->vm_file;
if (file) {
@ -34,9 +38,11 @@ aufs4.x-rcN mmap patch
dev = inode->i_sb->s_dev;
ino = inode->i_ino;
}
diff --git a/fs/proc/task_mmu.c b/fs/proc/task_mmu.c
index ec6d298..34c7193 100644
--- a/fs/proc/task_mmu.c
+++ b/fs/proc/task_mmu.c
@@ -311,7 +311,10 @@ show_map_vma(struct seq_file *m, struct
@@ -311,7 +311,10 @@ show_map_vma(struct seq_file *m, struct vm_area_struct *vma, int is_pid)
const char *name = NULL;
if (file) {
@ -48,7 +54,7 @@ aufs4.x-rcN mmap patch
dev = inode->i_sb->s_dev;
ino = inode->i_ino;
pgoff = ((loff_t)vma->vm_pgoff) << PAGE_SHIFT;
@@ -1741,7 +1744,7 @@ static int show_numa_map(struct seq_file
@@ -1741,7 +1744,7 @@ static int show_numa_map(struct seq_file *m, void *v, int is_pid)
struct proc_maps_private *proc_priv = &numa_priv->proc_maps;
struct vm_area_struct *vma = v;
struct numa_maps *md = &numa_priv->md;
@ -57,9 +63,11 @@ aufs4.x-rcN mmap patch
struct mm_struct *mm = vma->vm_mm;
struct mm_walk walk = {
.hugetlb_entry = gather_hugetlb_stats,
diff --git a/fs/proc/task_nommu.c b/fs/proc/task_nommu.c
index 5b62f57..dfb4a3b 100644
--- a/fs/proc/task_nommu.c
+++ b/fs/proc/task_nommu.c
@@ -156,7 +156,10 @@ static int nommu_vma_show(struct seq_fil
@@ -156,7 +156,10 @@ static int nommu_vma_show(struct seq_file *m, struct vm_area_struct *vma,
file = vma->vm_file;
if (file) {
@ -71,9 +79,11 @@ aufs4.x-rcN mmap patch
dev = inode->i_sb->s_dev;
ino = inode->i_ino;
pgoff = (loff_t)vma->vm_pgoff << PAGE_SHIFT;
diff --git a/include/linux/mm.h b/include/linux/mm.h
index ad06d42..75e5d37 100644
--- a/include/linux/mm.h
+++ b/include/linux/mm.h
@@ -1368,6 +1368,28 @@ static inline void unmap_shared_mapping_
@@ -1368,6 +1368,28 @@ static inline void unmap_shared_mapping_range(struct address_space *mapping,
unmap_mapping_range(mapping, holebegin, holelen, 0);
}
@ -102,6 +112,8 @@ aufs4.x-rcN mmap patch
extern int access_process_vm(struct task_struct *tsk, unsigned long addr,
void *buf, int len, unsigned int gup_flags);
extern int access_remote_vm(struct mm_struct *mm, unsigned long addr,
diff --git a/include/linux/mm_types.h b/include/linux/mm_types.h
index fd1af6b..89ec438 100644
--- a/include/linux/mm_types.h
+++ b/include/linux/mm_types.h
@@ -249,6 +249,7 @@ struct vm_region {
@ -120,9 +132,11 @@ aufs4.x-rcN mmap patch
void * vm_private_data; /* was vm_pte (shared mem) */
atomic_long_t swap_readahead_info;
diff --git a/kernel/fork.c b/kernel/fork.c
index e5d9d40..f6f6fbf 100644
--- a/kernel/fork.c
+++ b/kernel/fork.c
@@ -474,7 +474,7 @@ static __latent_entropy int dup_mmap(str
@@ -474,7 +474,7 @@ static __latent_entropy int dup_mmap(struct mm_struct *mm,
struct inode *inode = file_inode(file);
struct address_space *mapping = file->f_mapping;
@ -131,9 +145,11 @@ aufs4.x-rcN mmap patch
if (tmp->vm_flags & VM_DENYWRITE)
atomic_dec(&inode->i_writecount);
i_mmap_lock_write(mapping);
diff --git a/mm/Makefile b/mm/Makefile
index e669f02..9c36567 100644
--- a/mm/Makefile
+++ b/mm/Makefile
@@ -39,7 +39,7 @@ obj-y := filemap.o mempool.o oom_kill.
@@ -39,7 +39,7 @@ obj-y := filemap.o mempool.o oom_kill.o \
mm_init.o mmu_context.o percpu.o slab_common.o \
compaction.o vmacache.o swap_slots.o \
interval_tree.o list_lru.o workingset.o \
@ -142,9 +158,11 @@ aufs4.x-rcN mmap patch
obj-y += init-mm.o
diff --git a/mm/filemap.c b/mm/filemap.c
index 693f622..ea46048 100644
--- a/mm/filemap.c
+++ b/mm/filemap.c
@@ -2703,7 +2703,7 @@ int filemap_page_mkwrite(struct vm_fault
@@ -2703,7 +2703,7 @@ int filemap_page_mkwrite(struct vm_fault *vmf)
int ret = VM_FAULT_LOCKED;
sb_start_pagefault(inode->i_sb);
@ -153,9 +171,11 @@ aufs4.x-rcN mmap patch
lock_page(page);
if (page->mapping != inode->i_mapping) {
unlock_page(page);
diff --git a/mm/mmap.c b/mm/mmap.c
index 9efdc021..d77f01f 100644
--- a/mm/mmap.c
+++ b/mm/mmap.c
@@ -171,7 +171,7 @@ static struct vm_area_struct *remove_vma
@@ -171,7 +171,7 @@ static struct vm_area_struct *remove_vma(struct vm_area_struct *vma)
if (vma->vm_ops && vma->vm_ops->close)
vma->vm_ops->close(vma);
if (vma->vm_file)
@ -164,7 +184,7 @@ aufs4.x-rcN mmap patch
mpol_put(vma_policy(vma));
kmem_cache_free(vm_area_cachep, vma);
return next;
@@ -896,7 +896,7 @@ again:
@@ -896,7 +896,7 @@ int __vma_adjust(struct vm_area_struct *vma, unsigned long start,
if (remove_next) {
if (file) {
uprobe_munmap(next, next->vm_start, next->vm_end);
@ -173,7 +193,7 @@ aufs4.x-rcN mmap patch
}
if (next->anon_vma)
anon_vma_merge(vma, next);
@@ -1761,8 +1761,8 @@ out:
@@ -1761,8 +1761,8 @@ unsigned long mmap_region(struct file *file, unsigned long addr,
return addr;
unmap_and_free_vma:
@ -183,7 +203,7 @@ aufs4.x-rcN mmap patch
/* Undo any partial mapping done by a device driver. */
unmap_region(mm, vma, prev, vma->vm_start, vma->vm_end);
@@ -2586,7 +2586,7 @@ int __split_vma(struct mm_struct *mm, st
@@ -2586,7 +2586,7 @@ int __split_vma(struct mm_struct *mm, struct vm_area_struct *vma,
goto out_free_mpol;
if (new->vm_file)
@ -192,7 +212,7 @@ aufs4.x-rcN mmap patch
if (new->vm_ops && new->vm_ops->open)
new->vm_ops->open(new);
@@ -2605,7 +2605,7 @@ int __split_vma(struct mm_struct *mm, st
@@ -2605,7 +2605,7 @@ int __split_vma(struct mm_struct *mm, struct vm_area_struct *vma,
if (new->vm_ops && new->vm_ops->close)
new->vm_ops->close(new);
if (new->vm_file)
@ -201,7 +221,7 @@ aufs4.x-rcN mmap patch
unlink_anon_vmas(new);
out_free_mpol:
mpol_put(vma_policy(new));
@@ -2767,7 +2767,7 @@ SYSCALL_DEFINE5(remap_file_pages, unsign
@@ -2767,7 +2767,7 @@ SYSCALL_DEFINE5(remap_file_pages, unsigned long, start, unsigned long, size,
struct vm_area_struct *vma;
unsigned long populate = 0;
unsigned long ret = -EINVAL;
@ -210,7 +230,7 @@ aufs4.x-rcN mmap patch
pr_warn_once("%s (%d) uses deprecated remap_file_pages() syscall. See Documentation/vm/remap_file_pages.txt.\n",
current->comm, current->pid);
@@ -2842,10 +2842,27 @@ SYSCALL_DEFINE5(remap_file_pages, unsign
@@ -2842,10 +2842,27 @@ SYSCALL_DEFINE5(remap_file_pages, unsigned long, start, unsigned long, size,
}
}
@ -239,7 +259,7 @@ aufs4.x-rcN mmap patch
out:
up_write(&mm->mmap_sem);
if (populate)
@@ -3153,7 +3170,7 @@ struct vm_area_struct *copy_vma(struct v
@@ -3153,7 +3170,7 @@ struct vm_area_struct *copy_vma(struct vm_area_struct **vmap,
if (anon_vma_clone(new_vma, vma))
goto out_free_mempol;
if (new_vma->vm_file)
@ -248,9 +268,11 @@ aufs4.x-rcN mmap patch
if (new_vma->vm_ops && new_vma->vm_ops->open)
new_vma->vm_ops->open(new_vma);
vma_link(mm, new_vma, prev, rb_link, rb_parent);
diff --git a/mm/nommu.c b/mm/nommu.c
index ebb6e61..8cf2428 100644
--- a/mm/nommu.c
+++ b/mm/nommu.c
@@ -641,7 +641,7 @@ static void __put_nommu_region(struct vm
@@ -641,7 +641,7 @@ static void __put_nommu_region(struct vm_region *region)
up_write(&nommu_region_sem);
if (region->vm_file)
@ -259,7 +281,7 @@ aufs4.x-rcN mmap patch
/* IO memory and memory shared directly out of the pagecache
* from ramfs/tmpfs mustn't be released here */
@@ -799,7 +799,7 @@ static void delete_vma(struct mm_struct
@@ -799,7 +799,7 @@ static void delete_vma(struct mm_struct *mm, struct vm_area_struct *vma)
if (vma->vm_ops && vma->vm_ops->close)
vma->vm_ops->close(vma);
if (vma->vm_file)
@ -277,7 +299,7 @@ aufs4.x-rcN mmap patch
kmem_cache_free(vm_region_jar, region);
region = pregion;
result = start;
@@ -1396,10 +1396,10 @@ error_just_free:
@@ -1396,10 +1396,10 @@ unsigned long do_mmap(struct file *file,
up_write(&nommu_region_sem);
error:
if (region->vm_file)
@ -290,6 +312,9 @@ aufs4.x-rcN mmap patch
kmem_cache_free(vm_area_cachep, vma);
return ret;
diff --git a/mm/prfile.c b/mm/prfile.c
new file mode 100644
index 0000000..14efc4f
--- /dev/null
+++ b/mm/prfile.c
@@ -0,0 +1,86 @@
@ -301,7 +326,7 @@ aufs4.x-rcN mmap patch
+ *
+ * See Documentation/filesystems/aufs/design/06mmap.txt
+ *
+ * Copyright (c) 2014-2017 Junjro R. Okajima
+ * Copyright (c) 2014-2018 Junjro R. Okajima
+ * Copyright (c) 2014 Ian Campbell
+ */
+

View File

@ -1,19 +1,19 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Sat Dec 16 15:29:33 2017 +0900
Subject: SPDX-License-Identifier: GPL-2.0
Origin: https://github.com/sfjro/aufs4-standalone/tree/8b9c1be851f351af1104f55952e211ae541695ee
Date: Tue Apr 3 14:43:11 2018 +0900
Subject: aufs4.16 standalone patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/8ed212d3987b8aed42d89dd0137bd44bad4a0a6c
Bug-Debian: https://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs4/gen-patch
SPDX-License-Identifier: GPL-2.0
aufs4.x-rcN standalone patch
aufs4.16 standalone patch
diff --git a/fs/dcache.c b/fs/dcache.c
index 019f14b..10c1a6d 100644
index 87c19c0..b66fb04 100644
--- a/fs/dcache.c
+++ b/fs/dcache.c
@@ -1305,6 +1305,7 @@ void d_walk(struct dentry *parent, void *data,
@@ -1313,6 +1313,7 @@ void d_walk(struct dentry *parent, void *data,
seq = 1;
goto again;
}
@ -21,7 +21,7 @@ index 019f14b..10c1a6d 100644
struct check_mount {
struct vfsmount *mnt;
@@ -2892,6 +2893,7 @@ void d_exchange(struct dentry *dentry1, struct dentry *dentry2)
@@ -2931,6 +2932,7 @@ void d_exchange(struct dentry *dentry1, struct dentry *dentry2)
write_sequnlock(&rename_lock);
}
@ -30,7 +30,7 @@ index 019f14b..10c1a6d 100644
/**
* d_ancestor - search for an ancestor
diff --git a/fs/exec.c b/fs/exec.c
index 6be2aa0..1e003f9 100644
index 7eb8d21..56d7985 100644
--- a/fs/exec.c
+++ b/fs/exec.c
@@ -109,6 +109,7 @@ bool path_noexec(const struct path *path)
@ -42,7 +42,7 @@ index 6be2aa0..1e003f9 100644
#ifdef CONFIG_USELIB
/*
diff --git a/fs/fcntl.c b/fs/fcntl.c
index 74c255d..ec53ee1 100644
index 8cd01f7..bdd1c6c 100644
--- a/fs/fcntl.c
+++ b/fs/fcntl.c
@@ -85,6 +85,7 @@ int setfl(int fd, struct file * filp, unsigned long arg)
@ -54,10 +54,10 @@ index 74c255d..ec53ee1 100644
static void f_modown(struct file *filp, struct pid *pid, enum pid_type type,
int force)
diff --git a/fs/file_table.c b/fs/file_table.c
index 2dc9f38..7bf57df 100644
index 7ec0b3e..819ee07 100644
--- a/fs/file_table.c
+++ b/fs/file_table.c
@@ -148,6 +148,7 @@ struct file *get_empty_filp(void)
@@ -147,6 +147,7 @@ struct file *get_empty_filp(void)
}
return ERR_PTR(-ENFILE);
}
@ -65,7 +65,7 @@ index 2dc9f38..7bf57df 100644
/**
* alloc_file - allocate and initialize a 'struct file'
@@ -258,6 +259,7 @@ void flush_delayed_fput(void)
@@ -257,6 +258,7 @@ void flush_delayed_fput(void)
{
delayed_fput(NULL);
}
@ -73,7 +73,7 @@ index 2dc9f38..7bf57df 100644
static DECLARE_DELAYED_WORK(delayed_fput_work, delayed_fput);
@@ -300,6 +302,7 @@ void __fput_sync(struct file *file)
@@ -299,6 +301,7 @@ void __fput_sync(struct file *file)
}
EXPORT_SYMBOL(fput);
@ -81,7 +81,7 @@ index 2dc9f38..7bf57df 100644
void put_filp(struct file *file)
{
@@ -308,6 +311,7 @@ void put_filp(struct file *file)
@@ -307,6 +310,7 @@ void put_filp(struct file *file)
file_free(file);
}
}
@ -90,10 +90,10 @@ index 2dc9f38..7bf57df 100644
void __init files_init(void)
{
diff --git a/fs/inode.c b/fs/inode.c
index 517883c..5cece5e 100644
index 929a5a3..d93653e 100644
--- a/fs/inode.c
+++ b/fs/inode.c
@@ -1664,6 +1664,7 @@ int update_time(struct inode *inode, struct timespec *time, int flags)
@@ -1668,6 +1668,7 @@ int update_time(struct inode *inode, struct timespec *time, int flags)
return update_time(inode, time, flags);
}
@ -102,7 +102,7 @@ index 517883c..5cece5e 100644
/**
* touch_atime - update the access time
diff --git a/fs/namespace.c b/fs/namespace.c
index 312bdbd8..a5baeb5 100644
index 26ef600..a4b9707 100644
--- a/fs/namespace.c
+++ b/fs/namespace.c
@@ -517,6 +517,7 @@ void __mnt_drop_write(struct vfsmount *mnt)
@ -302,10 +302,10 @@ index 61cd28b..35570cd 100644
ssize_t
__vfs_getxattr(struct dentry *dentry, struct inode *inode, const char *name,
diff --git a/kernel/locking/lockdep.c b/kernel/locking/lockdep.c
index 2cd0282..af59768 100644
index 0dca42f..7bb20c5 100644
--- a/kernel/locking/lockdep.c
+++ b/kernel/locking/lockdep.c
@@ -167,6 +167,7 @@ inline struct lock_class *lockdep_hlock_class(struct held_lock *hlock)
@@ -151,6 +151,7 @@ inline struct lock_class *lockdep_hlock_class(struct held_lock *hlock)
}
return lock_classes + hlock->class_idx - 1;
}
@ -323,10 +323,10 @@ index 0fef395..83fb1ec 100644
}
+EXPORT_SYMBOL_GPL(task_work_run);
diff --git a/security/commoncap.c b/security/commoncap.c
index 4f8e093..f1e0544 100644
index 48620c9..4981104 100644
--- a/security/commoncap.c
+++ b/security/commoncap.c
@@ -1333,12 +1333,14 @@ int cap_mmap_addr(unsigned long addr)
@@ -1330,12 +1330,14 @@ int cap_mmap_addr(unsigned long addr)
}
return ret;
}