Add KEY_MICMUTE and enable it on Lenovo X220

this only shutsdown warnings concerning that key,
no real effect yet.

svn path=/dists/trunk/linux-2.6/; revision=17777
This commit is contained in:
Maximilian Attems 2011-07-02 19:57:43 +00:00
parent 2288a7163c
commit 39035feb5e
3 changed files with 55 additions and 0 deletions

1
debian/changelog vendored
View File

@ -9,6 +9,7 @@ linux-2.6 (3.0.0~rc5-1~experimental.2) UNRELEASED; urgency=low
* [x86_32] enable modular I2C_PXA.
* [x86] enable modular SENSORS_FAM15H_POWER.
* drm/i915: Hold struct_mutex during i915_save_state/i915_restore_state.
* [thinkpad] Add KEY_MICMUTE and enable it on Lenovo X220.
-- maximilian attems <maks@debian.org> Tue, 28 Jun 2011 12:10:21 +0200

View File

@ -0,0 +1,53 @@
From 0198af5884040ec6ded1558f5f3d4e696898a19f Mon Sep 17 00:00:00 2001
From: Andy Lutomirski <luto@MIT.EDU>
Date: Tue, 24 May 2011 15:16:43 -0400
Subject: [PATCH] Add KEY_MICMUTE and enable it on Lenovo X220
I suspect that this works on T410.
Signed-off-by: Andy Lutomirski <luto@mit.edu>
Signed-off-by: Matthew Garrett <mjg@redhat.com>
---
drivers/platform/x86/thinkpad_acpi.c | 11 ++++++++++-
include/linux/input.h | 2 ++
2 files changed, 12 insertions(+), 1 deletions(-)
diff --git a/drivers/platform/x86/thinkpad_acpi.c b/drivers/platform/x86/thinkpad_acpi.c
index 26c5b11..7bd829f 100644
--- a/drivers/platform/x86/thinkpad_acpi.c
+++ b/drivers/platform/x86/thinkpad_acpi.c
@@ -3186,8 +3186,17 @@ static int __init hotkey_init(struct ibm_init_struct *iibm)
KEY_VENDOR, /* 0x17: Thinkpad/AccessIBM/Lenovo */
/* (assignments unknown, please report if found) */
+ KEY_UNKNOWN, KEY_UNKNOWN,
+
+ /*
+ * The mic mute button only sends 0x1a. It does not
+ * automatically mute the mic or change the mute light.
+ */
+ KEY_MICMUTE, /* 0x1a: Mic mute (since ?400 or so) */
+
+ /* (assignments unknown, please report if found) */
KEY_UNKNOWN, KEY_UNKNOWN, KEY_UNKNOWN, KEY_UNKNOWN,
- KEY_UNKNOWN, KEY_UNKNOWN, KEY_UNKNOWN, KEY_UNKNOWN,
+ KEY_UNKNOWN,
},
};
diff --git a/include/linux/input.h b/include/linux/input.h
index 771d6d8..f26d3b7 100644
--- a/include/linux/input.h
+++ b/include/linux/input.h
@@ -438,6 +438,8 @@ struct input_keymap_entry {
#define KEY_WIMAX 246
#define KEY_RFKILL 247 /* Key that controls all radios */
+#define KEY_MICMUTE 248 /* Mute / unmute the microphone */
+
/* Code 255 is reserved for special needs of AT keyboard driver */
#define BTN_MISC 0x100
--
1.7.2.5

View File

@ -46,3 +46,4 @@
+ bugfix/ia64/nouveau-ACPI-support-is-dependent-on-X86.patch
+ features/all/rt2x00-Add-device-ID-for-RT539F-device.patch
+ bugfix/all/drm_i915_hold_struct_mutex.patch
+ bugfix/all/Add-KEY_MICMUTE-and-enable-it-on-Lenovo-X220.patch