Update patches to upstream versions

This commit is contained in:
Ben Hutchings 2016-02-21 15:30:51 +00:00
parent 8964473178
commit 38cac73239
7 changed files with 88 additions and 33 deletions

View File

@ -1,7 +1,7 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Mon, 14 Dec 2015 01:09:32 +0000
Subject: nvme: Stop installing kernel-only <linux/nvme.h> as UAPI
Forwarded: http://mid.gmane.org/20151214011442.GL28542@decadent.org.uk
Forwarded: not-needed
Fixes: 9d99a8dda154 ("nvme: move hardware structures out of the uapi ...")
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>

View File

@ -1,15 +1,23 @@
From: Markus Trippelsdorf <markus@trippelsdorf.de>
Subject: Add missing braces to if statement
Date: Mon, 14 Dec 2015 16:44:03 +0100
Origin: http://article.gmane.org/gmane.linux.kernel/2108038
Add missing braces to if statement.
Subject: perf annotate browser: Fix behaviour of Shift-Tab with nothing
focussed
Origin: https://git.kernel.org/linus/d4913cbd05bab685e49c8174896e563b2487d054
The issue was pointed out by gcc-6's -Wmisleading-indentation.
Acked-by: Ingo Molnar <mingo@kernel.org>
Signed-off-by: Markus Trippelsdorf <markus@trippelsdorf.de>
Acked-by: Ingo Molnar <mingo@kernel.org>
Cc: Ben Hutchings <ben@decadent.org.uk>
Cc: Matt Fleming <matt@codeblueprint.co.uk>
Cc: Peter Zijlstra <peterz@infradead.org>
Fixes: c97cf42219b7 ("perf top: Live TUI Annotation")
Link: http://lkml.kernel.org/r/20151214154403.GB1409@x4
Signed-off-by: Arnaldo Carvalho de Melo <acme@redhat.com>
---
tools/perf/ui/browsers/annotate.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/tools/perf/ui/browsers/annotate.c b/tools/perf/ui/browsers/annotate.c
index d4d7cc27252f..718bd46d47fa 100644
--- a/tools/perf/ui/browsers/annotate.c

View File

@ -1,18 +1,26 @@
From: Markus Trippelsdorf <markus@trippelsdorf.de>
Subject: Remove wrong semicolon in while loop
Date: Mon, 14 Dec 2015 16:43:35 +0100
Origin: http://article.gmane.org/gmane.linux.kernel/2108037
Subject: perf tests: Remove wrong semicolon in while loop in CQM test
Origin: https://git.kernel.org/linus/cf89813a5b514bff9b3b5e7eaf2090f22fba62e0
The while loop was spinning. Fix by removing a semicolon.
The issue was pointed out by gcc-6's -Wmisleading-indentation.
Signed-off-by: Markus Trippelsdorf <markus@trippelsdorf.de>
Reviewed-by: Matt Fleming <matt@codeblueprint.co.uk>
Acked-by: Ingo Molnar <mingo@kernel.org>
Signed-off-by: Markus Trippelsdorf <markus@trippelsdorf.de>
Cc: Ben Hutchings <ben@decadent.org.uk>
Cc: Peter Zijlstra <peterz@infradead.org>
Fixes: 035827e9f2bd ("perf tests: Add Intel CQM test")
Link: http://lkml.kernel.org/r/20151214154335.GA1409@x4
Signed-off-by: Arnaldo Carvalho de Melo <acme@redhat.com>
---
tools/perf/arch/x86/tests/intel-cqm.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/tools/perf/arch/x86/tests/intel-cqm.c b/tools/perf/arch/x86/tests/intel-cqm.c
index d28c1b6a3b54..fa5d17af88b7 100644
index 3e89ba825f6b..7f064eb37158 100644
--- a/tools/perf/arch/x86/tests/intel-cqm.c
+++ b/tools/perf/arch/x86/tests/intel-cqm.c
@@ -17,7 +17,7 @@ static pid_t spawn(void)

View File

@ -1,7 +1,7 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Wed, 13 Jan 2016 15:16:30 +0000
Subject: perf tools: Fix reading of build-id from vDSO
Forwarded: http://mid.gmane.org/20160113172301.GT28542@decadent.org.uk
Origin: https://git.kernel.org/linus/40c4a0f92aed570cc529a1e5c24c7e04a0ce8b85
We need to use the long name (the filename) when reading the build-id
from a DSO. Using the short name doesn't work for (at least) vDSOs.

View File

@ -17,9 +17,9 @@ alpha-uapi-add-support-for-__sane_userspace_types__.patch
nvme-stop-installing-kernel-only-linux-nvme.h-as-uap.patch
perf-tools-fix-reading-of-build-id-from-vdso.patch
perf-fix-misleadingly-indented-assignment-whitespace.patch
perf-add-missing-braces-to-if-statement.patch
perf-annotate-browser-fix-behaviour-of-shift-tab-with-nothing.patch
perf-tools-fix-unused-variables-x86_-32-64-_regoffse.patch
perf-remove-wrong-semicolon-in-while-loop.patch
revert-perf-tools-x86-build-perf-on-older-user-space.patch
perf-tools-fix-bpf-feature-check.patch
tools-stop-building-fixdep-in-source.patch
tools-build-use-fixdep-with-output-path-prefix.patch

View File

@ -0,0 +1,59 @@
From: Jiri Olsa <jolsa@redhat.com>
Date: Thu, 26 Nov 2015 19:50:55 +0100
Subject: tools build: Use fixdep with OUTPUT path prefix
Origin: https://git.kernel.org/linus/5e50426d5d9049dfdb8b2b18e761717e7e80a6ad
Adding OUTPUT path prefix for fixdep target so we use it properly in out
of tree builds.
If the fixdep already existed in the tree, the out of tree build would
see it already exist and did not build the out of tree version, as
reported by Arnaldo:
[acme@zoo linux]$ make O=/tmp/build/perf -C tools/perf
make: Entering directory '/home/git/linux/tools/perf'
BUILD: Doing 'make -j4' parallel build
make[2]: Nothing to be done for 'fixdep'.
make: Leaving directory '/home/git/linux/tools/perf'
Reported-and-Tested-by: Arnaldo Carvalho de Melo <acme@redhat.com>
Signed-off-by: Jiri Olsa <jolsa@kernel.org>
Cc: David Ahern <dsahern@gmail.com>
Cc: Namhyung Kim <namhyung@kernel.org>
Cc: Peter Zijlstra <a.p.zijlstra@chello.nl>
Cc: Wang Nan <wangnan0@huawei.com>
Link: http://lkml.kernel.org/r/20151126185055.GC19410@krava.brq.redhat.com
[ Fixed conflict with 5725dd8fa888 ("tools build: Clean CFLAGS and LDFLAGS for fixdep") ]
Signed-off-by: Arnaldo Carvalho de Melo <acme@redhat.com>
[bwh: Backported to 4.4: adjust context]
---
tools/build/Makefile | 2 +-
tools/build/Makefile.include | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/tools/build/Makefile b/tools/build/Makefile
index a93036272d43..0d5a0e3a8fa9 100644
--- a/tools/build/Makefile
+++ b/tools/build/Makefile
@@ -25,7 +25,7 @@ export Q srctree CC LD
MAKEFLAGS := --no-print-directory
build := -f $(srctree)/tools/build/Makefile.build dir=. obj
-all: fixdep
+all: $(OUTPUT)fixdep
clean:
$(call QUIET_CLEAN, fixdep)
diff --git a/tools/build/Makefile.include b/tools/build/Makefile.include
index 6254760290c9..be630bed66d2 100644
--- a/tools/build/Makefile.include
+++ b/tools/build/Makefile.include
@@ -4,7 +4,7 @@ ifdef CROSS_COMPILE
fixdep:
else
fixdep:
- $(Q)$(MAKE) -C $(srctree)/tools/build fixdep
+ $(Q)$(MAKE) -C $(srctree)/tools/build $(OUTPUT)fixdep
endif
.PHONY: fixdep

View File

@ -1,20 +0,0 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Fri, 19 Feb 2016 01:14:05 +0000
Subject: tools: Stop building fixdep in the source directory
Use the proper target, $(OUTPUT)fixdep, not fixdep.
Reported-by: Mattia Dongili <malattia@linux.it>
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
--- a/tools/build/Makefile.include
+++ b/tools/build/Makefile.include
@@ -4,7 +4,7 @@ ifdef CROSS_COMPILE
fixdep:
else
fixdep:
- $(Q)$(MAKE) -C $(srctree)/tools/build fixdep
+ $(Q)$(MAKE) -C $(srctree)/tools/build $(OUTPUT)fixdep
endif
.PHONY: fixdep