netfilter: x_tables: check for size overflow (CVE-2016-3135)

This commit is contained in:
Ben Hutchings 2016-03-17 01:15:05 +00:00
parent 29f3f5a875
commit 37886b6ea3
3 changed files with 31 additions and 0 deletions

1
debian/changelog vendored
View File

@ -129,6 +129,7 @@ linux (4.4.6-1) UNRELEASED; urgency=medium
- [mips*] smp.c: Fix uninitialised temp_foreign_map
- block: don't optimize for non-cloned bio in bio_get_last_bvec()
- target: Drop incorrect ABORT_TASK put for completed commands
* netfilter: x_tables: check for size overflow (CVE-2016-3135)
[ Ian Campbell ]
* [arm64] Enable ARCH_HISI (Hisilicon) and the set of currently available

View File

@ -0,0 +1,29 @@
From: Florian Westphal <fw@strlen.de>
Date: Thu, 10 Mar 2016 01:56:23 +0100
Subject: netfilter: x_tables: check for size overflow
Origin: https://git.kernel.org/cgit/linux/kernel/git/pablo/nf-next.git/commit?id=d157bd761585605b7882935ffb86286919f62ea1
Ben Hawkes says:
integer overflow in xt_alloc_table_info, which on 32-bit systems can
lead to small structure allocation and a copy_from_user based heap
corruption.
Reported-by: Ben Hawkes <hawkes@google.com>
Signed-off-by: Florian Westphal <fw@strlen.de>
Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
---
net/netfilter/x_tables.c | 3 +++
1 file changed, 3 insertions(+)
--- a/net/netfilter/x_tables.c
+++ b/net/netfilter/x_tables.c
@@ -658,6 +658,9 @@ struct xt_table_info *xt_alloc_table_inf
struct xt_table_info *info = NULL;
size_t sz = sizeof(*info) + size;
+ if (sz < sizeof(*info))
+ return NULL;
+
/* Pedantry: prevent them from hitting BUG() in vmalloc.c --RR */
if ((SMP_ALIGN(size) >> PAGE_SHIFT) + 2 > totalram_pages)
return NULL;

View File

@ -137,3 +137,4 @@ debian/revert-libata-align-ata_device-s-id-on-a-cacheline.patch
debian/module-fix-abi-change-in-4.4.5.patch
bugfix/x86/x86-efi-fix-boot-crash-by-always-mapping-boot-servic.patch
bugfix/x86/x86-mm-pat-fix-boot-crash-when-1gb-pages-are-not-supported.patch
bugfix/all/netfilter-x_tables-check-for-size-overflow.patch