Merge /dists/sid/linux-2.6.

svn path=/dists/trunk/linux-2.6/; revision=9025
This commit is contained in:
Bastian Blank 2007-06-26 10:27:56 +00:00
parent c561e2e84a
commit 36ea5550b6
7 changed files with 198 additions and 16 deletions

View File

@ -17,10 +17,12 @@ class: 32-bit PA-RISC
class: multiprocessor 32-bit PA-RISC
[parisc64]
cflags: -fno-cse-follow-jumps
class: 64-bit PA-RISC
override-host-type: hppa64-linux-gnu
[parisc64-smp]
cflags: -fno-cse-follow-jumps
class: multiprocessor 64-bit PA-RISC
override-host-type: hppa64-linux-gnu

View File

@ -105,16 +105,14 @@ CONFIG_CRC32=y
# enable new ethernet drivers
CONFIG_ARANYM=y
CONFIG_NATFEAT=y
# Atari SCSI driver is buggy
# CONFIG_ATARI_SCSI is not set
# enable ethernet
CONFIG_NET_ETHERNET=y
CONFIG_ATARILANCE=y
CONFIG_ATARI_NFETH=y
CONFIG_ATARI_ETHERNEC=m
CONFIG_ATARI_ETHERNEC=y
# 2.6.21
# disable atari_rom_isa for now
# CONFIG_ATARI_ROM_ISA is not set
# uses undefined isa_*
# CONFIG_PARPORT is not set
# CONFIG_PARPORT_PC
CONFIG_ATARI_ROM_ISA=y
CONFIG_ATARI_SCSI=y

View File

@ -83,6 +83,7 @@ class Gencontrol(Base):
def do_flavour_setup(self, vars, makeflags, arch, subarch, flavour, extra):
vars.update(self.config.get(('image', arch, subarch, flavour), {}))
for i in (
('cflags', 'CFLAGS'),
('compiler', 'COMPILER'),
('image-postproc', 'IMAGE_POSTPROC'),
('initramfs', 'INITRAMFS',),

180
debian/changelog vendored
View File

@ -73,6 +73,186 @@ linux-2.6 (2.6.21-3) UNRELEASED; urgency=low
-- maximilian attems <maks@debian.org> Sat, 19 May 2007 00:45:42 +0200
linux-2.6 (2.6.21-5) unstable; urgency=low
[ Christian T. Steigies ]
* [m68k] Add atari isa and scsi fixes
[ maximilian attems ]
* Add stable release 2.6.21.4:
- cpuset: prevent information leak in cpuset_tasks_read (CVE-2007-2875)
- random: fix error in entropy extraction (CVE-2007-2453 1 of 2)
- random: fix seeding with zero entropy (CVE-2007-2453 2 of 2)
- NETFILTER: {ip, nf}_conntrack_sctp: fix remotely triggerable NULL ptr
dereference (CVE-2007-2876)
* Add stable release 2.6.21.5:
- acpi: fix potential call to a freed memory section.
- USB: set the correct Interrupt interval in usb_bulk_msg
- i386: Fix K8/core2 oprofile on multiple CPUs
- ntfs_init_locked_inode(): fix array indexing
- ALSA: wm8750 typo fix
- neofb: Fix pseudo_palette array overrun in neofb_setcolreg
- e1000: disable polling before registering netdevice
- timer statistics: fix race
- x86: fix oprofile double free
- ALSA: usb-audio: explicitly match Logitech QuickCam
- zd1211rw: Add AL2230S RF support
- IPV4: Correct rp_filter help text.
- Fix AF_UNIX OOPS
- ICMP: Fix icmp_errors_use_inbound_ifaddr sysctl
- NET: Fix BMSR_100{HALF,FULL}2 defines in linux/mii.h
- SPARC64: Fix _PAGE_EXEC_4U check in sun4u I-TLB miss handler.
- SPARC64: Don't be picky about virtual-dma values on sun4v.
- SPARC64: Fix two bugs wrt. kernel 4MB TSB.
- cciss: fix pci_driver.shutdown while device is still active
- fix compat console unimap regression
- timer stats: speedups
- SPARC: Linux always started with 9600 8N1
- pci_ids: update patch for Intel ICH9M
- PCI: quirk disable MSI on via vt3351
- UML - Improve host PTRACE_SYSEMU check
- NET: parse ip:port strings correctly in in4_pton
- Char: cyclades, fix deadlock
- IPSEC: Fix panic when using inter address familiy IPsec on loopback.
- TCP: Use default 32768-61000 outgoing port range in all cases.
- TG3: Fix link problem on Dell's onboard 5906.
- fuse: fix mknod of regular file
- md: Avoid overflow in raid0 calculation with large components.
- md: Don't write more than is required of the last page of a bitmap
- make freezeable workqueues singlethread
- tty: fix leakage of -ERESTARTSYS to userland
- V4L/DVB (5593): Budget-ci: Fix tuning for TDM 1316 (160..200 MHz)
- Input: i8042 - fix AUX port detection with some chips
- SCSI: aacraid: Correct sa platform support.
(Was: [Bug 8469] Bad EIP value on pentium3 SMP kernel-2.6.21.1)
- BLUETOOTH: Fix locking in hci_sock_dev_event().
- hpt366: don't check enablebits for HPT36x
- ieee1394: eth1394: bring back a parent device
- NET: Fix race condition about network device name allocation.
- ALSA: hda-intel - Probe additional slots only if necessary
- ALSA: hda-intel - Fix detection of audio codec on Toshiba A100
- ahci: disable 64bit dma on sb600
- i386: HPET, check if the counter works
- Ignore bogus ACPI info for offline CPUs
- NOHZ: Rate limit the local softirq pending warning output
- Prevent going idle with softirq pending
- Work around Dell E520 BIOS reboot bug
- NET: "wrong timeout value" in sk_wait_data() v2
- IPV6 ROUTE: No longer handle ::/0 specially.
- x86_64: allocate sparsemem memmap above 4G
* Bump ABI to 2.
[ Bastian Blank ]
* Back out ABI fixing changes.
* Update vserver patch to 2.2.0-rc3.
-- Bastian Blank <waldi@debian.org> Fri, 22 Jun 2007 12:39:47 +0200
linux-2.6 (2.6.21-4) unstable; urgency=low
* [powerpc] Fix mkvmlinuz support.
* [s390] Add exception handler for diagnose 224.
-- Bastian Blank <waldi@debian.org> Sat, 26 May 2007 14:08:44 +0200
linux-2.6 (2.6.21-3) unstable; urgency=low
[ Gordon Farquharson ]
* arm/ixp4xx: Add patch to set NSLU2 timer frequency.
[ maximilian attems ]
* sparc64: enable USB_SERIAL. (closes: #412740)
* Apply stable 2.6.21.1.
* Add stable release 2.6.21.2:
- slob: fix page order calculation on not 4KB page
- libata-sff: Undo bug introduced with pci_iomap changes
- kbuild: fixdep segfault on pathological string-o-death
- IPMI: fix SI address space settings
- IPV6: Reverse sense of promisc tests in ip6_mc_input
- iop: fix iop_getttimeoffset
- iop13xx: fix i/o address translation
- arm: fix handling of svc mode undefined instructions
- CPUFREQ: powernow-k7: fix MHz rounding issue with perflib
- CPUFREQ: Support rev H AMD64s in powernow-k8
- CPUFREQ: Correct revision mask for powernow-k8
- JFS: Fix race waking up jfsIO kernel thread
- IPV6: Send ICMPv6 error on scope violations.
- SPARC64: Add missing cpus_empty() check in hypervisor xcall handling.
- SPARC64: Fix recursion in PROM tree building.
- SERIAL SUNHV: Add an ID string.
- SPARC64: Bump PROMINTR_MAX to 32.
- SPARC64: Be more resiliant with PCI I/O space regs.
- oom: fix constraint deadlock
- fix for bugzilla 8426: massive slowdown on SCSI CD/DVD drive connected to
mptspi driver
- x86_64 : Fix vgettimeofday()
- IPV6: Fix slab corruption running ip6sic
- IPSEC: Check validity of direction in xfrm_policy_byid
- CRYPTO: api: Read module pointer before freeing algorithm
- NET_SCHED: prio qdisc boundary condition
- reiserfs: suppress lockdep warning
- USB HID: hiddev - fix race between hiddev_send_event() and
hiddev_release()
- NETFILTER: {ip,nf}_nat_proto_gre: do not modify/corrupt GREv0 packets
through NAT
- fix leaky resv_huge_pages when cpuset is in use
- ACPI: Fix 2.6.21 boot regression on P4/HT
- TG3: Fix TSO bugs.
- TG3: Remove reset during MAC address changes.
- TG3: Update version and reldate.
- BNX2: Fix TSO problem with small MSS.
- BNX2: Block MII access when ifdown.
- BNX2: Save PCI state during suspend.
- BNX2: Update version and reldate.
- sis900: Allocate rx replacement buffer before rx operation
- knfsd: Avoid use of unitialised variables on error path when nfs exports.
- knfsd: rpc: fix server-side wrapping of krb5i replies
- md: Avoid a possibility that a read error can wrongly propagate through
- md/raid1 to a filesystem.
- fat: fix VFAT compat ioctls on 64-bit systems
- NETFILTER: {ip,nf}_conntrack: fix use-after-free in helper destroy
callback invocation
- ppp: Fix ppp_deflate issues with recent zlib_inflate changes
- NETPOLL: Fix TX queue overflow in trapped mode.
- NETPOLL: Remove CONFIG_NETPOLL_RX
- cxacru: Fix infinite loop when trying to cancel polling task
- TCP: zero out rx_opt in tcp_disconnect()
- ipv6: track device renames in snmp6
- skge: default WOL should be magic only (rev2)
- skge: allow WOL except for known broken chips
- sky2: allow 88E8056
- sky2: 88e8071 support not ready
- skge: crash on shutdown/suspend
- sky2: fix oops on shutdown
- udf: decrement correct link count in udf_rmdir
- ALSA: hda-codec - Fix resume of STAC92xx codecs
- sata_via: add missing PM hooks
- driver-core: don't free devt_attr till the device is released
- pci-quirks: disable MSI on RS400-200 and RS480
- highres/dyntick: prevent xtime lock contention
- clocksource: fix resume logic
- smc911x: fix compilation breakage wjen debug is on
- SCTP: Fix sctp_getsockopt_local_addrs_old() to use local storage.
- SCTP: Correctly copy addresses in sctp_copy_laddrs
- SCTP: Prevent OOPS if hmac modules didn't load
- IPV6: Do no rely on skb->dst before it is assigned.
- IPV6 ROUTE: Assign rt6i_idev for ip6_{prohibit,blk_hole}_entry.
[ Christian T. Steigies ]
* m68k: enable ATARI_SCSI and ATARI_ROM_ISA
[ Bastian Blank ]
* Fix linux/version.h in linux-libc-dev.
* Make it possible to specifiy special CFLAGS.
* [hppa] Reenable.
* [hppa] Workaround hppa64 failure.
* [hppa] Fix debugging in lws syscalls.
* Fix abi change.
* Add stable release 2.6.21.3:
- [PATCH] GEODE-AES: Allow in-place operations [CVE-2007-2451]
-- Bastian Blank <waldi@debian.org> Fri, 25 May 2007 10:57:48 +0200
linux-2.6 (2.6.21-2) unstable; urgency=low
[ Christian T. Steigies ]

View File

@ -37,7 +37,7 @@ class GenPatch(object):
if f.close() is not None:
raise RuntimeError
f = os.popen("cd %s; git log --pretty=oneline -r %s..%s" % (self.repo, tag_in, tag_out))
f = os.popen("cd %s; git log --pretty=oneline -r %s..%s^" % (self.repo, tag_in, tag_out))
out = file(os.path.join(self.path, log), 'w')
out.write(" * Add stable release %s:\n" % self.version.complete)
for line in f:

View File

@ -1,8 +1,8 @@
diff --git a/Makefile b/Makefile
index edfc2fd..2fb76d7 100644
index 1c018c4..a6583cc 100644
--- a/Makefile
+++ b/Makefile
@@ -176,9 +176,6 @@ # Note: Some architectures assign CROSS_
@@ -185,9 +185,6 @@ SUBARCH := $(shell uname -m | sed -e s/i.86/i386/ -e s/sun4u/sparc64/ \
ARCH ?= $(SUBARCH)
CROSS_COMPILE ?=
@ -12,15 +12,15 @@ index edfc2fd..2fb76d7 100644
KCONFIG_CONFIG ?= .config
# SHELL used by kbuild
@@ -298,6 +295,11 @@ LDFLAGS_MODULE = -r
CFLAGS_KERNEL =
AFLAGS_KERNEL =
@@ -320,6 +317,11 @@ AFLAGS := -D__ASSEMBLY__
KERNELRELEASE = $(shell cat include/config/kernel.release 2> /dev/null)
KERNELVERSION = $(VERSION).$(PATCHLEVEL).$(SUBLEVEL)$(EXTRAVERSION)
+-include .kernelvariables
+
+# Architecture as present in compile.h
+UTS_MACHINE := $(ARCH)
+
# Use LINUXINCLUDE when you must reference the include/ directory.
# Needed to be compatible with the O= option
export VERSION PATCHLEVEL SUBLEVEL KERNELRELEASE KERNELVERSION
export ARCH CONFIG_SHELL HOSTCC HOSTCFLAGS CROSS_COMPILE AS LD CC
export CPP AR NM STRIP OBJCOPY OBJDUMP MAKE AWK GENKSYMS PERL UTS_MACHINE

5
debian/rules.real vendored
View File

@ -131,6 +131,7 @@ else
echo 'override CROSS_COMPILE = $$(DEB_HOST_GNU_TYPE)-' >> '$(DIR)/.kernelvariables'
echo 'endif' >> '$(DIR)/.kernelvariables'
endif
echo 'CFLAGS += $(CFLAGS)' >> '$(DIR)/.kernelvariables'
cd '$(DIR)'; $(setup_env) make reportoldconfig
$(STAMPS_DIR)/setup-$(ARCH)-$(SUBARCH)-$(FLAVOUR)-$(TYPE): DIR=$(BUILD_DIR)/build-$(ARCH)-$(SUBARCH)-$(FLAVOUR)
@ -341,8 +342,8 @@ install-libc-dev_$(ARCH): $(STAMPS_DIR)/build-libc-dev
dh_testdir
dh_testroot
dh_clean -d -k
make -C '$(SOURCE_DIR)' headers_check ARCH=$(HEADERS_ARCH)
make -C '$(SOURCE_DIR)' headers_install ARCH=$(HEADERS_ARCH) INSTALL_HDR_PATH='$(DIR)'
$(setup_env) make -C '$(SOURCE_DIR)' headers_check ARCH=$(HEADERS_ARCH)
$(setup_env) make -C '$(SOURCE_DIR)' headers_install ARCH=$(HEADERS_ARCH) INSTALL_HDR_PATH='$(DIR)'
# XXX: Needs to be removed from libc6-dev
rm -rf '$(DIR)'/include/scsi
$(MAKE) -f debian/rules.real install-base