docs: sphinx-extensions: make rstFlatTable work with docutils 0.13

Thanks: Dmitry Shachnev <mitya57@debian.org>
Closes: #848349
This commit is contained in:
Salvatore Bonaccorso 2016-12-19 08:28:31 +01:00
parent be4cc8383e
commit 36b7372766
3 changed files with 43 additions and 0 deletions

2
debian/changelog vendored
View File

@ -162,6 +162,8 @@ linux (4.8.15-1) UNRELEASED; urgency=medium
* [rt] Update to 4.8.14-rt9
* netfilter: ipv6: nf_defrag: drop mangled skb on ream error (CVE-2016-9755)
* Ignore ABI changes in libnvdimm
* docs: sphinx-extensions: make rstFlatTable work with docutils 0.13.
Thanks to Dmitry Shachnev <mitya57@debian.org> (Closes: #848349)
[ Ben Hutchings ]
* [amd64] Re-enable LEGACY_VSYSCALL_EMULATE instead of LEGACY_VSYSCALL_NONE.

View File

@ -0,0 +1,40 @@
From: Dmitry Shachnev <mitya57@debian.org>
Date: Sun, 18 Dec 2016 13:11:46 +0300
Subject: docs: sphinx-extensions: make rstFlatTable work with docutils 0.13
Origin: https://git.kernel.org/linus/7a3bd0906838c816c22b27792c6c3fe4c53e0893
Bug-Debian: https://bugs.debian.org/848349
In docutils 0.13, the return type of get_column_widths method of the
Table directive has changed [1], which breaks our flat-table directive
and leads to a TypeError when trying to build the docs [2].
This patch adds support for the new return type, while keeping support
for older docutils versions too.
[1] https://sourceforge.net/p/docutils/patches/120/
[2] https://sourceforge.net/p/docutils/bugs/303/
Signed-off-by: Dmitry Shachnev <mitya57@xxxxxxxxxx>
---
Documentation/sphinx/rstFlatTable.py | 5 +++++
1 file changed, 5 insertions(+)
diff --git a/Documentation/sphinx/rstFlatTable.py b/Documentation/sphinx/rstFlatTable.py
index 55f2757..25feb0d 100755
--- a/Documentation/sphinx/rstFlatTable.py
+++ b/Documentation/sphinx/rstFlatTable.py
@@ -157,6 +157,11 @@ class ListTableBuilder(object):
def buildTableNode(self):
colwidths = self.directive.get_column_widths(self.max_cols)
+ if isinstance(colwidths, tuple):
+ # Since docutils 0.13, get_column_widths returns a (widths,
+ # colwidths) tuple, where widths is a string (i.e. 'auto').
+ # See https://sourceforge.net/p/docutils/patches/120/.
+ colwidths = colwidths[1]
stub_columns = self.directive.options.get('stub-columns', 0)
header_rows = self.directive.options.get('header-rows', 0)
--
2.1.4

View File

@ -64,6 +64,7 @@ bugfix/all/fs-add-module_softdep-declarations-for-hard-coded-cr.patch
bugfix/all/kbuild-do-not-use-hyphen-in-exported-variable-name.patch
bugfix/all/ext4-fix-bug-838544.patch
bugfix/all/mm-memcontrol-use-special-workqueue-for-creating-per-memcg-caches.patch
bugfix/all/docs-sphinx-extensions-make-rstFlatTable-work-with-d.patch
# Miscellaneous features