[armel/iop32x] Add missing #includes (fixes FTBFS)

svn path=/dists/trunk/linux-2.6/; revision=18910
This commit is contained in:
Ben Hutchings 2012-04-07 02:21:19 +00:00
parent 5ba5ce0d66
commit 36aa841844
4 changed files with 77 additions and 0 deletions

3
debian/changelog vendored
View File

@ -3,6 +3,9 @@ linux-2.6 (3.3.1-1~experimental.1) UNRELEASED; urgency=low
* New upstream stable update:
http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.3.1
[ Ben Hutchings ]
* [armel/iop32x] Add missing #includes (fixes FTBFS)
-- Ben Hutchings <ben@decadent.org.uk> Fri, 06 Apr 2012 20:35:03 +0100
linux-2.6 (3.3-1~experimental.1) experimental; urgency=low

View File

@ -0,0 +1,30 @@
From 139b280bb61305bc21cc8ba74309ca5c3b9e8840 Mon Sep 17 00:00:00 2001
From: Ben Hutchings <ben@decadent.org.uk>
Date: Sat, 7 Apr 2012 02:40:01 +0100
Subject: [PATCH 2/2] ARM: Fix missing #include for call to soft_restart() in
plat-iop/restart.c
This is for the stable 3.3.y branch only. The bug was fixed in
mainline as part of commit 9f97da78bf018206fb623cd351d454af2f105fe0
('Disintegrate asm/system.h for ARM').
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
arch/arm/plat-iop/restart.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/arch/arm/plat-iop/restart.c b/arch/arm/plat-iop/restart.c
index 6a85a0c..a6ee3b6 100644
--- a/arch/arm/plat-iop/restart.c
+++ b/arch/arm/plat-iop/restart.c
@@ -8,6 +8,7 @@
* published by the Free Software Foundation.
*/
#include <asm/hardware/iop3xx.h>
+#include <asm/system.h>
#include <mach/hardware.h>
void iop3xx_restart(char mode, const char *cmd)
--
1.7.9.5

View File

@ -0,0 +1,41 @@
From 7456ca98a1bec5feda73788d6c8cffac2143f5ff Mon Sep 17 00:00:00 2001
From: David Howells <dhowells@redhat.com>
Date: Fri, 23 Mar 2012 15:37:34 +0000
Subject: [PATCH 1/2] ARM: Fix missing linux/types.h #inclusion in
asm/hardware/iop3xx.h
commit 15e9b9b9ed268fa91e52c44d621f3d0296162d15 upstream.
arch/arm/include/asm/hardware/iop3xx.h needs to include linux/types.h to avoid
the following errors:
In file included from arch/arm/plat-iop/restart.c:10:0:
/data/fs/linux-2.6-fscache/arch/arm/include/asm/hardware/iop3xx.h:239:1: error: unknown type name 'u32'
/data/fs/linux-2.6-fscache/arch/arm/include/asm/hardware/iop3xx.h: In function 'read_tmr0':
/data/fs/linux-2.6-fscache/arch/arm/include/asm/hardware/iop3xx.h:241:2: error: unknown type name 'u32'
/data/fs/linux-2.6-fscache/arch/arm/include/asm/hardware/iop3xx.h: At top level:
/data/fs/linux-2.6-fscache/arch/arm/include/asm/hardware/iop3xx.h:246:31: error: unknown type name 'u32'
...
Signed-off-by: David Howells <dhowells@redhat.com>
---
arch/arm/include/asm/hardware/iop3xx.h | 3 +++
1 file changed, 3 insertions(+)
diff --git a/arch/arm/include/asm/hardware/iop3xx.h b/arch/arm/include/asm/hardware/iop3xx.h
index 077c323..2ff2c75 100644
--- a/arch/arm/include/asm/hardware/iop3xx.h
+++ b/arch/arm/include/asm/hardware/iop3xx.h
@@ -231,6 +231,9 @@ extern int iop3xx_get_init_atu(void);
#ifndef __ASSEMBLY__
+
+#include <linux/types.h>
+
void iop3xx_map_io(void);
void iop_init_cp6_handler(void);
void iop_init_time(unsigned long tickrate);
--
1.7.9.5

View File

@ -58,3 +58,6 @@
# Temporary, until the Xen regression is fixed
+ debian/revert-x86-ioapic-Add-register-level-checks-to-detec.patch
+ bugfix/arm/ARM-Fix-missing-linux-types.h-inclusion-in-asm-hardw.patch
+ bugfix/arm/ARM-Fix-missing-include-for-call-to-soft_restart-in-.patch