sis-agp: Remove SIS 760, handled by amd64-agp

svn path=/dists/sid/linux-2.6/; revision=15691
This commit is contained in:
Ben Hutchings 2010-05-16 22:14:19 +00:00
parent d894ded8f9
commit 368e89ed2b
3 changed files with 39 additions and 0 deletions

1
debian/changelog vendored
View File

@ -39,6 +39,7 @@ linux-2.6 (2.6.32-13) UNRELEASED; urgency=low
* libata: Disable HPA if it is only enabled after suspend
* V4L/DVB: budget: Select correct frontend drivers (Closes: #575223)
* 3c503: Fix IRQ probing (Closes: #566522)
* sis-agp: Remove SIS 760, handled by amd64-agp
[ Aurelien Jarno ]
* mips/swarm: fix boot from IDE based media (Sebastian Andrzej Siewior)

View File

@ -0,0 +1,37 @@
Subject: [PATCH 1/2] sis-agp: Remove SIS 760, handled by amd64-agp
From: Ben Hutchings <ben@decadent.org.uk>
To: David Airlie <airlied@linux.ie>
Cc: FUJITA Tomonori <fujita.tomonori@lab.ntt.co.jp>, LKML <linux-kernel@vger.kernel.org>
Date: Wed, 24 Mar 2010 03:33:48 +0000
SIS 760 is listed in the device tables for both amd64-agp and sis-agp.
amd64-agp is apparently preferable since it has workarounds for some
BIOS misconfigurations that sis-agp doesn't handle.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
drivers/char/agp/sis-agp.c | 8 --------
1 files changed, 0 insertions(+), 8 deletions(-)
diff --git a/drivers/char/agp/sis-agp.c b/drivers/char/agp/sis-agp.c
index 6c3837a..95fdd4d 100644
--- a/drivers/char/agp/sis-agp.c
+++ b/drivers/char/agp/sis-agp.c
@@ -415,14 +415,6 @@ static struct pci_device_id agp_sis_pci_table[] = {
.subvendor = PCI_ANY_ID,
.subdevice = PCI_ANY_ID,
},
- {
- .class = (PCI_CLASS_BRIDGE_HOST << 8),
- .class_mask = ~0,
- .vendor = PCI_VENDOR_ID_SI,
- .device = PCI_DEVICE_ID_SI_760,
- .subvendor = PCI_ANY_ID,
- .subdevice = PCI_ANY_ID,
- },
{ }
};
--
1.7.0

View File

@ -33,3 +33,4 @@
+ bugfix/all/drm-edid-Fix-1024x768@85Hz.patch
+ bugfix/all/3c503-Fix-IRQ-probing.patch
+ features/all/input-add-support-of-synaptics-clickpad-device.patch
+ bugfix/x86/sis-agp-Remove-SIS-760-handled-by-amd64-agp.patch