[sparc] sunxvr500: Support Intergraph graphics chips again (Closes: #508108)

svn path=/dists/sid/linux-2.6/; revision=15211
This commit is contained in:
Ben Hutchings 2010-02-19 02:42:12 +00:00
parent d78e608af7
commit 3682f00ce3
3 changed files with 4 additions and 13 deletions

2
debian/changelog vendored
View File

@ -6,6 +6,8 @@ linux-2.6 (2.6.32-9) UNRELEASED; urgency=low
* Ignore failure of lsusb when gathering information for bug reports
(Closes: #569725)
* macvlan: Add bridge, VEPA and private modes (Closes: #568756)
* [sparc] sunxvr500: Support Intergraph graphics chips again
(Closes: #508108)
[ maximilian attems]
* Postinst don't refercence k-p related manpage. (closes: #542208)

View File

@ -5,19 +5,7 @@ diff -aur a/drivers/video/sunxvr500.c b/drivers/video/sunxvr500.c
static struct pci_device_id e3d_pci_table[] = {
{ PCI_DEVICE(PCI_VENDOR_ID_3DLABS, 0x7a0), },
+ { PCI_DEVICE(PCI_VENDOR_ID_IGRAPH, 0x7a0), },
+ { PCI_DEVICE(0x1091, 0x7a0), },
{ PCI_DEVICE(PCI_VENDOR_ID_3DLABS, 0x7a2), },
{ .vendor = PCI_VENDOR_ID_3DLABS,
.device = PCI_ANY_ID,
diff -aur a/include/linux/pci_ids.h b/include/linux/pci_ids.h
--- a/include/linux/pci_ids.h 2008-11-20 18:02:37.000000000 -0500
+++ b/include/linux/pci_ids.h 2008-12-01 15:43:04.000000000 -0500
@@ -930,6 +930,8 @@
#define PCI_DEVICE_ID_SUN_TOMATILLO 0xa801
#define PCI_DEVICE_ID_SUN_CASSINI 0xabba
+#define PCI_VENDOR_ID_IGRAPH 0x1091
+
#define PCI_VENDOR_ID_CMD 0x1095
#define PCI_DEVICE_ID_CMD_643 0x0643
#define PCI_DEVICE_ID_CMD_646 0x0646

View File

@ -8,3 +8,4 @@
+ features/all/hwmon-Add-driver-for-VIA-CPU-core-temperature.patch
+ features/all/wireless-report-reasonable-bitrate-for-MCS-rates-th.patch
+ bugfix/all/efifb_fix_v2.patch
+ features/sparc/video-sunxvr500-intergraph.patch