Add a patch by David Miller to fix the strace

breakage on sparc64 introduced in 2.6.13.

svn path=/dists/trunk/linux-2.6/; revision=5378
This commit is contained in:
Jurij Smakov 2006-01-09 07:32:26 +00:00
parent 8917fde5a2
commit 367a28cb47
3 changed files with 29 additions and 0 deletions

5
debian/changelog vendored
View File

@ -23,6 +23,11 @@ linux-2.6 (2.6.15-2) UNRELEASED; urgency=low
[ Bastian Blank ]
* Remove pre-sarge conflict with hotplug.
[ Jurij Smakov ]
* [sparc64] Add sparc64-entry-strace.patch fixing strace breakage
introduced in 2.6.13. (Closes: #339562)
Ref: http://marc.theaimsgroup.com/?l=linux-sparc&m=113678944402745&w=2
-- maximilian attems <maks@sternwelten.at> Sat, 7 Jan 2006 19:25:19 +0100
linux-2.6 (2.6.15-1) unstable; urgency=low

View File

@ -3,3 +3,4 @@
+ alpha-generic-irq-1.patch
+ alpha-generic-irq-2.patch
# + buslogic-pci-id-table.patch Commented out because it is missing.
+ sparc64-entry-strace.patch

View File

@ -0,0 +1,23 @@
# In http://marc.theaimsgroup.com/?l=linux-sparc&m=113678944402745&w=2
# David Miller wrote:
#
# We're spamming the existing flags value in register %l0, thus
# corrupting the subsequent tracing flag et al. checks.
#
# This should fix it:
#
# diff --git a/arch/sparc64/kernel/entry.S b/arch/sparc64/kernel/entry.S
# index 11a8484..86ff6a9 100644
--- a/arch/sparc64/kernel/entry.S
+++ b/arch/sparc64/kernel/entry.S
@@ -1657,8 +1657,8 @@ ret_sys_call:
/* Check if force_successful_syscall_return()
* was invoked.
*/
- ldub [%curptr + TI_SYS_NOERROR], %l0
- brz,pt %l0, 1f
+ ldub [%curptr + TI_SYS_NOERROR], %l1
+ brz,pt %l1, 1f
nop
ba,pt %xcc, 80f
stb %g0, [%curptr + TI_SYS_NOERROR]