lockdep: Stub task_struct::state

This commit is contained in:
Ben Hutchings 2018-07-03 06:20:46 +01:00
parent a14e37b110
commit 353c1b13ce
3 changed files with 26 additions and 0 deletions

1
debian/changelog vendored
View File

@ -9,6 +9,7 @@ linux (4.18~rc3-1~exp1) UNRELEASED; urgency=medium
- [x86,arm64] PCI: HOTPLUG_PCI_SHPC is now built-in
* Move config files from linux-source-<version> to an arch-dependent
linux-config-<version> package
* lockdep: Stub task_struct::state
[ YunQiang Su ]
* [mips*r6*] Enable dtb building for boston.

View File

@ -0,0 +1,24 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Tue, 03 Jul 2018 06:19:07 +0100
Subject: lockdep: Stub task_struct::state
---
--- a/tools/include/linux/lockdep.h
+++ b/tools/include/linux/lockdep.h
@@ -31,12 +31,16 @@ struct task_struct {
gfp_t lockdep_reclaim_gfp;
int pid;
char comm[17];
+ long state;
};
extern struct task_struct *__curr(void);
#define current (__curr())
+/* lockdep checks task_struct::state == TASK_RUNNING */
+#define TASK_RUNNING 0
+
static inline int debug_locks_off(void)
{
return 1;

View File

@ -152,6 +152,7 @@ bugfix/all/tools-build-remove-bpf-run-time-check-at-build-time.patch
bugfix/all/cpupower-bump-soname-version.patch
bugfix/all/cpupower-fix-checks-for-cpu-existence.patch
bugfix/all/lockdep-stub-nmi-watchdog-reset.patch
bugfix/all/lockdep-stub-task_struct-state.patch
# wireless: Disable regulatory.db direct loading (until we sort out signing)
debian/wireless-disable-regulatory.db-direct-loading.patch