[hppa] clear floating point exception flag on SIGFPE signal

(Closes: #559406)

svn path=/dists/sid/linux-2.6/; revision=15820
This commit is contained in:
dann frazier 2010-06-01 15:58:28 +00:00
parent b60d976b38
commit 34b3ac241f
3 changed files with 36 additions and 0 deletions

7
debian/changelog vendored
View File

@ -1,3 +1,10 @@
linux-2.6 (2.6.32-16) UNRELEASED; urgency=low
* [hppa] clear floating point exception flag on SIGFPE signal
(Closes: #559406)
-- dann frazier <dannf@debian.org> Tue, 01 Jun 2010 09:23:57 -0600
linux-2.6 (2.6.32-15) unstable; urgency=low
[ Ben Hutchings ]

View File

@ -0,0 +1,28 @@
commit 550f0d922286556c7ea43974bb7921effb5a5278
Author: Helge Deller <deller@gmx.de>
Date: Mon May 3 20:44:21 2010 +0000
parisc: clear floating point exception flag on SIGFPE signal
Clear the floating point exception flag before returning to
user space. This is needed, else the libc trampoline handler
may hit the same SIGFPE again while building up a trampoline
to a signal handler.
Fixes debian bug #559406.
Signed-off-by: Helge Deller <deller@gmx.de>
Signed-off-by: Kyle McMartin <kyle@mcmartin.ca>
diff --git a/arch/parisc/math-emu/decode_exc.c b/arch/parisc/math-emu/decode_exc.c
index 3ca1c61..27a7492 100644
--- a/arch/parisc/math-emu/decode_exc.c
+++ b/arch/parisc/math-emu/decode_exc.c
@@ -342,6 +342,7 @@ decode_fpu(unsigned int Fpu_register[], unsigned int trap_counts[])
return SIGNALCODE(SIGFPE, FPE_FLTINV);
case DIVISIONBYZEROEXCEPTION:
update_trap_counts(Fpu_register, aflags, bflags, trap_counts);
+ Clear_excp_register(exception_index);
return SIGNALCODE(SIGFPE, FPE_FLTDIV);
case INEXACTEXCEPTION:
update_trap_counts(Fpu_register, aflags, bflags, trap_counts);

1
debian/patches/series/16 vendored Normal file
View File

@ -0,0 +1 @@
+ bugfix/parisc/clear-fp-exception-flag-on-SIGFPE.patch