topology: Provide CPU topology in sysfs in !SMP configurations (Closes: #649216)

svn path=/dists/sid/linux-2.6/; revision=18330
This commit is contained in:
Ben Hutchings 2011-11-28 05:07:47 +00:00
parent 0e5c2382cc
commit 343ef5a0cc
3 changed files with 48 additions and 0 deletions

2
debian/changelog vendored
View File

@ -17,6 +17,8 @@ linux-2.6 (3.1.3-1) UNRELEASED; urgency=low
* lirc_serial: Fix various bugs that may result in a crash, deadlock or
other failure (Closes: #645811)
* amilo-rfkill: Use proper functions to write to the i8042 safely
* topology: Provide CPU topology in sysfs in !SMP configurations
(Closes: #649216)
-- Ben Hutchings <ben@decadent.org.uk> Tue, 22 Nov 2011 05:26:25 +0000

View File

@ -0,0 +1,44 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Thu, 24 Nov 2011 07:04:39 +0000
Subject: [PATCH] topology: Provide CPU topology in sysfs in !SMP
configurations
commit ccbc60d3e19a1b6ae66ca0d89b3da02dde62088b upstream.
We should provide topology information to userland even if it's not
very interesting. The current code appears to work properly for !SMP
(tested on i386).
Reference: http://bugs.debian.org/649216
Reported-by: Marcus Osdoba <marcus.osdoba@googlemail.com>
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
---
drivers/base/Makefile | 4 ++--
1 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/base/Makefile b/drivers/base/Makefile
index 99a375a..1334d89 100644
--- a/drivers/base/Makefile
+++ b/drivers/base/Makefile
@@ -3,7 +3,8 @@
obj-y := core.o sys.o bus.o dd.o syscore.o \
driver.o class.o platform.o \
cpu.o firmware.o init.o map.o devres.o \
- attribute_container.o transport_class.o
+ attribute_container.o transport_class.o \
+ topology.o
obj-$(CONFIG_DEVTMPFS) += devtmpfs.o
obj-y += power/
obj-$(CONFIG_HAS_DMA) += dma-mapping.o
@@ -12,7 +13,6 @@ obj-$(CONFIG_ISA) += isa.o
obj-$(CONFIG_FW_LOADER) += firmware_class.o
obj-$(CONFIG_NUMA) += node.o
obj-$(CONFIG_MEMORY_HOTPLUG_SPARSE) += memory.o
-obj-$(CONFIG_SMP) += topology.o
ifeq ($(CONFIG_SYSFS),y)
obj-$(CONFIG_MODULES) += module.o
endif
--
1.7.7.3

View File

@ -77,3 +77,5 @@
+ bugfix/all/0003-media-staging-lirc_serial-Fix-deadlock-on-resume-fai.patch
+ bugfix/all/0004-media-staging-lirc_serial-Fix-bogus-error-codes.patch
+ bugfix/all/0005-media-staging-lirc_serial-Do-not-assume-error-codes-.patch
+ features/all/topology-Provide-CPU-topology-in-sysfs-in-SMP-configura.patch