[armhf] ARM: sun4i: dt: Add bindings for USB clocks (fixes FTBFS, Closes: #746420)

svn path=/dists/sid/linux/; revision=21293
This commit is contained in:
Ben Hutchings 2014-05-01 01:18:31 +00:00
parent b5e26fe5b4
commit 338c83984c
4 changed files with 35 additions and 2 deletions

2
debian/changelog vendored
View File

@ -5,6 +5,8 @@ linux (3.14.2-2) UNRELEASED; urgency=medium
* net: Start with correct mac_len in skb_network_protocol (Closes: #746453)
* [x86] ACPI/Processor: Fix failure of loading acpi-cpufreq driver
(Closes: #746448)
* [armhf] ARM: sun4i: dt: Add bindings for USB clocks (fixes FTBFS,
Closes: #746420)
-- Ben Hutchings <ben@decadent.org.uk> Thu, 01 May 2014 01:50:30 +0100

View File

@ -14,7 +14,7 @@ Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com>
--- a/arch/arm/boot/dts/sun4i-a10.dtsi
+++ b/arch/arm/boot/dts/sun4i-a10.dtsi
@@ -366,6 +366,38 @@
@@ -375,6 +375,38 @@
status = "disabled";
};
@ -53,7 +53,7 @@ Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com>
spi2: spi@01c17000 {
compatible = "allwinner,sun4i-a10-spi";
reg = <0x01c17000 0x1000>;
@@ -377,6 +409,26 @@
@@ -386,6 +418,26 @@
#size-cells = <0>;
};

View File

@ -0,0 +1,30 @@
From: Roman Byshko <rbyshko@gmail.com>
Date: Fri, 7 Feb 2014 16:21:51 +0100
Subject: ARM: sun4i: dt: Add bindings for USB clocks
Origin: https://git.kernel.org/linus/0076c8bdb417a96209e28755cf5156bd4439737b
Signed-off-by: Roman Byshko <rbyshko@gmail.com>
Signed-off-by: Hans de Goede <hdegoede@redhat.com>
Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com>
---
arch/arm/boot/dts/sun4i-a10.dtsi | 9 +++++++++
1 file changed, 9 insertions(+)
--- a/arch/arm/boot/dts/sun4i-a10.dtsi
+++ b/arch/arm/boot/dts/sun4i-a10.dtsi
@@ -305,6 +305,15 @@
clock-output-names = "ir1";
};
+ usb_clk: clk@01c200cc {
+ #clock-cells = <1>;
+ #reset-cells = <1>;
+ compatible = "allwinner,sun4i-a10-usb-clk";
+ reg = <0x01c200cc 0x4>;
+ clocks = <&pll6 1>;
+ clock-output-names = "usb_ohci0", "usb_ohci1", "usb_phy";
+ };
+
spi3_clk: clk@01c200d4 {
#clock-cells = <0>;
compatible = "allwinner,sun4i-mod0-clk";

View File

@ -81,6 +81,7 @@ features/arm/0002-spi-sun6i-Fix-define-for-SUN6I_TFR_CTL_CS_MASK.patch
features/arm/0003-spi-sun6i-Set-bits_per_word_mask-to-only-support-8-b.patch
features/arm/ARM-dt-sun4i-Add-A10-SPI-controller-nodes.patch
features/arm/PHY-sunxi-Add-driver-for-sunxi-usb-phy.patch
features/arm/ARM-sun4i-dt-Add-bindings-for-USB-clocks.patch
features/arm/ARM-sun4i-dt-Add-USB-host-bindings.patch
bugfix/all/net-Start-with-correct-mac_len-in-skb_network_protoc.patch
bugfix/x86/ACPI-Processor-Fix-failure-of-loading-acpi-cpufreq-driver.patch