[arm] Remove use of possibly undefined BUILD_BUG_ON in <asm/bug.h> (fixes FTBFS)

svn path=/dists/trunk/linux-2.6/; revision=18449
This commit is contained in:
Ben Hutchings 2012-01-02 13:24:06 +00:00
parent efebeb308a
commit 3341c6b5ba
3 changed files with 30 additions and 0 deletions

2
debian/changelog vendored
View File

@ -1,6 +1,8 @@
linux-2.6 (3.2~rc7-1~experimental.2) UNRELEASED; urgency=low
* media/dvb: Enable DVB_USB_IT913X as module (Closes: #653776)
* [arm] Remove use of possibly undefined BUILD_BUG_ON in <asm/bug.h>
(fixes FTBFS)
-- Ben Hutchings <ben@decadent.org.uk> Mon, 02 Jan 2012 02:55:28 +0000

View File

@ -0,0 +1,27 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Mon, 2 Jan 2012 02:50:42 +0000
Subject: [PATCH] ARM: Remove use of possibly-undefined BUILD_BUG_ON in
<asm/bug.h>
<asm/bug.h> may be included by either <linux/bug.h> or
<linux/kernel.h> but only the latter will define BUILD_BUG_ON.
Bodge it until there is a proper upstream fix.
---
arch/arm/include/asm/bug.h | 1 -
1 files changed, 0 insertions(+), 1 deletions(-)
diff --git a/arch/arm/include/asm/bug.h b/arch/arm/include/asm/bug.h
index 9abe7a0..fac79dc 100644
--- a/arch/arm/include/asm/bug.h
+++ b/arch/arm/include/asm/bug.h
@@ -32,7 +32,6 @@
#define __BUG(__file, __line, __value) \
do { \
- BUILD_BUG_ON(sizeof(struct bug_entry) != 12); \
asm volatile("1:\t" BUG_INSTR_TYPE #__value "\n" \
".pushsection .rodata.str, \"aMS\", %progbits, 1\n" \
"2:\t.asciz " #__file "\n" \
--
1.7.7.3

View File

@ -57,3 +57,4 @@
+ features/all/topology-Provide-CPU-topology-in-sysfs-in-SMP-configura.patch
+ debian/x86-memtest-WARN-if-bad-RAM-found.patch
+ debian/ARM-Remove-use-of-possibly-undefined-BUILD_BUG_ON-in.patch