Add yet more dependencies for the EFI stub fix

svn path=/dists/sid/linux-2.6/; revision=18960
This commit is contained in:
Ben Hutchings 2012-04-29 06:58:16 +00:00
parent 5f6354e7f6
commit 33398c2c85
7 changed files with 161 additions and 5 deletions

View File

@ -1,6 +1,6 @@
From: Matt Fleming <matt.fleming@intel.com>
Date: Tue, 28 Feb 2012 13:37:20 +0000
Subject: [PATCH 12/14] tools/include: Add byteshift headers for endian access
Subject: [PATCH 12/17] tools/include: Add byteshift headers for endian access
commit a07f7672d7cf0ff0d6e548a9feb6e0bd016d9c6c upstream.

View File

@ -0,0 +1,62 @@
From: Matt Fleming <matt.fleming@intel.com>
Date: Tue, 28 Feb 2012 13:37:22 +0000
Subject: [PATCH 13/17] x86, mkpiggy: Don't open code put_unaligned_le32()
commit 12871c568305a0b20f116315479a18cd46882e9b upstream.
Use the new headers in tools/include instead of rolling our own
put_unaligned_le32() implementation.
Cc: H. Peter Anvin <hpa@zytor.com>
Signed-off-by: Matt Fleming <matt.fleming@intel.com>
Link: http://lkml.kernel.org/r/1330436245-24875-4-git-send-email-matt@console-pimps.org
Signed-off-by: H. Peter Anvin <hpa@zytor.com>
---
arch/x86/boot/compressed/Makefile | 1 +
arch/x86/boot/compressed/mkpiggy.c | 11 ++---------
2 files changed, 3 insertions(+), 9 deletions(-)
diff --git a/arch/x86/boot/compressed/Makefile b/arch/x86/boot/compressed/Makefile
index b123b9a..fd55a2f 100644
--- a/arch/x86/boot/compressed/Makefile
+++ b/arch/x86/boot/compressed/Makefile
@@ -22,6 +22,7 @@ LDFLAGS := -m elf_$(UTS_MACHINE)
LDFLAGS_vmlinux := -T
hostprogs-y := mkpiggy
+HOST_EXTRACFLAGS += -I$(srctree)/tools/include
VMLINUX_OBJS = $(obj)/vmlinux.lds $(obj)/head_$(BITS).o $(obj)/misc.o \
$(obj)/string.o $(obj)/cmdline.o $(obj)/early_serial_console.o \
diff --git a/arch/x86/boot/compressed/mkpiggy.c b/arch/x86/boot/compressed/mkpiggy.c
index 46a8238..958a641 100644
--- a/arch/x86/boot/compressed/mkpiggy.c
+++ b/arch/x86/boot/compressed/mkpiggy.c
@@ -29,14 +29,7 @@
#include <stdio.h>
#include <string.h>
#include <inttypes.h>
-
-static uint32_t getle32(const void *p)
-{
- const uint8_t *cp = p;
-
- return (uint32_t)cp[0] + ((uint32_t)cp[1] << 8) +
- ((uint32_t)cp[2] << 16) + ((uint32_t)cp[3] << 24);
-}
+#include <tools/le_byteshift.h>
int main(int argc, char *argv[])
{
@@ -69,7 +62,7 @@ int main(int argc, char *argv[])
}
ilen = ftell(f);
- olen = getle32(&olen);
+ olen = get_unaligned_le32(&olen);
fclose(f);
/*
--
1.7.10

View File

@ -0,0 +1,41 @@
From: Matt Fleming <matt.fleming@intel.com>
Date: Tue, 28 Feb 2012 13:37:23 +0000
Subject: [PATCH 14/17] x86, boot: Restrict CFLAGS for hostprogs
commit d40f833630a1299fd377408dc8d8fac370d621b0 upstream.
Currently tools/build has access to all the kernel headers in
$(srctree). This is unnecessary and could potentially allow
tools/build to erroneously include kernel headers when it should only
be including userspace-exported headers.
Unfortunately, mkcpustr still needs access to some of the asm kernel
headers, so explicitly special case that hostprog.
Cc: H. Peter Anvin <hpa@zytor.com>
Signed-off-by: Matt Fleming <matt.fleming@intel.com>
Link: http://lkml.kernel.org/r/1330436245-24875-5-git-send-email-matt@console-pimps.org
Signed-off-by: H. Peter Anvin <hpa@zytor.com>
---
arch/x86/boot/Makefile | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/arch/x86/boot/Makefile b/arch/x86/boot/Makefile
index 95365a8..3e02148 100644
--- a/arch/x86/boot/Makefile
+++ b/arch/x86/boot/Makefile
@@ -37,8 +37,9 @@ setup-y += video-bios.o
targets += $(setup-y)
hostprogs-y := mkcpustr tools/build
-HOST_EXTRACFLAGS += $(LINUXINCLUDE)
-
+HOSTCFLAGS_mkcpustr.o := -I$(srctree)/arch/$(SRCARCH)/include
+HOST_EXTRACFLAGS += -I$(objtree)/include -I$(srctree)/tools/include \
+ -include $(srctree)/include/linux/kconfig.h
$(obj)/cpu.o: $(obj)/cpustr.h
quiet_cmd_cpustr = CPUSTR $@
--
1.7.10

View File

@ -1,6 +1,6 @@
From: Matt Fleming <matt.fleming@intel.com>
Date: Tue, 28 Feb 2012 13:37:24 +0000
Subject: [PATCH 13/14] x86, efi: Fix endian issues and unaligned accesses
Subject: [PATCH 15/17] x86, efi: Fix endian issues and unaligned accesses
commit 92f42c50f227ad228f815a8f4eec872524dae3a5 upstream.

View File

@ -0,0 +1,50 @@
From: "H. Peter Anvin" <hpa@zytor.com>
Date: Thu, 22 Mar 2012 11:08:18 -0700
Subject: [PATCH 16/17] x86, boot: Correct CFLAGS for hostprogs
commit 446e1c86d51d0823e003a43a2b85c430efce2733 upstream.
This is a partial revert of commit:
d40f833 "Restrict CFLAGS for hostprogs"
The endian-manipulation macros in tools/include need <linux/types.h>,
but the hostprogs in arch/x86/boot need several headers from the
kernel build tree, which means we have to add the kernel headers to
the include path. This picks up <linux/types.h> from the kernel tree,
which gives a warning.
Since this use of <linux/types.h> is intentional, add
-D__EXPORTED_HEADERS__ to the command line to silence the warning.
A better way to fix this would be to always install the exported
kernel headers into $(objtree)/usr/include as a standard part of the
kernel build, but that is a lot more involved.
Reported-by: Linus Torvalds <torvalds@linux-foundation.org>
Acked-by: Matt Fleming <matt.fleming@intel.com>
Link: http://lkml.kernel.org/r/1330436245-24875-5-git-send-email-matt@console-pimps.org
Signed-off-by: H. Peter Anvin <hpa@zytor.com>
---
arch/x86/boot/Makefile | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/arch/x86/boot/Makefile b/arch/x86/boot/Makefile
index 3e02148..5a747dd 100644
--- a/arch/x86/boot/Makefile
+++ b/arch/x86/boot/Makefile
@@ -37,9 +37,9 @@ setup-y += video-bios.o
targets += $(setup-y)
hostprogs-y := mkcpustr tools/build
-HOSTCFLAGS_mkcpustr.o := -I$(srctree)/arch/$(SRCARCH)/include
-HOST_EXTRACFLAGS += -I$(objtree)/include -I$(srctree)/tools/include \
- -include $(srctree)/include/linux/kconfig.h
+HOST_EXTRACFLAGS += -I$(srctree)/tools/include $(LINUXINCLUDE) \
+ -D__EXPORTED_HEADERS__
+
$(obj)/cpu.o: $(obj)/cpustr.h
quiet_cmd_cpustr = CPUSTR $@
--
1.7.10

View File

@ -1,6 +1,6 @@
From: Matt Fleming <matt.fleming@intel.com>
Date: Sun, 15 Apr 2012 16:06:04 +0100
Subject: [PATCH 14/14] x86, efi: Add dedicated EFI stub entry point
Subject: [PATCH 17/17] x86, efi: Add dedicated EFI stub entry point
commit b1994304fc399f5d3a5368c81111d713490c4799 upstream.

View File

@ -184,8 +184,11 @@
+ features/x86/efi-stub/0010-x86-efi-Break-up-large-initrd-reads.patch
+ features/x86/efi-stub/0011-x86-efi-Fix-pointer-math-issue-in-handle_ramdisks.patch
+ features/x86/efi-stub/0012-tools-include-Add-byteshift-headers-for-endian-acces.patch
+ features/x86/efi-stub/0013-x86-efi-Fix-endian-issues-and-unaligned-accesses.patch
+ features/x86/efi-stub/0014-x86-efi-Add-dedicated-EFI-stub-entry-point.patch
+ features/x86/efi-stub/0013-x86-mkpiggy-Don-t-open-code-put_unaligned_le32.patch
+ features/x86/efi-stub/0014-x86-boot-Restrict-CFLAGS-for-hostprogs.patch
+ features/x86/efi-stub/0015-x86-efi-Fix-endian-issues-and-unaligned-accesses.patch
+ features/x86/efi-stub/0016-x86-boot-Correct-CFLAGS-for-hostprogs.patch
+ features/x86/efi-stub/0017-x86-efi-Add-dedicated-EFI-stub-entry-point.patch
+ bugfix/all/brcmsmac-INTERMEDIATE-but-not-AMPDU-only-when-tracin.patch
+ bugfix/all/NFSv4-Rate-limit-the-state-manager-for-lock-reclaim-.patch