tools/build: Fix bpf(2) feature test (fixes FTBFS on alpha, sh4; closes: #822364)

This commit is contained in:
Ben Hutchings 2016-04-28 16:27:44 +02:00
parent 5f25a78c8e
commit 32586f7a95
2 changed files with 13 additions and 1 deletions

2
debian/changelog vendored
View File

@ -132,6 +132,8 @@ linux (4.5.2-1) UNRELEASED; urgency=medium
result in file conflicts
* linux-perf: Move tips.txt to /usr/share/doc/linux-perf-<version>
(Closes: #821741)
* tools/build: Fix bpf(2) feature test (fixes FTBFS on alpha, sh4;
closes: #822364)
[ Aurelien Jarno ]
* [mips*] Emulate unaligned LDXC1 and SDXC1 instructions.

View File

@ -6,11 +6,21 @@ It is not correct to test that a syscall works on the build system's
kernel. We might be building on an earlier kernel version or with
security restrictions that block bpf().
Also fix the test for whether __NR_bpf is defined.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
--- a/tools/build/feature/test-bpf.c
+++ b/tools/build/feature/test-bpf.c
@@ -28,9 +28,5 @@ int main(void)
@@ -9,6 +9,7 @@
# define __NR_bpf 321
# elif defined(__aarch64__)
# define __NR_bpf 280
+# else
# error __NR_bpf not defined. libbpf does not support your arch.
# endif
#endif
@@ -28,9 +29,5 @@ int main(void)
attr.kern_version = 0;
attr = attr;