Update to 4.17-rc6

This commit is contained in:
Romain Perier 2018-05-22 21:03:54 +02:00
parent 90aece9ead
commit 3230e66a9c
2 changed files with 21 additions and 8 deletions

7
debian/changelog vendored
View File

@ -1,7 +1,12 @@
linux (4.17~rc5-1~exp1) UNRELEASED; urgency=medium
linux (4.17~rc6-1~exp1) UNRELEASED; urgency=medium
* New upstream release candidate
[ Romain Perier]
* Update patch debian/wireless-disable-regulatory.db-direct-loading.patch to
fix a FTBFS with undefined symbol reg_query_regdb_wmm() that is used by
wireless driver iwlwifi.
[ Luca Boccassi ]
* Disable building linux-doc-* and tools documentation when the "nodoc"
build profile is used.

View File

@ -8,10 +8,11 @@ Don't complain about being unable to load regulatory.db directly.
This is expected until we generate a signing key and update
wireless-regdb to be signed with it.
---
--- a/net/wireless/reg.c
+++ b/net/wireless/reg.c
@@ -475,6 +475,7 @@ static void reg_regdb_apply(struct work_
Index: debian-kernel/net/wireless/reg.c
===================================================================
--- debian-kernel.orig/net/wireless/reg.c
+++ debian-kernel/net/wireless/reg.c
@@ -489,6 +489,7 @@ static void reg_regdb_apply(struct work_
static DECLARE_WORK(reg_regdb_work, reg_regdb_apply);
@ -19,7 +20,7 @@ wireless-regdb to be signed with it.
static int reg_schedule_apply(const struct ieee80211_regdomain *regdom)
{
struct reg_regdb_apply_request *request;
@@ -494,6 +495,7 @@ static int reg_schedule_apply(const stru
@@ -508,6 +509,7 @@ static int reg_schedule_apply(const stru
schedule_work(&reg_regdb_work);
return 0;
}
@ -27,7 +28,7 @@ wireless-regdb to be signed with it.
#ifdef CONFIG_CFG80211_CRDA_SUPPORT
/* Max number of consecutive attempts to communicate with CRDA */
@@ -573,6 +575,29 @@ static inline int call_crda(const char *
@@ -587,6 +589,36 @@ static inline int call_crda(const char *
/* code to directly load a firmware database through request_firmware */
static const struct fwdb_header *regdb;
@ -52,12 +53,19 @@ wireless-regdb to be signed with it.
+ return -ENOENT;
+}
+
+int reg_query_regdb_wmm(char *alpha2, int freq, u32 *dbptr,
+ struct ieee80211_wmm_rule *rule)
+{
+ return -ENODATA;
+}
+EXPORT_SYMBOL(reg_query_regdb_wmm);
+
+#else /* disabled until we update wireless-regdb */
+
struct fwdb_country {
u8 alpha2[2];
__be16 coll_ptr;
@@ -963,6 +988,8 @@ int reg_reload_regdb(void)
@@ -1152,6 +1184,8 @@ int reg_reload_regdb(void)
return err;
}