Fix console selection in PowerPC LPAR environment.

* debian/changelog: Update.
* debian/patches/bugfix/powerpc/lpar-console.patch: Add.
* debian/patches/series/1~experimental.1: Add new patch.

svn path=/dists/trunk/linux-2.6/; revision=11914
This commit is contained in:
Bastian Blank 2008-07-28 19:20:10 +00:00
parent f298d464c4
commit 320ba26f70
3 changed files with 43 additions and 0 deletions

2
debian/changelog vendored
View File

@ -136,6 +136,8 @@ linux-2.6 (2.6.26-1~experimental.1) UNRELEASED; urgency=low
* Reenable SECCOMP. There is no longer additional overhead.
(closes: #474648)
* Export symbol required for MOL again. (closes: #460667)
* [powerpc/powerpc64] Fix console selection in LPAR environment.
(closes: #492703)
[ Christian T. Steigies ]
* [m68k] enable SERIAL_CONSOLE for amiga and atari

View File

@ -0,0 +1,40 @@
diff --git a/arch/powerpc/platforms/pseries/lpar.c b/arch/powerpc/platforms/pseries/lpar.c
index 9235c46..626290d 100644
--- a/arch/powerpc/platforms/pseries/lpar.c
+++ b/arch/powerpc/platforms/pseries/lpar.c
@@ -57,6 +57,7 @@ extern void pSeries_find_serial_port(void);
int vtermno; /* virtual terminal# for udbg */
+static char *console_name;
#define __ALIGNED__ __attribute__((__aligned__(sizeof(long))))
static void udbg_hvsi_putc(char c)
@@ -232,18 +233,24 @@ void __init find_udbg_vterm(void)
udbg_putc = udbg_putcLP;
udbg_getc = udbg_getcLP;
udbg_getc_poll = udbg_getc_pollLP;
- add_preferred_console("hvc", termno[0] & 0xff, NULL);
+ console_name = "hvc";
} else if (of_device_is_compatible(stdout_node, "hvterm-protocol")) {
- vtermno = termno[0];
udbg_putc = udbg_hvsi_putc;
udbg_getc = udbg_hvsi_getc;
udbg_getc_poll = udbg_hvsi_getc_poll;
- add_preferred_console("hvsi", termno[0] & 0xff, NULL);
+ console_name = "hvsi";
}
out:
of_node_put(stdout_node);
}
+static void __init enable_vterm(void)
+{
+ if (console_name)
+ add_preferred_console(console_name, vtermno, NULL);
+}
+arch_initcall(enable_vterm);
+
void vpa_init(int cpu)
{
int hwcpu = get_hard_smp_processor_id(cpu);

View File

@ -64,3 +64,4 @@
+ bugfix/all/sound_hda_intel_dg33.patch
+ features/x86/drivers-hp_ilo.patch
+ bugfix/all/Input-i8042-add-Arima-Rioworks-HDAMB-board-to-nol.patch
+ bugfix/powerpc/lpar-console.patch