[x86] Skip looking for ioapic overrides when ioapics are not present (Closes: #598533)

svn path=/dists/trunk/linux-2.6/; revision=16426
This commit is contained in:
Ben Hutchings 2010-10-10 21:12:51 +00:00
parent 6991dd77f3
commit 30e7656cce
3 changed files with 50 additions and 0 deletions

2
debian/changelog vendored
View File

@ -10,6 +10,8 @@ linux-2.6 (2.6.36~rc7-1~experimental.1) UNRELEASED; urgency=low
* perf: Enable Perl and Python scripting
- Move scripts to /usr/share/perf_<version>-core (Closes: #599624)
* crypto: Explicitly enable algorithm self-tests (Closes: #599441)
* [x86] Skip looking for ioapic overrides when ioapics are not present
(Closes: #598533)
-- Ben Hutchings <ben@decadent.org.uk> Thu, 07 Oct 2010 03:24:21 +0100

View File

@ -0,0 +1,47 @@
Subject: Skip looking for ioapic overrides when ioapics are not present
Date: Sun, 06 Jun 2010 03:56:05 -0000
From: Eric W. Biederman <ebiederm@xmission.com>
Avinash Kurup <kurup.avinash@gmail.com> writes:
> Hi Eric,
>     I get the following errors while booting into 2.6.35-rc1. I did not
> get these in 2.6.34 . The computer however boots and works fine, So its not
> serious but the following errors are displayed in dmesg.
>
> [    0.089969] ERROR: Unable to locate IOAPIC for GSI 13
> [    0.090556] ERROR: Unable to locate IOAPIC for GSI 8
> [    0.091104] ERROR: Unable to locate IOAPIC for GSI 12
> [    0.091375] ERROR: Unable to locate IOAPIC for GSI 1
> [    0.093195] ERROR: Unable to locate IOAPIC for GSI 4
> [    0.094342] ERROR: Unable to locate IOAPIC for GSI 10
> [    0.096335] ERROR: Unable to locate IOAPIC for GSI 6
The new warning originates from acpi_get_override_irq, which I changed to
use helper functions that warn when they fail.
When IOAPICs and ACPI are enabled in a kernel and run on ACPI hardware
that doesn't use the ioapics the pnp acpi code calls this function,
looking for ACPI irq overrides. ACPI irq overrides exist only in the
ioapic case so this function will never succeed. So make the function
fail fast so we don't call into help functions that legitimately
complain when they fail.
Tested-by: Avinash Kurup <kurup.avinash@gmail.com>
Signed-off-by: "Eric W. Biederman" <ebiederm@xmission.com>
[bwh: Add config condition]
---
--- a/arch/x86/kernel/apic/io_apic.c
+++ b/arch/x86/kernel/apic/io_apic.c
@@ -4066,6 +4066,11 @@ int acpi_get_override_irq(u32 gsi, int *trigger, int *polarity)
{
int ioapic, pin, idx;
+#ifdef CONFIG_ACPI
+ if (acpi_irq_model != ACPI_IRQ_MODEL_IOAPIC)
+ return -1;
+#endif
+
if (skip_ioapic_setup)
return -1;

View File

@ -49,3 +49,4 @@
+ bugfix/all/qla4xxx-Fix-build-on-some-architectures-lacking-64-bit-I-O.patch
+ bugfix/all/perf-Use-PERF_EXEC_PATH-in-canned-report-scripts.patch
+ bugfix/all/perf-Fix-detection-of-script-extension.patch
+ bugfix/x86/Skip-looking-for-ioapic-overrides-when-ioapics-are-not-present.patch