[x86] efi: Ensure efi-pstore is loaded on EFI systems

efi-pstore is now a separate module (dependent on efivars).  We still
want it to be auto-loaded to enable crash dumps on EFI systems, so add
another module alias.

While we're at it, explicitly set EFI_VARS_PSTORE=m matching what the
actual configuration will be.

svn path=/dists/sid/linux/; revision=20577
This commit is contained in:
Ben Hutchings 2013-09-08 16:19:58 +00:00
parent f47c6ce282
commit 2fc55f7dc0
3 changed files with 14 additions and 5 deletions

1
debian/changelog vendored
View File

@ -72,6 +72,7 @@ linux (3.10.11-1) UNRELEASED; urgency=low
* aufs: mvdown, don't let unprivileged users provoke a WARNING
* [x86] ACPI: Re-enable ACPI_HOTPLUG_MEMORY as built-in
* [x86] amd64_edac: Fix single-channel setups (Closes: #717473)
* [x86] efi: Ensure efi-pstore is loaded on EFI systems
[ Ian Campbell ]
* [armel]: Enable MVMDIO and USB_EHCI_HCD_ORION on Kirkwood and Orion

View File

@ -410,7 +410,7 @@ CONFIG_EDAC_AMD8111=m
CONFIG_EDD=m
# CONFIG_EDD_OFF is not set
CONFIG_EFI_VARS=m
CONFIG_EFI_VARS_PSTORE=y
CONFIG_EFI_VARS_PSTORE=m
CONFIG_DELL_RBU=m
CONFIG_DCDBAS=m
CONFIG_DMIID=y

View File

@ -6,12 +6,13 @@ Forwarded: no
efivars is generally useful to have on EFI systems, and in some cases
it may be impossible to load it after a kernel upgrade in order to
complete a boot loader update. At the same time we don't want to
waste memory on non-EFI systems by making it built-in.
complete a boot loader update. efi-pstore is similarly useful though
less critical. At the same time we don't want to waste memory on
non-EFI systems by making them built-in.
Instead, give it a module alias as if it's a platform driver, and
Instead, give them module aliases as if they are platform drivers, and
register a corresponding platform device whenever EFI runtime services
are available. This should trigger udev to load it.
are available. This should trigger udev to load them.
---
--- a/arch/x86/platform/efi/efi.c
@ -55,3 +56,10 @@ are available. This should trigger udev to load it.
LIST_HEAD(efivar_sysfs_list);
EXPORT_SYMBOL_GPL(efivar_sysfs_list);
--- a/drivers/firmware/efi/efi-pstore.c
+++ b/drivers/firmware/efi/efi-pstore.c
@@ -250,3 +250,4 @@ module_exit(efivars_pstore_exit);
MODULE_DESCRIPTION("EFI variable backend for pstore");
MODULE_LICENSE("GPL");
+MODULE_ALIAS("platform:efivars");