Update to 3.2.29

svn path=/dists/sid/linux/; revision=19378
This commit is contained in:
Ben Hutchings 2012-09-15 22:26:00 +00:00
parent d4de026a3f
commit 2f89585a47
3 changed files with 22 additions and 34 deletions

25
debian/changelog vendored
View File

@ -1,4 +1,4 @@
linux (3.2.28-1) UNRELEASED; urgency=low
linux (3.2.29-1) UNRELEASED; urgency=low
* New upstream stable update:
http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.2.24
@ -38,7 +38,6 @@ linux (3.2.28-1) UNRELEASED; urgency=low
- ext4: don't let i_reserved_meta_blocks go negative
- ext4: undo ext4_calc_metadata_amount if we fail to claim space
- locks: fix checking of fcntl_setlease argument
- drm/radeon: fix bo creation retry path
- Btrfs: call the ordered free operation without any locks held
http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.2.26
http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.2.27
@ -74,6 +73,27 @@ linux (3.2.28-1) UNRELEASED; urgency=low
- rtlwifi: rtl8192cu: Change buffer allocation for synchronous reads
- hfsplus: fix overflow in sector calculations in hfsplus_submit_bio
- drm/i915: fixup seqno allocation logic for lazy_request
http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.2.29
- pnfs: defer release of pages in layoutget
- fuse: verify all ioctl retry iov elements
- usb: serial: mos7840: Fixup mos7840_chars_in_buffer()
- sched: fix divide by zero at {thread_group,task}_times
- vfs: canonicalize create mode in build_open_flags()
- dccp: check ccid before dereferencing
- md: Don't truncate size at 4TB for RAID0 and Linear
- target: fix NULL pointer dereference bug alloc_page() fails to get memory
- USB: CDC ACM: Fix NULL pointer dereference
- alpha: Don't export SOCK_NONBLOCK to user space. (Closes: #658460)
- radeon: Fix various bugs in reading vbios (Closes: #685604)
- vfs: missed source of ->f_pos races
- svcrpc: fix BUG() in svc_tcp_clear_pages
- svcrpc: sends on closed socket should stop immediately
- fbcon: fix race condition between console lock and cursor timer (v1.1)
- mm: hugetlbfs: correctly populate shared pmd
- fs/buffer.c: remove BUG() in possible but rare condition
- block: replace __getblk_slow misfix by grow_dev_page fix
- Staging: speakup: fix an improperly-declared variable. (Closes: #685953)
- NFS: Fix Oopses in nfs_lookup_revalidate and nfs4_lookup_revalidate
[ Ben Hutchings ]
* Bump ABI to 4
@ -111,7 +131,6 @@ linux (3.2.28-1) UNRELEASED; urgency=low
* [i386/686-pae] video: Disable Geode framebuffer drivers, not used with
any chips that support PAE
* [x86] drm/i915: Fix i8xx interrupt handling (Closes: #655152)
* speakup: Fix crash on 'goto' operation (Closes: #685953)
* [armel/kirkwood] ahci: Add JMicron 362 device IDs (Closes: #634180)
* speakup: lower default software speech rate (Closes: #686742)

View File

@ -1,30 +0,0 @@
From: Christopher Brannon <chris@the-brannons.com>
Date: Sat, 16 Jun 2012 16:55:20 -0500
Subject: Staging: speakup: fix an improperly-declared variable.
commit 4ea418b8b2fa8a70d0fcc8231b65e67b3a72984b upstream.
A local static variable was declared as a pointer to a string
constant. We're assigning to the underlying memory, so it
needs to be an array instead.
Signed-off-by: Christopher Brannon <chris@the-brannons.com>
Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
drivers/staging/speakup/main.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/speakup/main.c b/drivers/staging/speakup/main.c
index 92b34e2..40e2488 100644
--- a/drivers/staging/speakup/main.c
+++ b/drivers/staging/speakup/main.c
@@ -1854,7 +1854,7 @@ static void speakup_bits(struct vc_data *vc)
static int handle_goto(struct vc_data *vc, u_char type, u_char ch, u_short key)
{
- static u_char *goto_buf = "\0\0\0\0\0\0";
+ static u_char goto_buf[8];
static int num;
int maxlen, go_pos;
char *cp;

View File

@ -394,6 +394,5 @@ bugfix/all/usb-Add-quirk-detection-based-on-interface-informati.patch
bugfix/all/usb-Add-USB_QUIRK_RESET_RESUME-for-all-Logitech-UVC-.patch
bugfix/alpha/alpha-use-large-data-model.diff
bugfix/x86/drm-i915-i8xx-interrupt-handler.patch
bugfix/all/staging-speakup-fix-an-improperly-declared-variable.patch
features/arm/ahci-Add-JMicron-362-device-IDs.patch
bugfix/all/speakup-lower-default-software-speech-rate.patch