m68k updates, if the spinlock patch breaks your arch, I'll have to add it to the m68k.diff

svn path=/dists/trunk/linux-2.6/; revision=4753
This commit is contained in:
Christian T. Steigies 2005-11-08 23:10:57 +00:00
parent 2830b2982c
commit 2f60f00ed2
9 changed files with 3206 additions and 144 deletions

View File

@ -348,3 +348,7 @@ CONFIG_CRC_CCITT=m
CONFIG_LIBCRC32C=m
CONFIG_ZLIB_INFLATE=y
CONFIG_ZLIB_DEFLATE=m
CONFIG_IEEE80211_CRYPT_CCMP=n
CONFIG_IEEE80211_CRYPT_TKIP=n
CONFIG_IEEE80211_CRYPT_WEP=n
CONFIG_IEEE80211=n

View File

@ -58,7 +58,7 @@ CONFIG_IPDDP_DECAP=y
CONFIG_NET_ETHERNET=y
CONFIG_MAC8390=y
CONFIG_MAC89x0=y
CONFIG_MACSONIC=y
CONFIG_MACSONIC=n # does not compile at the moment
CONFIG_MACMACE=y
# CONFIG_NET_VENDOR_SMC is not set
CONFIG_PPP_FILTER=y

6
debian/changelog vendored
View File

@ -32,6 +32,12 @@ linux-2.6 (2.6.14-3) UNRELEASED; urgency=low
* net-ipconntrack-nat-fix.patch - fix compilation of
ip_conntrack_helper_pptp.c when NAT is disabled. (Closes: #336431)
[ Christian T. Steigies ]
* update m68k.diff to 2.6.14
* add m68k-*vme* patches
* disable macsonic driver until the dma patch is fixed
* disable IEEE80211 drivers for all of m68k
-- Simon Horman <horms@debian.org> Mon, 7 Nov 2005 18:17:47 +0900
linux-2.6 (2.6.14-2) unstable; urgency=low

File diff suppressed because it is too large Load Diff

10
debian/patches-debian/m68k-bvme.patch vendored Normal file
View File

@ -0,0 +1,10 @@
--- linux-2.6-2.6.14/arch/m68k/bvme6000/bvmeints.c.orig 2005-10-28 02:02:08.000000000 +0200
+++ linux-2.6-2.6.14/arch/m68k/bvme6000/bvmeints.c 2005-11-07 21:35:32.000000000 +0100
@@ -15,6 +15,7 @@
#include <linux/kernel.h>
#include <linux/errno.h>
#include <linux/seq_file.h>
+#include <linux/interrupt.h>
#include <asm/ptrace.h>
#include <asm/system.h>

View File

@ -0,0 +1,10 @@
--- linux-2.6-2.6.14/arch/m68k/mvme147/147ints.c.orig 2005-10-28 02:02:08.000000000 +0200
+++ linux-2.6-2.6.14/arch/m68k/mvme147/147ints.c 2005-11-08 08:31:05.000000000 +0100
@@ -15,6 +15,7 @@
#include <linux/kernel.h>
#include <linux/errno.h>
#include <linux/seq_file.h>
+#include <linux/interrupt.h>
#include <asm/ptrace.h>
#include <asm/system.h>

View File

@ -0,0 +1,10 @@
--- linux-2.6-2.6.14/arch/m68k/mvme16x/16xints.c.orig 2005-10-28 02:02:08.000000000 +0200
+++ linux-2.6-2.6.14/arch/m68k/mvme16x/16xints.c 2005-11-08 08:32:28.000000000 +0100
@@ -15,6 +15,7 @@
#include <linux/kernel.h>
#include <linux/errno.h>
#include <linux/seq_file.h>
+#include <linux/interrupt.h>
#include <asm/system.h>
#include <asm/ptrace.h>

View File

@ -0,0 +1,33 @@
--- linux-2.6-2.6.14/kernel/audit.c.orig 2005-10-28 02:02:08.000000000 +0200
+++ linux-2.6-2.6.14/kernel/audit.c 2005-11-08 22:29:43.000000000 +0100
@@ -41,6 +41,7 @@
* Example user-space utilities: http://people.redhat.com/sgrubb/audit/
*/
+#include <linux/spinlock.h>
#include <linux/init.h>
#include <asm/atomic.h>
#include <asm/types.h>
--- linux-2.6-2.6.14/include/linux/dcache.h.orig 2005-10-28 02:02:08.000000000 +0200
+++ linux-2.6-2.6.14/include/linux/dcache.h 2005-11-08 22:19:45.000000000 +0100
@@ -3,9 +3,9 @@
#ifdef __KERNEL__
+#include <linux/spinlock.h>
#include <asm/atomic.h>
#include <linux/list.h>
-#include <linux/spinlock.h>
#include <linux/cache.h>
#include <linux/rcupdate.h>
#include <asm/bug.h>
--- linux-2.6-2.6.14/drivers/md/kcopyd.c.orig 2005-10-28 02:02:08.000000000 +0200
+++ linux-2.6-2.6.14/drivers/md/kcopyd.c 2005-11-08 22:46:17.000000000 +0100
@@ -8,6 +8,7 @@
* completion notification.
*/
+#include <linux/spinlock.h>
#include <asm/atomic.h>
#include <linux/blkdev.h>

View File

@ -1,2 +1,6 @@
+ net-ipconntrack-nat-fix.patch
+ net-nf_queue-oops.patch
+ m68k-bvme.patch
+ m68k-mvme147.patch
+ m68k-mvme16x.patch
+ m68k-spinlock.patch