drm/i915: give up on 8xx lid status

add patch tracked by stable 2.6.32 regressions,
queued for linus.

svn path=/dists/sid/linux-2.6/; revision=15256
This commit is contained in:
Maximilian Attems 2010-02-22 10:37:51 +00:00
parent 1031e46442
commit 2f5c47eb63
3 changed files with 37 additions and 0 deletions

1
debian/changelog vendored
View File

@ -28,6 +28,7 @@ linux-2.6 (2.6.32-9) UNRELEASED; urgency=low
* r8169 patch for rx length check errors. (CVE-2009-4537)
* vgaarb: fix incorrect dereference of userspace pointer.
* Bump ABI to 3.
* drm/i915: give up on 8xx lid status.
[ Bastian Blank ]
* Restrict access to sensitive SysRq keys by default.

View File

@ -0,0 +1,35 @@
From patchwork Fri Feb 12 17:30:00 2010
Content-Type: text/plain; charset="utf-8"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
Subject: drm/i915: give up on 8xx lid status
Date: Fri, 12 Feb 2010 17:30:00 -0000
From: Jesse Barnes <jbarnes@virtuousgeek.org>
X-Patchwork-Id: 78947
Message-Id: <20100212093000.5cead4da@jbarnes-piketon>
To: intel-gfx@lists.freedesktop.org, eric@anholt.net
These old machines more often than not lie about their lid state. So
don't use it to detect LVDS presence, but leave the event handler to
deal with lid open/close, when we might need to reset the mode.
Signed-off-by: Jesse Barnes <jbarnes@virtuousgeek.org>
diff --git a/drivers/gpu/drm/i915/intel_lvds.c b/drivers/gpu/drm/i915/intel_lvds.c
index 75a9772..9f4855b 100644
--- a/drivers/gpu/drm/i915/intel_lvds.c
+++ b/drivers/gpu/drm/i915/intel_lvds.c
@@ -641,8 +641,12 @@ static const struct dmi_system_id bad_lid_status[] = {
*/
static enum drm_connector_status intel_lvds_detect(struct drm_connector *connector)
{
+ struct drm_device *dev = connector->dev;
enum drm_connector_status status = connector_status_connected;
+ if (IS_I8XX(dev))
+ return connector_status_connected;
+
if (!acpi_lid_open() && !dmi_check_system(bad_lid_status))
status = connector_status_disconnected;

View File

@ -18,3 +18,4 @@
+ bugfix/all/sfc-Fix-sign-of-efx_mcdi_poll_reboot-error-in-efx_mcdi_poll.patch
+ bugfix/all/sfc-SFE4002-SFN4112F-Widen-temperature-voltage-tolerances.patch
+ features/all/ath9k-add-support-for-802.11n-bonded-out-AR2427.patch
+ bugfix/all/drm-i915-give-up-on-8xx-lid-status.patch