Partially revert "usb: Kconfig: using select for USB_COMMON dependency"

It causes USB_COMMON to be built-in for no good reason.
This commit is contained in:
Ben Hutchings 2017-01-11 04:34:58 +00:00
parent 7a737f217d
commit 2ebf1235ed
3 changed files with 31 additions and 0 deletions

2
debian/changelog vendored
View File

@ -22,6 +22,8 @@ linux (4.9.2-1~exp1) UNRELEASED; urgency=medium
* drm: Enable DRM_LEGACY; re-enable DRM_TDFX, DRM_R128, DRM_MGA, DRM_SIS,
DRM_VIA, DRM_SAVAGE as modules for some architectures
* 8250: Disable SERIAL_8250_LPSS, since it causes DW_DMAC_CORE to be built-in
* Partially revert "usb: Kconfig: using select for USB_COMMON dependency",
since it causes USB_COMMON to be built-in
[ John Paul Adrian Glaubitz ]
* [sh3] Build a linux-libc-dev package (Closes: #850732)

View File

@ -0,0 +1,28 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Wed, 11 Jan 2017 04:30:40 +0000
Subject: Partially revert "usb: Kconfig: using select for USB_COMMON dependency"
This reverts commit cb9c1cfc86926d0e86d19c8e34f6c23458cd3478 for
USB_LED_TRIG. This config symbol has bool type and enables extra code
in usb_common itself, not a separate driver. Enabling it should not
force usb_common to be built-in!
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
drivers/usb/Kconfig | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/drivers/usb/Kconfig b/drivers/usb/Kconfig
index 644e978cbd3e..989c6208678f 100644
--- a/drivers/usb/Kconfig
+++ b/drivers/usb/Kconfig
@@ -152,8 +152,7 @@ source "drivers/usb/gadget/Kconfig"
config USB_LED_TRIG
bool "USB LED Triggers"
- depends on LEDS_CLASS && LEDS_TRIGGERS
- select USB_COMMON
+ depends on LEDS_CLASS && USB_COMMON && LEDS_TRIGGERS
help
This option adds LED triggers for USB host and/or gadget activity.

View File

@ -63,6 +63,7 @@ bugfix/all/fs-add-module_softdep-declarations-for-hard-coded-cr.patch
bugfix/all/kbuild-do-not-use-hyphen-in-exported-variable-name.patch
bugfix/all/ext4-fix-bug-838544.patch
bugfix/all/mm-memcontrol-use-special-workqueue-for-creating-per-memcg-caches.patch
bugfix/all/partially-revert-usb-kconfig-using-select-for-usb_co.patch
# Miscellaneous features