debian/patches/arm-fix-dc21285.patch: Fix compilation errors in

drivers/mtd/maps/dc21285.c.

svn path=/dists/trunk/linux-2.6/; revision=5399
This commit is contained in:
Martin Michlmayr 2006-01-10 23:24:25 +00:00
parent 136a7fe8aa
commit 2e8f91dc35
3 changed files with 43 additions and 0 deletions

2
debian/changelog vendored
View File

@ -9,6 +9,8 @@ linux-2.6 (2.6.15-3) UNRELEASED; urgency=low
NE2K).
* [arm] Allow modules to be unloaded.
* [arm] Enable more framebuffer drivers on Footbridge.
* debian/patches/arm-fix-dc21285.patch: Fix compilation errors in
drivers/mtd/maps/dc21285.c.
-- Martin Michlmayr <tbm@cyrius.com> Tue, 10 Jan 2006 22:59:19 +0000

40
debian/patches/arm-fix-dc21285.patch vendored Normal file
View File

@ -0,0 +1,40 @@
## DP: Fix compilation errors in dc21285.c
## DP: Patch author: Martin Michlmayr <tbm@cyrius.com>
## DP: Upstream status: Submitted
#
--- old/drivers/mtd/maps/dc21285.c~ 2006-01-10 19:40:53.000000000 +0000
+++ new/drivers/mtd/maps/dc21285.c 2006-01-10 19:52:14.000000000 +0000
@@ -110,8 +110,9 @@
{
while (len > 0) {
map_word d;
- d.x[0] = *((uint32_t*)from)++;
+ d.x[0] = *((uint32_t*)from);
dc21285_write32(map, d, to);
+ from += 4;
to += 4;
len -= 4;
}
@@ -121,8 +122,9 @@
{
while (len > 0) {
map_word d;
- d.x[0] = *((uint16_t*)from)++;
+ d.x[0] = *((uint16_t*)from);
dc21285_write16(map, d, to);
+ from += 2;
to += 2;
len -= 2;
}
@@ -131,8 +133,9 @@
static void dc21285_copy_to_8(struct map_info *map, unsigned long to, const void *from, ssize_t len)
{
map_word d;
- d.x[0] = *((uint8_t*)from)++;
+ d.x[0] = *((uint8_t*)from);
dc21285_write8(map, d, to);
+ from++;
to++;
len--;
}

View File

@ -21,4 +21,5 @@
+ powerpc-mv643xx-spinlock-fix-support.patch
+ powerpc-prep-utah-ide-interrupt.patch
+ powerpc-mv643xx-hotplug-support.patch
+ arm-fix-dc21285.patch