add input bugfix

svn path=/dists/trunk/linux-2.6/; revision=11892
This commit is contained in:
Maximilian Attems 2008-07-23 22:56:55 +00:00
parent afb53ee287
commit 2da8978ba5
3 changed files with 39 additions and 0 deletions

2
debian/changelog vendored
View File

@ -75,6 +75,8 @@ linux-2.6 (2.6.26-1~experimental.1) UNRELEASED; urgency=low
* [ALSA] hda - Add ICH9 controller support (8086:2911)
* [ALSA] hda - support intel DG33 motherboards
* HP iLO driver
* Input: i8042 - add Arima-Rioworks HDAMB board to noloop list
(closes: #489190) thanks Guillaume Morin <guillaume@morinfr.org>
[ Martin Michlmayr ]
* [arm/orion5x] Update the config to reflect upstream renaming this

View File

@ -0,0 +1,36 @@
From 87d9173ea0c820021cf49e4c675b3821cfb4f0eb Mon Sep 17 00:00:00 2001
From: Dmitry Torokhov <dmitry.torokhov@gmail.com>
Date: Sat, 19 Jul 2008 00:35:43 -0400
Subject: [PATCH] Input: i8042 - add Arima-Rioworks HDAMB board to noloop list
The board does not raise AUX IRQ in response to AUX LOOP command.
Reported-by: Guillaume Morin <guillaume@morinfr.org>
Signed-off-by: Dmitry Torokhov <dtor@mail.ru>
---
drivers/input/serio/i8042-x86ia64io.h | 9 +++++++++
1 files changed, 9 insertions(+), 0 deletions(-)
diff --git a/drivers/input/serio/i8042-x86ia64io.h b/drivers/input/serio/i8042-x86ia64io.h
index 5d46d64..fe732a5 100644
--- a/drivers/input/serio/i8042-x86ia64io.h
+++ b/drivers/input/serio/i8042-x86ia64io.h
@@ -70,6 +70,15 @@ static inline void i8042_write_command(int val)
static struct dmi_system_id __initdata i8042_dmi_noloop_table[] = {
{
/* AUX LOOP command does not raise AUX IRQ */
+ .ident = "Arima-Rioworks HDAMB",
+ .matches = {
+ DMI_MATCH(DMI_BOARD_VENDOR, "RIOWORKS"),
+ DMI_MATCH(DMI_BOARD_NAME, "HDAMB"),
+ DMI_MATCH(DMI_BOARD_VERSION, "Rev E"),
+ },
+ },
+ {
+ /* AUX LOOP command does not raise AUX IRQ */
.ident = "ASUS P65UP5",
.matches = {
DMI_MATCH(DMI_BOARD_VENDOR, "ASUSTeK Computer INC."),
--
1.5.6.2

View File

@ -60,3 +60,4 @@
+ bugfix/all/sound_hda_ich9.patch
+ bugfix/all/sound_hda_intel_dg33.patch
+ features/all/drivers-hp_ilo.patch
+ bugfix/all/Input-i8042-add-Arima-Rioworks-HDAMB-board-to-nol.patch