UAPI: include <asm/byteorder.h> in linux/raid/md_p.h.

svn path=/dists/sid/linux/; revision=20760
This commit is contained in:
Aurelien Jarno 2013-10-30 15:30:07 +00:00
parent 565dc3ec81
commit 2b65b3949c
3 changed files with 35 additions and 0 deletions

4
debian/changelog vendored
View File

@ -1,10 +1,14 @@
linux (3.11.6-2) UNRELEASED; urgency=low
[ Ben Hutchings ]
* [sh4] Reduce compiler version to gcc-4.7, as gcc-4.8 is not yet
available
* [ia64] Reduce compiler version to gcc-4.6, matching gcc-defaults
(fixes FTBFS)
[ Aurelien Jarno ]
* UAPI: include <asm/byteorder.h> in linux/raid/md_p.h.
-- Ben Hutchings <ben@decadent.org.uk> Tue, 29 Oct 2013 14:36:09 +0000
linux (3.11.6-1) unstable; urgency=low

View File

@ -0,0 +1,30 @@
From: Aurelien Jarno <aurelien@aurel32.net>
Date: Tue, 29 Oct 2013 11:55:17 +0100
Subject: [PATCH] UAPI: include <asm/byteorder.h> in linux/raid/md_p.h
Forwarded: http://comments.gmane.org/gmane.linux.kernel/1586604
linux/raid/md_p.h is using conditionals depending on endianess and fails
with an error if neither of __BIG_ENDIAN, __LITTLE_ENDIAN or
__BYTE_ORDER are defined, but it doesn't include any header which can
define these constants. This make this header unusable alone.
This patch adds a #include <asm/byteorder.h> at the beginning of this
header to make it usable alone. This is needed to compile klibc on MIPS.
Signed-off-by: Aurelien Jarno <aurelien@aurel32.net>
---
include/uapi/linux/raid/md_p.h | 1 +
1 file changed, 1 insertion(+)
diff --git a/include/uapi/linux/raid/md_p.h b/include/uapi/linux/raid/md_p.h
index fe1a540..f7cf7f3 100644
--- a/include/uapi/linux/raid/md_p.h
+++ b/include/uapi/linux/raid/md_p.h
@@ -16,6 +16,7 @@
#define _MD_P_H
#include <linux/types.h>
+#include <asm/byteorder.h>
/*
* RAID superblock.

View File

@ -79,3 +79,4 @@ bugfix/m68k/atari-irqs.patch
bugfix/all/crypto-ansi_cprng-Fix-off-by-one-error-in-non-block-.patch
features/all/mvsas-Recognise-device-subsystem-9485-9485-as-88SE94.patch
bugfix/all/kbuild-use-nostdinc-in-compile-tests.patch
bugfix/all/UAPI-include-asm-byteorder.h-in-linux-raid-md_p.h.patch