Update to 4.3-rc5

This commit is contained in:
Ben Hutchings 2015-10-13 22:02:43 +01:00
parent 81a7a029f9
commit 2b5f419b85
3 changed files with 3 additions and 78 deletions

5
debian/changelog vendored
View File

@ -1,6 +1,7 @@
linux-tools (4.3~rc4-1~exp2) UNRELEASED; urgency=medium
linux-tools (4.3~rc5-1~exp1) UNRELEASED; urgency=medium
* perf: Fix build on architectures without CONFIG_PERF_REGS
* New upstream release candidate
- perf: Fix build on architectures without CONFIG_PERF_REGS
-- Ben Hutchings <ben@decadent.org.uk> Thu, 08 Oct 2015 17:54:09 +0100

View File

@ -1,75 +0,0 @@
From: Sukadev Bhattiprolu <sukadev@linux.vnet.ibm.com>
Date: Thu, 24 Sep 2015 17:53:49 -0400
Subject: perf tools: Fix build break on powerpc due to sample_reg_masks
Origin: https://git.kernel.org/cgit/linux/kernel/git/tip/tip.git/commit?id=9fb4765451f22c5e782c1590747717550bff34b2
perf_regs.c does not get built on Powerpc as CONFIG_PERF_REGS is false.
So the weak definition for 'sample_regs_masks' doesn't get picked up.
Adding perf_regs.o to util/Build unconditionally, exposes a redefinition
error for 'perf_reg_value()' function (due to the static inline version
in util/perf_regs.h). So use #ifdef HAVE_PERF_REGS_SUPPORT' around that
function.
Signed-off-by: Sukadev Bhattiprolu <sukadev@linux.vnet.ibm.com>
Acked-by: Jiri Olsa <jolsa@kernel.org>
Cc: Naveen N. Rao <naveen.n.rao@linux.vnet.ibm.com>
Cc: Stephane Eranian <eranian@google.com>
Cc: linuxppc-dev@ozlabs.org
Link: http://lkml.kernel.org/r/20150930182836.GA27858@us.ibm.com
Signed-off-by: Arnaldo Carvalho de Melo <acme@redhat.com>
---
tools/perf/util/Build | 2 +-
tools/perf/util/perf_regs.c | 2 ++
tools/perf/util/perf_regs.h | 1 +
3 files changed, 4 insertions(+), 1 deletion(-)
diff --git a/tools/perf/util/Build b/tools/perf/util/Build
index 349bc96..e5f18a2 100644
--- a/tools/perf/util/Build
+++ b/tools/perf/util/Build
@@ -17,6 +17,7 @@ libperf-y += levenshtein.o
libperf-y += llvm-utils.o
libperf-y += parse-options.o
libperf-y += parse-events.o
+libperf-y += perf_regs.o
libperf-y += path.o
libperf-y += rbtree.o
libperf-y += bitmap.o
@@ -103,7 +104,6 @@ libperf-$(CONFIG_LIBBABELTRACE) += data-convert-bt.o
libperf-y += scripting-engines/
-libperf-$(CONFIG_PERF_REGS) += perf_regs.o
libperf-$(CONFIG_ZLIB) += zlib.o
libperf-$(CONFIG_LZMA) += lzma.o
diff --git a/tools/perf/util/perf_regs.c b/tools/perf/util/perf_regs.c
index 885e8ac..6b8eb13 100644
--- a/tools/perf/util/perf_regs.c
+++ b/tools/perf/util/perf_regs.c
@@ -6,6 +6,7 @@ const struct sample_reg __weak sample_reg_masks[] = {
SMPL_REG_END
};
+#ifdef HAVE_PERF_REGS_SUPPORT
int perf_reg_value(u64 *valp, struct regs_dump *regs, int id)
{
int i, idx = 0;
@@ -29,3 +30,4 @@ out:
*valp = regs->cache_regs[id];
return 0;
}
+#endif
diff --git a/tools/perf/util/perf_regs.h b/tools/perf/util/perf_regs.h
index 2984dcc..679d6e4 100644
--- a/tools/perf/util/perf_regs.h
+++ b/tools/perf/util/perf_regs.h
@@ -2,6 +2,7 @@
#define __PERF_REGS_H
#include <linux/types.h>
+#include <linux/compiler.h>
struct regs_dump;

View File

@ -15,4 +15,3 @@ tools-lib-lockdep-use-ldflags.patch
tools-hv-fix-fortify-format-warning.patch
revert-perf-build-fix-libunwind-feature-detection-on.patch
alpha-uapi-add-support-for-__sane_userspace_types__.patch
perf-tools-fix-build-break-on-powerpc-due-to-sample_.patch