init: Avoid ABI change for build salt

This commit is contained in:
Ben Hutchings 2018-07-15 23:45:49 +01:00
parent ba1733832f
commit 29f1a23722
3 changed files with 26 additions and 0 deletions

1
debian/changelog vendored
View File

@ -14,6 +14,7 @@ linux (4.17.6-2) UNRELEASED; urgency=medium
- kbuild: Add build salt to the kernel and modules
- [arm64,powerpc,x86] Add build salt to the vDSO
- Set BUILD_SALT equal to the release string
* init: Avoid ABI change for build salt
[ Vagrant Cascadian ]
* [riscv64] Build linux-libc-dev (Closes: #886440).

View File

@ -0,0 +1,24 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Sun, 15 Jul 2018 23:44:02 +0100
Subject: init: Avoid ABI change for build salt
Forwarded: not-needed
<linux/build-salt.h> indirectly includes <linux/elf.h>, which
apparently adds some type definitions that change the symbol
version for init_uts_ns.
Hide this change from genksyms.
---
--- a/init/version.c
+++ b/init/version.c
@@ -7,7 +7,9 @@
*/
#include <generated/compile.h>
+#ifndef __GENKSYMS__
#include <linux/build-salt.h>
+#endif
#include <linux/export.h>
#include <linux/uts.h>
#include <linux/utsname.h>

View File

@ -161,3 +161,4 @@ debian/wireless-disable-regulatory.db-direct-loading.patch
# ABI maintenance
debian/hid-avoid-abi-change-in-4.17.6.patch
debian/dax-avoid-abi-change-in-4.17.6.patch
debian/init-avoid-abi-change-for-build-salt.patch