Update to 4.11.11

This commit is contained in:
Ben Hutchings 2017-07-16 21:22:27 +01:00
parent 951507e517
commit 292c881344
3 changed files with 34 additions and 39 deletions

35
debian/changelog vendored
View File

@ -1,4 +1,4 @@
linux (4.11.9-1) UNRELEASED; urgency=medium
linux (4.11.11-1) UNRELEASED; urgency=medium
* New upstream stable update:
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.11.7
@ -220,6 +220,39 @@ linux (4.11.9-1) UNRELEASED; urgency=medium
- KVM: nVMX: Fix exception injection
- esp4: Fix udpencap for local TCP packets.
- [armhf] hsi: Fix build regression due to netdev destructor fix.
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.11.10
- fs: completely ignore unknown open flags
- driver core: platform: fix race condition with driver_override
- RDMA/uverbs: Check port number supplied by user verbs cmds
- ceph: choose readdir frag based on previous readdir reply
- tracing/kprobes: Allow to create probe with a module name starting with a
digit
- drm/virtio: don't leak bo on drm_gem_object_init failure (CVE-2017-10810)
- usb: dwc3: replace %p with %pK
- Add USB quirk for HVR-950q to avoid intermittent device resets
- usb: usbip: set buffer pointers to NULL after free
- usb: Fix typo in the definition of Endpoint[out]Request
- USB: core: fix device node leak
- [armhf] pinctrl: meson: meson8b: fix the NAND DQS pins
- [armhf,arm64] pinctrl: sunxi: Fix SPDIF function name for A83T
- pinctrl: core: Fix warning by removing bogus code
- [x86] xhci: Limit USB2 port wake support for AMD Promontory hosts
- gfs2: Fix glock rhashtable rcu bug
- Add "shutdown" to "struct class".
- tpm: Issue a TPM2_Shutdown for TPM2 devices.
- tpm: fix a kernel memory leak in tpm-sysfs.c
- [x86] uaccess: Optimize copy_user_enhanced_fast_string() for short strings
- xen: avoid deadlock in xenbus driver
- crypto: drbg - Fixes panic in wait_for_completion call
- [x86] rt286: add Thinkpad Helix 2 to force_combo_jack_table
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.11.11
- mqueue: fix a use-after-free in sys_mq_notify() (CVE-2017-11176)
- proc: Fix proc_sys_prune_dcache to hold a sb reference
- locking/rwsem-spinlock: Fix EINTR branch in __down_write_common()
- [x86] staging: comedi: fix clean-up of comedi_class in comedi_init()
- crypto: rsa-pkcs1pad - use constant time memory comparison for MACs
- ext4: check return value of kstrtoull correctly in reserved_clusters_store
- [x86] mm/pat: Don't report PAT on CPUs that don't support it
[ Ben Hutchings ]
* [m68k] udeb: Use only the common module list for nic-shared-modules

View File

@ -1,37 +0,0 @@
From: Johan Hovold <johan@kernel.org>
Date: Mon, 12 Jun 2017 16:30:16 +0200
Subject: USB: serial: option: add two Longcheer device ids
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Origin: https://git.kernel.org/pub/scm/linux/kernel/git/johan/usb-serial.git/commit?id=8fb060da715ad10fe956d7c0077b2fb0c12bb9d7
Bug-Debian: https://bugs.debian.org/864604
Add two Longcheer device-id entries which specifically enables a
Telewell TW-3G HSPA+ branded modem (0x9801).
Reported-by: Teemu Likonen <tlikonen@iki.fi>
Reported-by: Bjørn Mork <bjorn@mork.no>
Reported-by: Lars Melin <larsm17@gmail.com>
Tested-by: Teemu Likonen <tlikonen@iki.fi>
Cc: stable <stable@vger.kernel.org>
Signed-off-by: Johan Hovold <johan@kernel.org>
---
drivers/usb/serial/option.c | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/drivers/usb/serial/option.c b/drivers/usb/serial/option.c
index 3bf61acfc26b..ebe51f11105d 100644
--- a/drivers/usb/serial/option.c
+++ b/drivers/usb/serial/option.c
@@ -1877,6 +1877,10 @@ static const struct usb_device_id option_ids[] = {
.driver_info = (kernel_ulong_t)&four_g_w100_blacklist
},
{ USB_DEVICE_INTERFACE_CLASS(LONGCHEER_VENDOR_ID, SPEEDUP_PRODUCT_SU9800, 0xff) },
+ { USB_DEVICE_INTERFACE_CLASS(LONGCHEER_VENDOR_ID, 0x9801, 0xff),
+ .driver_info = (kernel_ulong_t)&net_intf3_blacklist },
+ { USB_DEVICE_INTERFACE_CLASS(LONGCHEER_VENDOR_ID, 0x9803, 0xff),
+ .driver_info = (kernel_ulong_t)&net_intf4_blacklist },
{ USB_DEVICE(LONGCHEER_VENDOR_ID, ZOOM_PRODUCT_4597) },
{ USB_DEVICE(LONGCHEER_VENDOR_ID, IBALL_3_5G_CONNECT) },
{ USB_DEVICE(HAIER_VENDOR_ID, HAIER_PRODUCT_CE100) },

View File

@ -69,7 +69,6 @@ bugfix/all/partially-revert-usb-kconfig-using-select-for-usb_co.patch
bugfix/all/kbuild-include-addtree-remove-quotes-before-matching-path.patch
# Miscellaneous features
features/all/usb-serial-option-add-two-longcheer-device-ids.patch
# Lockdown (formerly 'securelevel') patchset
features/all/lockdown/0001-Annotate-module-params-that-specify-hardware-paramet.patch